From: "Roger Pau Monné" <roger.pau@citrix.com>
To: Julien Grall <julien@xen.org>
Cc: xen-devel@lists.xenproject.org, Julien Grall <jgrall@amazon.com>,
Wei Liu <wl@xen.org>, Jan Beulich <jbeulich@suse.com>,
Andrew Cooper <andrew.cooper3@citrix.com>
Subject: Re: [Xen-devel] [PATCH 2/3] xen/x86: ioapic: Rename init_ioapic_mappings() to init_ioapic()
Date: Mon, 30 Mar 2020 12:37:24 +0200 [thread overview]
Message-ID: <20200330103724.GQ28601@Air-de-Roger> (raw)
In-Reply-To: <20200327190546.21580-3-julien@xen.org>
On Fri, Mar 27, 2020 at 07:05:45PM +0000, Julien Grall wrote:
> From: Julien Grall <jgrall@amazon.com>
>
> The function init_ioapic_mappings() is doing more than initialization
> mappings. It is also initialization the number of IRQs/GSIs supported.
>
> So rename the function to init_ioapic(). This will allow us to re-use
> the name in a follow-up patch.
>
> Signed-off-by: Julien Grall <jgrall@amazon.com>
Reviewed-by: Roger Pau Monné <roger.pau@citrix.com>
I've got one comment/request however.
> ---
> xen/arch/x86/apic.c | 2 +-
> xen/arch/x86/io_apic.c | 2 +-
> xen/include/asm-x86/io_apic.h | 2 +-
> 3 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/xen/arch/x86/apic.c b/xen/arch/x86/apic.c
> index cde67cd87e..c7a54cafc3 100644
> --- a/xen/arch/x86/apic.c
> +++ b/xen/arch/x86/apic.c
> @@ -978,7 +978,7 @@ __next:
> boot_cpu_physical_apicid = get_apic_id();
> x86_cpu_to_apicid[0] = get_apic_id();
>
> - init_ioapic_mappings();
> + init_ioapic();
I would rename this to ioapic_init instead since you are already
changing it. I usually prefer the subsystem name to be prefixed to the
action the function performs instead of the other way around.
Thanks, Roger.
next prev parent reply other threads:[~2020-03-30 10:37 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-03-27 19:05 [Xen-devel] [PATCH 0/3] xen/x86: Simplify ioapic_init() Julien Grall
2020-03-27 19:05 ` [Xen-devel] [PATCH 1/3] xen/x86: ioapic: Use true/false in bad_ioapic_register() Julien Grall
2020-03-28 11:01 ` Wei Liu
2020-03-31 11:05 ` Jan Beulich
2020-03-27 19:05 ` [Xen-devel] [PATCH 2/3] xen/x86: ioapic: Rename init_ioapic_mappings() to init_ioapic() Julien Grall
2020-03-30 10:37 ` Roger Pau Monné [this message]
2020-03-30 12:55 ` Julien Grall
2020-03-31 11:08 ` Jan Beulich
2020-03-27 19:05 ` [Xen-devel] [PATCH 3/3] xen/x86: ioapic: Simplify ioapic_init() Julien Grall
2020-03-29 14:35 ` Wei Liu
2020-03-29 15:54 ` Julien Grall
2020-03-30 10:43 ` Roger Pau Monné
2020-03-30 12:56 ` Julien Grall
2020-03-31 11:22 ` Jan Beulich
2020-03-31 11:51 ` Julien Grall
2020-03-31 12:12 ` Jan Beulich
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200330103724.GQ28601@Air-de-Roger \
--to=roger.pau@citrix.com \
--cc=andrew.cooper3@citrix.com \
--cc=jbeulich@suse.com \
--cc=jgrall@amazon.com \
--cc=julien@xen.org \
--cc=wl@xen.org \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.