All of lore.kernel.org
 help / color / mirror / Atom feed
From: Roger Pau Monne <roger.pau@citrix.com>
To: <linux-kernel@vger.kernel.org>
Cc: xen-devel@lists.xenproject.org, Roger Pau Monne <roger.pau@citrix.com>
Subject: [PATCH v4 0/2] xen/balloon: fixes for memory hotplug
Date: Tue, 11 Aug 2020 11:44:45 +0200	[thread overview]
Message-ID: <20200811094447.31208-1-roger.pau@citrix.com> (raw)

Hello,

The following series contain some fixes in order to split Xen
unpopulated memory handling from the ballooning driver if ZONE_DEVICE is
available, so that physical memory regions used to map foreign pages are
not tied to memory hotplug.

The main difference in this version is that MEMORY_DEVICE_DEVDAX is
renamed to MEMORY_DEVICE_GENERIC, as using DEVDAX in the Xen code to
allocate unpopulated memory felt wrong.

Thanks, Roger.

Roger Pau Monne (2):
  memremap: rename MEMORY_DEVICE_DEVDAX to MEMORY_DEVICE_GENERIC
  xen: add helpers to allocate unpopulated memory

 drivers/dax/device.c                    |   2 +-
 drivers/gpu/drm/xen/xen_drm_front_gem.c |   9 +-
 drivers/xen/Kconfig                     |   4 +
 drivers/xen/Makefile                    |   1 +
 drivers/xen/balloon.c                   |   4 +-
 drivers/xen/grant-table.c               |   4 +-
 drivers/xen/privcmd.c                   |   4 +-
 drivers/xen/unpopulated-alloc.c         | 185 ++++++++++++++++++++++++
 drivers/xen/xenbus/xenbus_client.c      |   6 +-
 drivers/xen/xlate_mmu.c                 |   4 +-
 include/linux/memremap.h                |   9 +-
 include/xen/xen.h                       |   9 ++
 mm/memremap.c                           |   2 +-
 13 files changed, 221 insertions(+), 22 deletions(-)
 create mode 100644 drivers/xen/unpopulated-alloc.c

-- 
2.28.0



WARNING: multiple messages have this Message-ID (diff)
From: Roger Pau Monne <roger.pau@citrix.com>
To: <linux-kernel@vger.kernel.org>
Cc: Roger Pau Monne <roger.pau@citrix.com>, <xen-devel@lists.xenproject.org>
Subject: [PATCH v4 0/2] xen/balloon: fixes for memory hotplug
Date: Tue, 11 Aug 2020 11:44:45 +0200	[thread overview]
Message-ID: <20200811094447.31208-1-roger.pau@citrix.com> (raw)

Hello,

The following series contain some fixes in order to split Xen
unpopulated memory handling from the ballooning driver if ZONE_DEVICE is
available, so that physical memory regions used to map foreign pages are
not tied to memory hotplug.

The main difference in this version is that MEMORY_DEVICE_DEVDAX is
renamed to MEMORY_DEVICE_GENERIC, as using DEVDAX in the Xen code to
allocate unpopulated memory felt wrong.

Thanks, Roger.

Roger Pau Monne (2):
  memremap: rename MEMORY_DEVICE_DEVDAX to MEMORY_DEVICE_GENERIC
  xen: add helpers to allocate unpopulated memory

 drivers/dax/device.c                    |   2 +-
 drivers/gpu/drm/xen/xen_drm_front_gem.c |   9 +-
 drivers/xen/Kconfig                     |   4 +
 drivers/xen/Makefile                    |   1 +
 drivers/xen/balloon.c                   |   4 +-
 drivers/xen/grant-table.c               |   4 +-
 drivers/xen/privcmd.c                   |   4 +-
 drivers/xen/unpopulated-alloc.c         | 185 ++++++++++++++++++++++++
 drivers/xen/xenbus/xenbus_client.c      |   6 +-
 drivers/xen/xlate_mmu.c                 |   4 +-
 include/linux/memremap.h                |   9 +-
 include/xen/xen.h                       |   9 ++
 mm/memremap.c                           |   2 +-
 13 files changed, 221 insertions(+), 22 deletions(-)
 create mode 100644 drivers/xen/unpopulated-alloc.c

-- 
2.28.0


             reply	other threads:[~2020-08-11  9:45 UTC|newest]

Thread overview: 47+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-08-11  9:44 Roger Pau Monne [this message]
2020-08-11  9:44 ` [PATCH v4 0/2] xen/balloon: fixes for memory hotplug Roger Pau Monne
2020-08-11  9:44 ` [PATCH v4 1/2] memremap: rename MEMORY_DEVICE_DEVDAX to MEMORY_DEVICE_GENERIC Roger Pau Monne
2020-08-11  9:44   ` Roger Pau Monne
2020-08-11  9:44   ` Roger Pau Monne
2020-08-11 21:07   ` David Hildenbrand
2020-08-11 21:07     ` David Hildenbrand
2020-08-11 21:07     ` David Hildenbrand
2020-08-20 11:37     ` Roger Pau Monné
2020-08-20 11:37       ` Roger Pau Monné
2020-08-31 10:19       ` Roger Pau Monné
2020-08-31 10:19         ` Roger Pau Monné
2020-08-31 20:56         ` Ira Weiny
2020-08-31 20:56           ` Ira Weiny
2020-08-31 19:20   ` Andrew Morton
2020-08-31 19:20     ` Andrew Morton
2020-08-11  9:44 ` [PATCH v4 2/2] xen: add helpers to allocate unpopulated memory Roger Pau Monne
2020-08-11  9:44   ` Roger Pau Monne
2020-08-11  9:44   ` Roger Pau Monne
2020-08-12  7:28   ` Jürgen Groß
2020-08-12  7:28     ` Jürgen Groß
2020-08-12  7:28     ` Jürgen Groß
2020-08-12  7:38     ` Roger Pau Monné
2020-08-12  7:38       ` Roger Pau Monné
2020-08-12  7:38       ` Roger Pau Monné
2020-08-12 18:13   ` kernel test robot
2020-08-12 18:13     ` kernel test robot
2020-08-13  7:33   ` Christoph Hellwig
2020-08-13  7:54     ` Roger Pau Monné
2020-08-13  7:54       ` Roger Pau Monné
2020-08-13  9:49       ` Daniel Vetter
2020-08-13  9:49         ` Daniel Vetter
2020-08-13 10:02         ` Roger Pau Monné
2020-08-13 10:02           ` Roger Pau Monné
2020-08-14  7:29       ` Christoph Hellwig
2020-08-14  9:56         ` Roger Pau Monné
2020-08-14  9:56           ` Roger Pau Monné
2020-08-14 10:27           ` Jürgen Groß
2020-08-14 10:27             ` Jürgen Groß
2020-08-14 12:47             ` Roger Pau Monné
2020-08-14 12:47               ` Roger Pau Monné
2020-08-14 12:54               ` Jürgen Groß
2020-08-14 12:54                 ` Jürgen Groß
2020-08-14 13:35                 ` Roger Pau Monné
2020-08-14 13:35                   ` Roger Pau Monné
2020-08-14 13:52                   ` Jürgen Groß
2020-08-14 13:52                     ` Jürgen Groß

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200811094447.31208-1-roger.pau@citrix.com \
    --to=roger.pau@citrix.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.