All of lore.kernel.org
 help / color / mirror / Atom feed
From: Lee Jones <lee.jones@linaro.org>
To: lee.jones@linaro.org
Cc: linux-kernel@vger.kernel.org, Jens Axboe <axboe@kernel.dk>,
	Tejun Heo <htejun@gmail.com>,
	linux-ide@vger.kernel.org
Subject: [PATCH 02/20] ata: libata-sata: Fix function names in header comments
Date: Mon,  1 Feb 2021 14:39:22 +0000	[thread overview]
Message-ID: <20210201143940.2070919-3-lee.jones@linaro.org> (raw)
In-Reply-To: <20210201143940.2070919-1-lee.jones@linaro.org>

Fixes the following W=1 kernel build warning(s):

 drivers/ata/libata-sata.c:1085: warning: expecting prototype for port_alloc(). Prototype was for ata_sas_port_alloc() instead
 drivers/ata/libata-sata.c:1140: warning: expecting prototype for ata_port_stop(). Prototype was for ata_sas_port_stop() instead

Cc: Jens Axboe <axboe@kernel.dk>
Cc: Tejun Heo <htejun@gmail.com>
Cc: linux-ide@vger.kernel.org
Signed-off-by: Lee Jones <lee.jones@linaro.org>
---
 drivers/ata/libata-sata.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/ata/libata-sata.c b/drivers/ata/libata-sata.c
index c16423e445255..8adeab76dd382 100644
--- a/drivers/ata/libata-sata.c
+++ b/drivers/ata/libata-sata.c
@@ -1067,7 +1067,7 @@ int ata_scsi_change_queue_depth(struct scsi_device *sdev, int queue_depth)
 EXPORT_SYMBOL_GPL(ata_scsi_change_queue_depth);
 
 /**
- *	port_alloc - Allocate port for a SAS attached SATA device
+ *	ata_sas_port_alloc - Allocate port for a SAS attached SATA device
  *	@host: ATA host container for all SAS ports
  *	@port_info: Information from low-level host driver
  *	@shost: SCSI host that the scsi device is attached to
@@ -1127,7 +1127,7 @@ int ata_sas_port_start(struct ata_port *ap)
 EXPORT_SYMBOL_GPL(ata_sas_port_start);
 
 /**
- *	ata_port_stop - Undo ata_sas_port_start()
+ *	ata_sas_port_stop - Undo ata_sas_port_start()
  *	@ap: Port to shut down
  *
  *	May be used as the port_stop() entry in ata_port_operations.
-- 
2.25.1


  parent reply	other threads:[~2021-02-01 14:41 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-02-01 14:39 [PATCH v2 00/20] [Set 1] Rid W=1 warnings from ATA Lee Jones
2021-02-01 14:39 ` [PATCH 01/20] ata: libata-transport: Fix some potential doc-rot issues Lee Jones
2021-02-01 14:39 ` Lee Jones [this message]
2021-02-01 14:39 ` [PATCH 03/20] ata: libata-pmp: Fix misspelling of 'val' Lee Jones
2021-02-01 14:39 ` [PATCH 04/20] ata: pata_ali: Repair some misnamed kernel-doc issues Lee Jones
2021-02-01 14:39 ` [PATCH 05/20] ata: pata_artop: Fix a function name and parameter description Lee Jones
2021-02-01 14:39 ` [PATCH 06/20] ata: pata_amd: Remove superfluous, add missing and fix broken params Lee Jones
2021-02-01 14:39 ` [PATCH 07/20] ata: pata_hpt366: Provide missing description for 'hpt366_filter()'s 'mask' param Lee Jones
2021-02-01 14:39 ` [PATCH 08/20] ata: pata_hpt37x: Fix some function misnaming and missing param issues Lee Jones
2021-02-01 14:39 ` [PATCH 09/20] ata: ahci_xgene: Fix incorrect naming of 'xgene_ahci_handle_broken_edge_irq()'s 'host' param Lee Jones
2021-02-01 14:39 ` [PATCH 10/20] ata: sata_mv: Fix worthy headers and demote others Lee Jones
2021-02-01 14:39 ` [PATCH 11/20] ata: pata_ali: Supply description for 'ali_20_filter()'s 'mask' param Lee Jones
2021-02-01 14:39 ` [PATCH 12/20] ata: pata_amd: Fix incorrectly named function in the header Lee Jones
2021-02-01 14:39 ` [PATCH 13/20] ata: pata_artop: Repair possible copy/paste issue in 'artop_6210_qc_defer()'s header Lee Jones
2021-02-01 14:39 ` [PATCH 14/20] ata: pata_atiixp: Fix a function name and supply description for 'pio' Lee Jones
2021-02-01 14:39 ` [PATCH 15/20] ata: pata_cs5520: Add a couple of missing param descriptions Lee Jones
2021-02-01 14:39 ` [PATCH 16/20] ata: pata_hpt3x2n: Fix possible doc-rotted function name Lee Jones
2021-02-01 14:39 ` [PATCH 17/20] ata: pata_marvell: Fix incorrectly documented function parameter Lee Jones
2021-02-01 14:39 ` [PATCH 18/20] ata: pata_jmicron: " Lee Jones
2021-02-01 14:39 ` [PATCH 19/20] ata: pata_optidma: Fix a function misnaming, a formatting issue and a missing description Lee Jones
2021-02-01 14:39 ` [PATCH 20/20] ata: pata_pdc2027x: Fix some incorrect function names and parameter docs Lee Jones
2021-03-03 14:26 ` [PATCH v2 00/20] [Set 1] Rid W=1 warnings from ATA Lee Jones
2021-03-04  0:41 ` Jens Axboe

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210201143940.2070919-3-lee.jones@linaro.org \
    --to=lee.jones@linaro.org \
    --cc=axboe@kernel.dk \
    --cc=htejun@gmail.com \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.