From: Markus Schneider-Pargmann <msp@baylibre.com>
To: Matthias Brugger <matthias.bgg@gmail.com>
Cc: Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Chun-Jie Chen <chun-jie.chen@mediatek.com>,
AngeloGioacchino Del Regno
<angelogioacchino.delregno@collabora.com>,
Fabien Parent <parent.f@gmail.com>,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-mediatek@lists.infradead.org,
Fabien Parent <fparent@baylibre.com>
Subject: Re: [PATCH 8/8] soc: mediatek: pm-domains: Add support for MT8365
Date: Mon, 20 Feb 2023 20:44:41 +0100 [thread overview]
Message-ID: <20230220194441.2564ct25qsxvvvic@blmsp> (raw)
In-Reply-To: <07a16be1-3f96-374c-3a9b-e3920bb4b437@gmail.com>
Hi Matthias,
On Fri, Feb 03, 2023 at 01:22:38PM +0100, Matthias Brugger wrote:
>
>
> On 05/01/2023 18:07, Markus Schneider-Pargmann wrote:
> > From: Fabien Parent <fparent@baylibre.com>
> >
> > Add the needed board data to support MT8365 SoC.
> >
> > Signed-off-by: Fabien Parent <fparent@baylibre.com>
> > Signed-off-by: Markus Schneider-Pargmann <msp@baylibre.com>
> > ---
> > drivers/soc/mediatek/mt8365-pm-domains.h | 147 +++++++++++++++++++++++
> > drivers/soc/mediatek/mtk-pm-domains.c | 5 +
> > 2 files changed, 152 insertions(+)
> > create mode 100644 drivers/soc/mediatek/mt8365-pm-domains.h
> >
> > diff --git a/drivers/soc/mediatek/mt8365-pm-domains.h b/drivers/soc/mediatek/mt8365-pm-domains.h
> > new file mode 100644
> > index 000000000000..8735e833b15b
> > --- /dev/null
> > +++ b/drivers/soc/mediatek/mt8365-pm-domains.h
> > @@ -0,0 +1,147 @@
> > +/* SPDX-License-Identifier: GPL-2.0-only */
> > +
> > +#ifndef __SOC_MEDIATEK_MT8365_PM_DOMAINS_H
> > +#define __SOC_MEDIATEK_MT8365_PM_DOMAINS_H
> > +
> > +#include "mtk-pm-domains.h"
> > +#include <dt-bindings/power/mediatek,mt8365-power.h>
> > +
> > +/*
> > + * MT8365 power domain support
> > + */
> > +
> > +static const struct scpsys_domain_data scpsys_domain_data_mt8365[] = {
> > + [MT8365_POWER_DOMAIN_MM] = {
> > + .name = "mm",
> > + .sta_mask = PWR_STATUS_DISP,
> > + .ctl_offs = 0x30c,
> > + .pwr_sta_offs = 0x0180,
> > + .pwr_sta2nd_offs = 0x0184,
> > + .sram_pdn_bits = GENMASK(8, 8),
> > + .sram_pdn_ack_bits = GENMASK(12, 12),
> > + .caps = MTK_SCPD_STRICT_BUS_PROTECTION | MTK_SCPD_HAS_WAY_EN,
> > + .bp_infracfg = {
> > + BUS_PROT_WR(BIT(16) | BIT(17), 0x2a8, 0x2ac, 0x258),
> > + BUS_PROT_WR(BIT(1) | BIT(2) | BIT(10) | BIT(11), 0x2a0, 0x2a4, 0x228),
> > + BUS_PROT_WAY_EN(BIT(6), 0x200, BIT(24), 0x0),
> > + BUS_PROT_WAY_EN(BIT(5), 0x234, BIT(14), 0x28),
> > + BUS_PROT_WR(BIT(6), 0x2a0, 0x2a4, 0x228),
>
>
> BUS_PROT_WR(BIT(6), 0x2a0, 0x2a4, 0x228) repeates several times in the
> definition. Would it make sense to create a new define like we did with
> BUS_PROT_UPDATE_TOPAXI()? Are this offests are used in other SoCs.
>
> In any case instead of magic numbers the values should be defined in
> include/linux/soc/mediatek/infracfg.h or appropiate header files.
Thanks, you are right, I got rid of all the magic numbers and introduced
some helper defines as well.
Thank you,
Markus
WARNING: multiple messages have this Message-ID (diff)
From: Markus Schneider-Pargmann <msp@baylibre.com>
To: Matthias Brugger <matthias.bgg@gmail.com>
Cc: Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Chun-Jie Chen <chun-jie.chen@mediatek.com>,
AngeloGioacchino Del Regno
<angelogioacchino.delregno@collabora.com>,
Fabien Parent <parent.f@gmail.com>,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-mediatek@lists.infradead.org,
Fabien Parent <fparent@baylibre.com>
Subject: Re: [PATCH 8/8] soc: mediatek: pm-domains: Add support for MT8365
Date: Mon, 20 Feb 2023 20:44:41 +0100 [thread overview]
Message-ID: <20230220194441.2564ct25qsxvvvic@blmsp> (raw)
In-Reply-To: <07a16be1-3f96-374c-3a9b-e3920bb4b437@gmail.com>
Hi Matthias,
On Fri, Feb 03, 2023 at 01:22:38PM +0100, Matthias Brugger wrote:
>
>
> On 05/01/2023 18:07, Markus Schneider-Pargmann wrote:
> > From: Fabien Parent <fparent@baylibre.com>
> >
> > Add the needed board data to support MT8365 SoC.
> >
> > Signed-off-by: Fabien Parent <fparent@baylibre.com>
> > Signed-off-by: Markus Schneider-Pargmann <msp@baylibre.com>
> > ---
> > drivers/soc/mediatek/mt8365-pm-domains.h | 147 +++++++++++++++++++++++
> > drivers/soc/mediatek/mtk-pm-domains.c | 5 +
> > 2 files changed, 152 insertions(+)
> > create mode 100644 drivers/soc/mediatek/mt8365-pm-domains.h
> >
> > diff --git a/drivers/soc/mediatek/mt8365-pm-domains.h b/drivers/soc/mediatek/mt8365-pm-domains.h
> > new file mode 100644
> > index 000000000000..8735e833b15b
> > --- /dev/null
> > +++ b/drivers/soc/mediatek/mt8365-pm-domains.h
> > @@ -0,0 +1,147 @@
> > +/* SPDX-License-Identifier: GPL-2.0-only */
> > +
> > +#ifndef __SOC_MEDIATEK_MT8365_PM_DOMAINS_H
> > +#define __SOC_MEDIATEK_MT8365_PM_DOMAINS_H
> > +
> > +#include "mtk-pm-domains.h"
> > +#include <dt-bindings/power/mediatek,mt8365-power.h>
> > +
> > +/*
> > + * MT8365 power domain support
> > + */
> > +
> > +static const struct scpsys_domain_data scpsys_domain_data_mt8365[] = {
> > + [MT8365_POWER_DOMAIN_MM] = {
> > + .name = "mm",
> > + .sta_mask = PWR_STATUS_DISP,
> > + .ctl_offs = 0x30c,
> > + .pwr_sta_offs = 0x0180,
> > + .pwr_sta2nd_offs = 0x0184,
> > + .sram_pdn_bits = GENMASK(8, 8),
> > + .sram_pdn_ack_bits = GENMASK(12, 12),
> > + .caps = MTK_SCPD_STRICT_BUS_PROTECTION | MTK_SCPD_HAS_WAY_EN,
> > + .bp_infracfg = {
> > + BUS_PROT_WR(BIT(16) | BIT(17), 0x2a8, 0x2ac, 0x258),
> > + BUS_PROT_WR(BIT(1) | BIT(2) | BIT(10) | BIT(11), 0x2a0, 0x2a4, 0x228),
> > + BUS_PROT_WAY_EN(BIT(6), 0x200, BIT(24), 0x0),
> > + BUS_PROT_WAY_EN(BIT(5), 0x234, BIT(14), 0x28),
> > + BUS_PROT_WR(BIT(6), 0x2a0, 0x2a4, 0x228),
>
>
> BUS_PROT_WR(BIT(6), 0x2a0, 0x2a4, 0x228) repeates several times in the
> definition. Would it make sense to create a new define like we did with
> BUS_PROT_UPDATE_TOPAXI()? Are this offests are used in other SoCs.
>
> In any case instead of magic numbers the values should be defined in
> include/linux/soc/mediatek/infracfg.h or appropiate header files.
Thanks, you are right, I got rid of all the magic numbers and introduced
some helper defines as well.
Thank you,
Markus
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
next prev parent reply other threads:[~2023-02-20 19:45 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-01-05 17:07 [PATCH 0/8] soc: mediatek: MT8365 power support Markus Schneider-Pargmann
2023-01-05 17:07 ` Markus Schneider-Pargmann
2023-01-05 17:07 ` [PATCH 1/8] dt-bindings: power: Add MT8365 power domains Markus Schneider-Pargmann
2023-01-05 17:07 ` Markus Schneider-Pargmann
2023-01-08 22:07 ` Rob Herring
2023-01-08 22:07 ` Rob Herring
2023-02-03 12:31 ` Matthias Brugger
2023-02-03 12:31 ` Matthias Brugger
2023-02-20 20:10 ` Markus Schneider-Pargmann
2023-02-20 20:10 ` Markus Schneider-Pargmann
2023-01-05 17:07 ` [PATCH 2/8] soc: mediatek: pm-domains: Split bus_prot_mask Markus Schneider-Pargmann
2023-01-05 17:07 ` Markus Schneider-Pargmann
2023-01-05 17:07 ` [PATCH 3/8] soc: mediatek: pm-domains: Create bus protection operation functions Markus Schneider-Pargmann
2023-01-05 17:07 ` Markus Schneider-Pargmann
2023-02-03 12:32 ` Matthias Brugger
2023-02-03 12:32 ` Matthias Brugger
2023-03-13 11:49 ` Markus Schneider-Pargmann
2023-03-13 11:49 ` Markus Schneider-Pargmann
2023-01-05 17:07 ` [PATCH 4/8] soc: mediatek: pm-domains: Document scpsys_bus_prot_data Markus Schneider-Pargmann
2023-01-05 17:07 ` Markus Schneider-Pargmann
2023-01-05 17:07 ` [PATCH 5/8] soc: mediatek: pm-domains: Fix caps field documentation Markus Schneider-Pargmann
2023-01-05 17:07 ` Markus Schneider-Pargmann
2023-02-03 11:14 ` Matthias Brugger
2023-02-03 11:14 ` Matthias Brugger
2023-01-05 17:07 ` [PATCH 6/8] soc: mediatek: Add support for WAY_EN operations Markus Schneider-Pargmann
2023-01-05 17:07 ` Markus Schneider-Pargmann
2023-02-03 12:49 ` Matthias Brugger
2023-02-03 12:49 ` Matthias Brugger
2023-01-05 17:07 ` [PATCH 7/8] soc: mediatek: Add support for MTK_SCPD_STRICT_BUS_PROTECTION cap Markus Schneider-Pargmann
2023-01-05 17:07 ` Markus Schneider-Pargmann
2023-01-05 17:07 ` [PATCH 8/8] soc: mediatek: pm-domains: Add support for MT8365 Markus Schneider-Pargmann
2023-01-05 17:07 ` Markus Schneider-Pargmann
2023-02-03 12:22 ` Matthias Brugger
2023-02-03 12:22 ` Matthias Brugger
2023-02-20 19:44 ` Markus Schneider-Pargmann [this message]
2023-02-20 19:44 ` Markus Schneider-Pargmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230220194441.2564ct25qsxvvvic@blmsp \
--to=msp@baylibre.com \
--cc=angelogioacchino.delregno@collabora.com \
--cc=chun-jie.chen@mediatek.com \
--cc=devicetree@vger.kernel.org \
--cc=fparent@baylibre.com \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=matthias.bgg@gmail.com \
--cc=parent.f@gmail.com \
--cc=robh+dt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.