All of lore.kernel.org
 help / color / mirror / Atom feed
From: Thomas Zimmermann <tzimmermann@suse.de>
To: jfalempe@redhat.com, airlied@redhat.com, airlied@gmail.com,
	daniel@ffwll.ch
Cc: Thomas Zimmermann <tzimmermann@suse.de>, dri-devel@lists.freedesktop.org
Subject: [PATCH 0/4] drm/ast: Use struct ast_device
Date: Tue, 21 Feb 2023 16:57:41 +0100	[thread overview]
Message-ID: <20230221155745.27484-1-tzimmermann@suse.de> (raw)

Rename struct ast_private to struct ast_device. The old name comes
from the time when struct drm_device.dev_private was still in use.
Also update the upcast helper.

The renaming touches ast's I/O-helper macros, which generate warnings
with checkpatch. So fix the I/O helpers in the first two patches of
this patchset.

Tested on AST2100 hardware.

Thomas Zimmermann (4):
  drm/ast: Remove little-endianism from I/O helpers
  drm/ast: Rework definition of I/O read and write helpers
  drm/ast: Rename struct ast_private to struct ast_device
  drm/ast: Rename to_ast_private() to to_ast_device()

 drivers/gpu/drm/ast/ast_dp.c    | 10 ++--
 drivers/gpu/drm/ast/ast_dp501.c | 40 +++++++-------
 drivers/gpu/drm/ast/ast_drv.c   |  2 +-
 drivers/gpu/drm/ast/ast_drv.h   | 84 ++++++++++++-----------------
 drivers/gpu/drm/ast/ast_i2c.c   |  8 +--
 drivers/gpu/drm/ast/ast_main.c  | 24 ++++-----
 drivers/gpu/drm/ast/ast_mm.c    |  4 +-
 drivers/gpu/drm/ast/ast_mode.c  | 78 +++++++++++++--------------
 drivers/gpu/drm/ast/ast_post.c  | 94 ++++++++++++++++-----------------
 9 files changed, 163 insertions(+), 181 deletions(-)

-- 
2.39.2


             reply	other threads:[~2023-02-21 15:58 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-02-21 15:57 Thomas Zimmermann [this message]
2023-02-21 15:57 ` [PATCH 1/4] drm/ast: Remove little-endianism from I/O helpers Thomas Zimmermann
2023-02-28 10:15   ` Javier Martinez Canillas
2023-02-21 15:57 ` [PATCH 2/4] drm/ast: Rework definition of I/O read and write helpers Thomas Zimmermann
2023-02-28 10:25   ` Javier Martinez Canillas
2023-02-21 15:57 ` [PATCH 3/4] drm/ast: Rename struct ast_private to struct ast_device Thomas Zimmermann
2023-02-28 10:32   ` Javier Martinez Canillas
2023-02-21 15:57 ` [PATCH 4/4] drm/ast: Rename to_ast_private() to to_ast_device() Thomas Zimmermann
2023-02-28 10:33   ` Javier Martinez Canillas

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230221155745.27484-1-tzimmermann@suse.de \
    --to=tzimmermann@suse.de \
    --cc=airlied@gmail.com \
    --cc=airlied@redhat.com \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jfalempe@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.