From: Javier Martinez Canillas <javierm@redhat.com>
To: Thomas Zimmermann <tzimmermann@suse.de>,
jfalempe@redhat.com, airlied@redhat.com, airlied@gmail.com,
daniel@ffwll.ch
Cc: dri-devel@lists.freedesktop.org, Thomas Zimmermann <tzimmermann@suse.de>
Subject: Re: [PATCH 3/4] drm/ast: Rename struct ast_private to struct ast_device
Date: Tue, 28 Feb 2023 11:32:48 +0100 [thread overview]
Message-ID: <87v8jmxepb.fsf@minerva.mail-host-address-is-not-set> (raw)
In-Reply-To: <20230221155745.27484-4-tzimmermann@suse.de>
Thomas Zimmermann <tzimmermann@suse.de> writes:
> The data structure struct ast_private represents an AST device. Its
> name comes from the time when it was allocated and stored separately
> in struct drm_device.dev_private. The DRM device is now embedded, so
> rename struct ast_private to struct ast_device.
>
> Signed-off-by: Thomas Zimmermann <tzimmermann@suse.de>
> ---
> drivers/gpu/drm/ast/ast_dp.c | 10 ++--
> drivers/gpu/drm/ast/ast_dp501.c | 40 +++++++-------
> drivers/gpu/drm/ast/ast_drv.c | 2 +-
> drivers/gpu/drm/ast/ast_drv.h | 40 +++++++-------
> drivers/gpu/drm/ast/ast_i2c.c | 8 +--
> drivers/gpu/drm/ast/ast_main.c | 24 ++++-----
> drivers/gpu/drm/ast/ast_mm.c | 4 +-
> drivers/gpu/drm/ast/ast_mode.c | 78 +++++++++++++--------------
> drivers/gpu/drm/ast/ast_post.c | 94 ++++++++++++++++-----------------
> 9 files changed, 150 insertions(+), 150 deletions(-)
>
> diff --git a/drivers/gpu/drm/ast/ast_dp.c b/drivers/gpu/drm/ast/ast_dp.c
> index 56483860306b..9e34297d836d 100644
> --- a/drivers/gpu/drm/ast/ast_dp.c
> +++ b/drivers/gpu/drm/ast/ast_dp.c
> @@ -9,7 +9,7 @@
>
> int ast_astdp_read_edid(struct drm_device *dev, u8 *ediddata)
> {
> - struct ast_private *ast = to_ast_private(dev);
> + struct ast_device *ast = to_ast_private(dev);
I would just squash patches #3 and #4 and rename the macro as well. There
is no need to have it as two separate patches IMO.
Reviewed-by: Javier Martinez Canillas <javierm@redhat.com>
--
Best regards,
Javier Martinez Canillas
Core Platforms
Red Hat
next prev parent reply other threads:[~2023-02-28 10:32 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-02-21 15:57 [PATCH 0/4] drm/ast: Use struct ast_device Thomas Zimmermann
2023-02-21 15:57 ` [PATCH 1/4] drm/ast: Remove little-endianism from I/O helpers Thomas Zimmermann
2023-02-28 10:15 ` Javier Martinez Canillas
2023-02-21 15:57 ` [PATCH 2/4] drm/ast: Rework definition of I/O read and write helpers Thomas Zimmermann
2023-02-28 10:25 ` Javier Martinez Canillas
2023-02-21 15:57 ` [PATCH 3/4] drm/ast: Rename struct ast_private to struct ast_device Thomas Zimmermann
2023-02-28 10:32 ` Javier Martinez Canillas [this message]
2023-02-21 15:57 ` [PATCH 4/4] drm/ast: Rename to_ast_private() to to_ast_device() Thomas Zimmermann
2023-02-28 10:33 ` Javier Martinez Canillas
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87v8jmxepb.fsf@minerva.mail-host-address-is-not-set \
--to=javierm@redhat.com \
--cc=airlied@gmail.com \
--cc=airlied@redhat.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=jfalempe@redhat.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.