From: Christoph Hellwig <hch@lst.de>
To: Jens Axboe <axboe@kernel.dk>
Cc: Loic Poulain <loic.poulain@linaro.org>,
Vignesh Raghavendra <vigneshr@ti.com>,
"Rafael J. Wysocki" <rafael@kernel.org>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
linux-pm@vger.kernel.org, Joern Engel <joern@lazybastard.org>,
linux-kernel@vger.kernel.org, linux-block@vger.kernel.org,
Richard Weinberger <richard@nod.at>,
dm-devel@redhat.com, Mike Snitzer <snitzer@kernel.org>,
Pavel Machek <pavel@ucw.cz>,
Miquel Raynal <miquel.raynal@bootlin.com>,
linux-mtd@lists.infradead.org
Subject: [dm-devel] [PATCH 21/24] PM: hibernate: don't use early_lookup_bdev in resume_store
Date: Wed, 31 May 2023 14:55:32 +0200 [thread overview]
Message-ID: <20230531125535.676098-22-hch@lst.de> (raw)
In-Reply-To: <20230531125535.676098-1-hch@lst.de>
resume_store is a sysfs attribute written during normal kernel runtime,
and it should not use the early_lookup_bdev API that bypasses all normal
path based permission checking, and might cause problems with certain
container environments renaming devices.
Switch to lookup_bdev, which does a normal path lookup instead, and fall
back to trying to parse a numeric dev_t just like early_lookup_bdev did.
Note that this strictly speaking changes the kernel ABI as the PARTUUID=
and PARTLABEL= style syntax is now not available during a running
systems. They never were intended for that, but this breaks things
we'll have to figure out a way to make them available again. But if
avoidable in any way I'd rather avoid that.
Fixes: 421a5fa1a6cf ("PM / hibernate: use name_to_dev_t to parse resume")
Signed-off-by: Christoph Hellwig <hch@lst.de>
Acked-by: Rafael J. Wysocki <rafael@kernel.org>
---
kernel/power/hibernate.c | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)
diff --git a/kernel/power/hibernate.c b/kernel/power/hibernate.c
index c52dedb9f7c8e8..7ae95ec72f9902 100644
--- a/kernel/power/hibernate.c
+++ b/kernel/power/hibernate.c
@@ -1178,7 +1178,23 @@ static ssize_t resume_store(struct kobject *kobj, struct kobj_attribute *attr,
if (!name)
return -ENOMEM;
- error = early_lookup_bdev(name, &dev);
+ error = lookup_bdev(name, &dev);
+ if (error) {
+ unsigned maj, min, offset;
+ char *p, dummy;
+
+ if (sscanf(name, "%u:%u%c", &maj, &min, &dummy) == 2 ||
+ sscanf(name, "%u:%u:%u:%c", &maj, &min, &offset,
+ &dummy) == 3) {
+ dev = MKDEV(maj, min);
+ if (maj != MAJOR(dev) || min != MINOR(dev))
+ error = -EINVAL;
+ } else {
+ dev = new_decode_dev(simple_strtoul(name, &p, 16));
+ if (*p)
+ error = -EINVAL;
+ }
+ }
kfree(name);
if (error)
return error;
--
2.39.2
--
dm-devel mailing list
dm-devel@redhat.com
https://listman.redhat.com/mailman/listinfo/dm-devel
WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch@lst.de>
To: Jens Axboe <axboe@kernel.dk>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
"Rafael J. Wysocki" <rafael@kernel.org>,
Mike Snitzer <snitzer@kernel.org>,
Joern Engel <joern@lazybastard.org>,
Miquel Raynal <miquel.raynal@bootlin.com>,
Richard Weinberger <richard@nod.at>,
Vignesh Raghavendra <vigneshr@ti.com>,
Pavel Machek <pavel@ucw.cz>,
Loic Poulain <loic.poulain@linaro.org>,
dm-devel@redhat.com, linux-kernel@vger.kernel.org,
linux-block@vger.kernel.org, linux-mtd@lists.infradead.org,
linux-pm@vger.kernel.org
Subject: [PATCH 21/24] PM: hibernate: don't use early_lookup_bdev in resume_store
Date: Wed, 31 May 2023 14:55:32 +0200 [thread overview]
Message-ID: <20230531125535.676098-22-hch@lst.de> (raw)
In-Reply-To: <20230531125535.676098-1-hch@lst.de>
resume_store is a sysfs attribute written during normal kernel runtime,
and it should not use the early_lookup_bdev API that bypasses all normal
path based permission checking, and might cause problems with certain
container environments renaming devices.
Switch to lookup_bdev, which does a normal path lookup instead, and fall
back to trying to parse a numeric dev_t just like early_lookup_bdev did.
Note that this strictly speaking changes the kernel ABI as the PARTUUID=
and PARTLABEL= style syntax is now not available during a running
systems. They never were intended for that, but this breaks things
we'll have to figure out a way to make them available again. But if
avoidable in any way I'd rather avoid that.
Fixes: 421a5fa1a6cf ("PM / hibernate: use name_to_dev_t to parse resume")
Signed-off-by: Christoph Hellwig <hch@lst.de>
Acked-by: Rafael J. Wysocki <rafael@kernel.org>
---
kernel/power/hibernate.c | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)
diff --git a/kernel/power/hibernate.c b/kernel/power/hibernate.c
index c52dedb9f7c8e8..7ae95ec72f9902 100644
--- a/kernel/power/hibernate.c
+++ b/kernel/power/hibernate.c
@@ -1178,7 +1178,23 @@ static ssize_t resume_store(struct kobject *kobj, struct kobj_attribute *attr,
if (!name)
return -ENOMEM;
- error = early_lookup_bdev(name, &dev);
+ error = lookup_bdev(name, &dev);
+ if (error) {
+ unsigned maj, min, offset;
+ char *p, dummy;
+
+ if (sscanf(name, "%u:%u%c", &maj, &min, &dummy) == 2 ||
+ sscanf(name, "%u:%u:%u:%c", &maj, &min, &offset,
+ &dummy) == 3) {
+ dev = MKDEV(maj, min);
+ if (maj != MAJOR(dev) || min != MINOR(dev))
+ error = -EINVAL;
+ } else {
+ dev = new_decode_dev(simple_strtoul(name, &p, 16));
+ if (*p)
+ error = -EINVAL;
+ }
+ }
kfree(name);
if (error)
return error;
--
2.39.2
WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch@lst.de>
To: Jens Axboe <axboe@kernel.dk>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
"Rafael J. Wysocki" <rafael@kernel.org>,
Mike Snitzer <snitzer@kernel.org>,
Joern Engel <joern@lazybastard.org>,
Miquel Raynal <miquel.raynal@bootlin.com>,
Richard Weinberger <richard@nod.at>,
Vignesh Raghavendra <vigneshr@ti.com>,
Pavel Machek <pavel@ucw.cz>,
Loic Poulain <loic.poulain@linaro.org>,
dm-devel@redhat.com, linux-kernel@vger.kernel.org,
linux-block@vger.kernel.org, linux-mtd@lists.infradead.org,
linux-pm@vger.kernel.org
Subject: [PATCH 21/24] PM: hibernate: don't use early_lookup_bdev in resume_store
Date: Wed, 31 May 2023 14:55:32 +0200 [thread overview]
Message-ID: <20230531125535.676098-22-hch@lst.de> (raw)
In-Reply-To: <20230531125535.676098-1-hch@lst.de>
resume_store is a sysfs attribute written during normal kernel runtime,
and it should not use the early_lookup_bdev API that bypasses all normal
path based permission checking, and might cause problems with certain
container environments renaming devices.
Switch to lookup_bdev, which does a normal path lookup instead, and fall
back to trying to parse a numeric dev_t just like early_lookup_bdev did.
Note that this strictly speaking changes the kernel ABI as the PARTUUID=
and PARTLABEL= style syntax is now not available during a running
systems. They never were intended for that, but this breaks things
we'll have to figure out a way to make them available again. But if
avoidable in any way I'd rather avoid that.
Fixes: 421a5fa1a6cf ("PM / hibernate: use name_to_dev_t to parse resume")
Signed-off-by: Christoph Hellwig <hch@lst.de>
Acked-by: Rafael J. Wysocki <rafael@kernel.org>
---
kernel/power/hibernate.c | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)
diff --git a/kernel/power/hibernate.c b/kernel/power/hibernate.c
index c52dedb9f7c8e8..7ae95ec72f9902 100644
--- a/kernel/power/hibernate.c
+++ b/kernel/power/hibernate.c
@@ -1178,7 +1178,23 @@ static ssize_t resume_store(struct kobject *kobj, struct kobj_attribute *attr,
if (!name)
return -ENOMEM;
- error = early_lookup_bdev(name, &dev);
+ error = lookup_bdev(name, &dev);
+ if (error) {
+ unsigned maj, min, offset;
+ char *p, dummy;
+
+ if (sscanf(name, "%u:%u%c", &maj, &min, &dummy) == 2 ||
+ sscanf(name, "%u:%u:%u:%c", &maj, &min, &offset,
+ &dummy) == 3) {
+ dev = MKDEV(maj, min);
+ if (maj != MAJOR(dev) || min != MINOR(dev))
+ error = -EINVAL;
+ } else {
+ dev = new_decode_dev(simple_strtoul(name, &p, 16));
+ if (*p)
+ error = -EINVAL;
+ }
+ }
kfree(name);
if (error)
return error;
--
2.39.2
______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/
next prev parent reply other threads:[~2023-05-31 13:07 UTC|newest]
Thread overview: 104+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-31 12:55 [dm-devel] fix the name_to_dev_t mess v2 Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 01/24] driver core: return bool from driver_probe_done Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-06-05 17:22 ` [dm-devel] " Jens Axboe
2023-06-05 17:22 ` Jens Axboe
2023-06-05 17:22 ` Jens Axboe
2023-05-31 12:55 ` [dm-devel] [PATCH 02/24] PM: hibernate: factor out a helper to find the resume device Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 03/24] PM: hibernate: remove the global snapshot_test variable Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 04/24] PM: hibernate: move finding the resume device out of software_resume Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-08-03 8:27 ` [dm-devel] " Vlastimil Babka
2023-08-03 8:27 ` Vlastimil Babka
2023-08-03 8:27 ` Vlastimil Babka
2023-08-04 10:31 ` [dm-devel] " Christoph Hellwig
2023-08-04 10:31 ` Christoph Hellwig
2023-08-04 10:31 ` Christoph Hellwig
2023-08-04 13:30 ` [dm-devel] " Greg Kroah-Hartman
2023-08-04 13:30 ` Greg Kroah-Hartman
2023-08-04 13:30 ` Greg Kroah-Hartman
2023-08-05 13:07 ` [dm-devel] " Linux regression tracking #adding (Thorsten Leemhuis)
2023-08-05 13:07 ` Linux regression tracking #adding (Thorsten Leemhuis)
2023-08-05 13:07 ` Linux regression tracking #adding (Thorsten Leemhuis)
2023-05-31 12:55 ` [dm-devel] [PATCH 05/24] init: remove pointless Root_* values Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 06/24] init: rename mount_block_root to mount_root_generic Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 07/24] init: refactor mount_root Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 08/24] init: pass root_device_name explicitly Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-06-24 0:08 ` [dm-devel] " Guenter Roeck
2023-06-24 0:08 ` Guenter Roeck
2023-06-24 0:08 ` Guenter Roeck
2023-06-26 7:53 ` [dm-devel] " Christoph Hellwig
2023-06-26 7:53 ` Christoph Hellwig
2023-06-26 7:53 ` Christoph Hellwig
2023-06-26 14:50 ` [dm-devel] " Guenter Roeck
2023-06-26 14:50 ` Guenter Roeck
2023-06-26 14:50 ` Guenter Roeck
2023-06-27 10:38 ` [dm-devel] " Max Filippov
2023-06-27 10:38 ` Max Filippov
2023-06-27 10:38 ` Max Filippov
2023-05-31 12:55 ` [dm-devel] [PATCH 09/24] init: don't remove the /dev/ prefix from error messages Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 10/24] init: handle ubi/mtd root mounting like all other root types Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 11/24] init: factor the root_wait logic in prepare_namespace into a helper Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 12/24] init: move the nfs/cifs/ram special cases out of name_to_dev_t Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 13/24] init: improve the name_to_dev_t interface Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 14/24] init: clear root_wait on all invalid root= strings Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 15/24] block: move the code to do early boot lookup of block devices to block/ Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 16/24] block: move more code to early-lookup.c Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 17/24] dm-snap: simplify the origin_dev == cow_dev check in snapshot_ctr Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 18/24] dm: open code dm_get_dev_t in dm_init_init Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 19/24] dm: remove dm_get_dev_t Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 20/24] dm: only call early_lookup_bdev from early boot context Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig [this message]
2023-05-31 12:55 ` [PATCH 21/24] PM: hibernate: don't use early_lookup_bdev in resume_store Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 22/24] mtd: block2mtd: factor the early block device open logic into a helper Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 23/24] mtd: block2mtd: don't call early_lookup_bdev after the system is running Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` [dm-devel] [PATCH 24/24] block: mark early_lookup_bdev as __init Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
2023-05-31 12:55 ` Christoph Hellwig
-- strict thread matches above, loose matches on Subject: below --
2023-05-23 7:45 [dm-devel] fix the name_to_dev_t mess Christoph Hellwig
2023-05-23 7:45 ` [dm-devel] [PATCH 21/24] PM: hibernate: don't use early_lookup_bdev in resume_store Christoph Hellwig
2023-05-23 18:36 ` Rafael J. Wysocki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230531125535.676098-22-hch@lst.de \
--to=hch@lst.de \
--cc=axboe@kernel.dk \
--cc=dm-devel@redhat.com \
--cc=gregkh@linuxfoundation.org \
--cc=joern@lazybastard.org \
--cc=linux-block@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=linux-pm@vger.kernel.org \
--cc=loic.poulain@linaro.org \
--cc=miquel.raynal@bootlin.com \
--cc=pavel@ucw.cz \
--cc=rafael@kernel.org \
--cc=richard@nod.at \
--cc=snitzer@kernel.org \
--cc=vigneshr@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.