All of lore.kernel.org
 help / color / mirror / Atom feed
From: Simon Glass <sjg@chromium.org>
To: U-Boot Mailing List <u-boot@lists.denx.de>
Cc: Tom Rini <trini@konsulko.com>, Simon Glass <sjg@chromium.org>,
	Stephen Warren <swarren@nvidia.com>,
	Stephen Warren <swarren@wwwdotorg.org>,
	Svyatoslav Ryhel <clamor95@gmail.com>,
	Thierry Reding <treding@nvidia.com>,
	Tom Warren <twarren@nvidia.com>
Subject: [PATCH v3 03/33] tegra: Drop dependency on SPL_BUILD
Date: Sun, 29 Sep 2024 19:49:26 -0600	[thread overview]
Message-ID: <20240930014956.1434060-4-sjg@chromium.org> (raw)
In-Reply-To: <20240930014956.1434060-1-sjg@chromium.org>

SPL_BUILD is not a Kconfig symbol so perhaps the intent here is to
use SPL instead. But that changes the output size.

So drop the dependency on !SPL_BUILD since it does nothing.

Signed-off-by: Simon Glass <sjg@chromium.org>
---

Changes in v3:
- Correct the subject to match what the patch changed to do

 arch/arm/mach-tegra/tegra124/Kconfig | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/arm/mach-tegra/tegra124/Kconfig b/arch/arm/mach-tegra/tegra124/Kconfig
index fb016aa46c9..84c8f86bad0 100644
--- a/arch/arm/mach-tegra/tegra124/Kconfig
+++ b/arch/arm/mach-tegra/tegra124/Kconfig
@@ -21,8 +21,8 @@ config TARGET_CEI_TK1_SOM
 	bool "Colorado Engineering Inc Tegra124 TK1-som board"
 	select ARCH_SUPPORT_PSCI
 	select BOARD_LATE_INIT
-	select CPU_V7_HAS_NONSEC if !SPL_BUILD
-	select CPU_V7_HAS_VIRT if !SPL_BUILD
+	select CPU_V7_HAS_NONSEC
+	select CPU_V7_HAS_VIRT
 	help
 	  The Colorado Engineering Tegra TK1-SOM is a very compact
 	  (51mmx58mm) board that is functionally almost the same as
-- 
2.34.1


  parent reply	other threads:[~2024-09-30  1:50 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-09-30  1:49 [PATCH v3 00/33] Tidy up use of 'SPL' and CONFIG_SPL_BUILD Simon Glass
2024-09-30  1:49 ` [PATCH v3 01/33] Makefile: Add a u-boot.cfg file for VPL Simon Glass
2024-10-01 21:54   ` Tom Rini
2024-09-30  1:49 ` [PATCH v3 02/33] boot: Drop unnecessary ifdef for LOAD_FIT Simon Glass
2024-10-01 21:54   ` Tom Rini
2024-09-30  1:49 ` Simon Glass [this message]
2024-09-30  1:49 ` [PATCH v3 04/33] net: freescale: Drop use of SPL_BUILD dependency Simon Glass
2024-09-30  1:49 ` [PATCH v3 05/33] serial: Make use of the SERIAL define Simon Glass
2024-09-30  1:49 ` [PATCH v3 06/33] stdio: " Simon Glass
2024-10-01 21:54   ` Tom Rini
2024-09-30  1:49 ` [PATCH v3 07/33] scripts: Rename Makefile.spl to Makefile.xpl Simon Glass
2024-09-30  1:49 ` [PATCH v3 08/33] scripts: Add some comments about autoconf.mk Simon Glass
2024-09-30  1:49 ` [PATCH v3 09/33] scripts: Define CONFIG_XPL_BUILD for all xPL builds Simon Glass
2024-09-30  1:49 ` [PATCH v3 10/33] qconfig: Add XPL_BUILD to ignored symbols Simon Glass
2024-09-30  1:49 ` [PATCH v3 11/33] xpl: Rename u_boot_first_phase to xpl_is_first_phase() Simon Glass
2024-09-30  1:49 ` [PATCH v3 12/33] xpl: Rename spl_phase to xpl_phase_t Simon Glass
2024-09-30  1:49 ` [PATCH v3 13/33] xpl: Rename spl_phase() to xpl_phase() Simon Glass
2024-09-30  1:49 ` [PATCH v3 14/33] xpl: Rename spl_in_proper() to not_xpl() Simon Glass
2024-09-30  1:49 ` [PATCH v3 15/33] xpl: Add a function to indicate when in xPL Simon Glass
2024-09-30  1:49 ` [PATCH v3 16/33] xpl: Rename spl_next_phase() and spl_prev_phase() Simon Glass
2024-09-30  1:49 ` [PATCH v3 17/33] xpl: Rename spl_phase_prefix() and spl_phase_name() Simon Glass
2024-09-30  1:49 ` [PATCH v3 18/33] log: global: Rename warn_non_spl() Simon Glass
2024-09-30  1:49 ` [PATCH v3 19/33] doc: Update SPL docs for the xPL changes Simon Glass
2024-09-30  1:49 ` [PATCH v3 20/33] README: Drop SoC-specific comment about SPL Simon Glass
2024-09-30  1:49 ` [PATCH v3 21/33] doc: Move init-related things out of README Simon Glass
2024-09-30  1:49 ` [PATCH v3 22/33] doc: Update init docs for the xPL changes Simon Glass
2024-09-30  1:49 ` [PATCH v3 23/33] arch: Use CONFIG_XPL_BUILD instead of CONFIG_SPL_BUILD Simon Glass
2024-09-30  1:49 ` [PATCH v3 24/33] board: " Simon Glass
2024-09-30  1:49 ` [PATCH v3 25/33] drivers: " Simon Glass
2024-09-30  1:49 ` [PATCH v3 26/33] include: " Simon Glass
2024-09-30  1:49 ` [PATCH v3 27/33] global: " Simon Glass
2024-09-30  1:49 ` [PATCH v3 28/33] xpl: Define CONFIG_SPL_BUILD only for the SPL build Simon Glass
2024-09-30  1:49 ` [PATCH v3 29/33] kconfig: binman: Check for SPL instead of XPL Simon Glass
2024-09-30  1:49 ` [PATCH v3 30/33] global: Rename SPL_ to XPL_ Simon Glass
2024-09-30  1:49 ` [PATCH v3 31/33] global: Rename SPL_TPL_ to PHASE_ Simon Glass
2024-10-01 21:54   ` Tom Rini
2024-09-30  1:49 ` [PATCH v3 32/33] spl: Rename SPL_TPL_NAME and SPL_TPL_PROMPT Simon Glass
2024-09-30  1:49 ` [PATCH v3 33/33] qconfig: Update tool for new Makefile variables Simon Glass
2024-10-11 23:01 ` [PATCH v3 00/33] Tidy up use of 'SPL' and CONFIG_SPL_BUILD Tom Rini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20240930014956.1434060-4-sjg@chromium.org \
    --to=sjg@chromium.org \
    --cc=clamor95@gmail.com \
    --cc=swarren@nvidia.com \
    --cc=swarren@wwwdotorg.org \
    --cc=treding@nvidia.com \
    --cc=trini@konsulko.com \
    --cc=twarren@nvidia.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.