From: Tom Rini <trini@konsulko.com>
To: Simon Glass <sjg@chromium.org>
Cc: U-Boot Mailing List <u-boot@lists.denx.de>,
Alexey Romanov <avromanov@salutedevices.com>,
Anton Bambura <jenneron@protonmail.com>,
Arseniy Krasnov <avkrasnov@salutedevices.com>,
Billy Tsai <billy_tsai@aspeedtech.com>,
Bin Meng <bmeng.cn@gmail.com>,
Heinrich Schuchardt <xypron.glpk@gmx.de>,
Jagan Teki <jagan@amarulasolutions.com>,
Jesse Taube <mr.bossman075@gmail.com>,
Kever Yang <kever.yang@rock-chips.com>,
Kongyang Liu <seashell11234455@gmail.com>,
Konrad Dybcio <konrad.dybcio@linaro.org>,
Leo <ycliang@andestech.com>,
Martin Kurbanov <mmkurbanov@sberdevices.ru>,
Masahisa Kojima <kojima.masahisa@socionext.com>,
Max Resch <resch.max@gmail.com>,
Michael Trimarchi <michael@amarulasolutions.com>,
Michal Simek <michal.simek@amd.com>,
Nicolas Ferre <nicolas.ferre@microchip.com>,
Nishanth Menon <nm@ti.com>,
Patrick Delaunay <patrick.delaunay@foss.st.com>,
Quentin Schulz <quentin.schulz@cherry.de>,
Randolph <randolph@andestech.com>,
Sam Protsenko <semen.protsenko@linaro.org>,
Stefan Roese <sr@denx.de>, Sumit Garg <sumit.garg@linaro.org>,
Svyatoslav Ryhel <clamor95@gmail.com>,
Vasileios Bimpikas <vasileios.bimpikas@analog.com>,
Vignesh R <vigneshr@ti.com>
Subject: Re: [PATCH v3 31/33] global: Rename SPL_TPL_ to PHASE_
Date: Tue, 1 Oct 2024 15:54:29 -0600 [thread overview]
Message-ID: <20241001215429.GJ4737@bill-the-cat> (raw)
In-Reply-To: <20240930014956.1434060-32-sjg@chromium.org>
[-- Attachment #1: Type: text/plain, Size: 1185 bytes --]
On Sun, Sep 29, 2024 at 07:49:54PM -0600, Simon Glass wrote:
> Use PHASE_ as the symbol to select a particular XPL build. This means
> that SPL_TPL_ is no-longer set.
>
> Update the comment in bootstage to refer to this symbol, instead of
> SPL_
>
> Signed-off-by: Simon Glass <sjg@chromium.org>
[snip]
> diff --git a/common/bootstage.c b/common/bootstage.c
> index dca33148192..dd6aed7c2fd 100644
> --- a/common/bootstage.c
> +++ b/common/bootstage.c
> @@ -351,7 +351,7 @@ void bootstage_report(void)
> }
> if (data->rec_count > RECORD_COUNT)
> printf("Overflowed internal boot id table by %d entries\n"
> - "Please increase CONFIG_(SPL_TPL_)BOOTSTAGE_RECORD_COUNT\n",
> + "Please increase CONFIG_(PHASE_)BOOTSTAGE_RECORD_COUNT\n",
> data->rec_count - RECORD_COUNT);
>
> puts("\nAccumulated time:\n");
This is a 2 byte rodata reduction because we change the constant string
to be shorter. Perhaps this (and the later debug() message) should be
reworked to read:
"Please increase BOOTSTAGE_RECORD_COUNT for this phase\n"
which is hopefully enough of a crumb to lead someone to the right CONFIG
option?
--
Tom
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 659 bytes --]
next prev parent reply other threads:[~2024-10-01 21:54 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-09-30 1:49 [PATCH v3 00/33] Tidy up use of 'SPL' and CONFIG_SPL_BUILD Simon Glass
2024-09-30 1:49 ` [PATCH v3 01/33] Makefile: Add a u-boot.cfg file for VPL Simon Glass
2024-10-01 21:54 ` Tom Rini
2024-09-30 1:49 ` [PATCH v3 02/33] boot: Drop unnecessary ifdef for LOAD_FIT Simon Glass
2024-10-01 21:54 ` Tom Rini
2024-09-30 1:49 ` [PATCH v3 03/33] tegra: Drop dependency on SPL_BUILD Simon Glass
2024-09-30 1:49 ` [PATCH v3 04/33] net: freescale: Drop use of SPL_BUILD dependency Simon Glass
2024-09-30 1:49 ` [PATCH v3 05/33] serial: Make use of the SERIAL define Simon Glass
2024-09-30 1:49 ` [PATCH v3 06/33] stdio: " Simon Glass
2024-10-01 21:54 ` Tom Rini
2024-09-30 1:49 ` [PATCH v3 07/33] scripts: Rename Makefile.spl to Makefile.xpl Simon Glass
2024-09-30 1:49 ` [PATCH v3 08/33] scripts: Add some comments about autoconf.mk Simon Glass
2024-09-30 1:49 ` [PATCH v3 09/33] scripts: Define CONFIG_XPL_BUILD for all xPL builds Simon Glass
2024-09-30 1:49 ` [PATCH v3 10/33] qconfig: Add XPL_BUILD to ignored symbols Simon Glass
2024-09-30 1:49 ` [PATCH v3 11/33] xpl: Rename u_boot_first_phase to xpl_is_first_phase() Simon Glass
2024-09-30 1:49 ` [PATCH v3 12/33] xpl: Rename spl_phase to xpl_phase_t Simon Glass
2024-09-30 1:49 ` [PATCH v3 13/33] xpl: Rename spl_phase() to xpl_phase() Simon Glass
2024-09-30 1:49 ` [PATCH v3 14/33] xpl: Rename spl_in_proper() to not_xpl() Simon Glass
2024-09-30 1:49 ` [PATCH v3 15/33] xpl: Add a function to indicate when in xPL Simon Glass
2024-09-30 1:49 ` [PATCH v3 16/33] xpl: Rename spl_next_phase() and spl_prev_phase() Simon Glass
2024-09-30 1:49 ` [PATCH v3 17/33] xpl: Rename spl_phase_prefix() and spl_phase_name() Simon Glass
2024-09-30 1:49 ` [PATCH v3 18/33] log: global: Rename warn_non_spl() Simon Glass
2024-09-30 1:49 ` [PATCH v3 19/33] doc: Update SPL docs for the xPL changes Simon Glass
2024-09-30 1:49 ` [PATCH v3 20/33] README: Drop SoC-specific comment about SPL Simon Glass
2024-09-30 1:49 ` [PATCH v3 21/33] doc: Move init-related things out of README Simon Glass
2024-09-30 1:49 ` [PATCH v3 22/33] doc: Update init docs for the xPL changes Simon Glass
2024-09-30 1:49 ` [PATCH v3 23/33] arch: Use CONFIG_XPL_BUILD instead of CONFIG_SPL_BUILD Simon Glass
2024-09-30 1:49 ` [PATCH v3 24/33] board: " Simon Glass
2024-09-30 1:49 ` [PATCH v3 25/33] drivers: " Simon Glass
2024-09-30 1:49 ` [PATCH v3 26/33] include: " Simon Glass
2024-09-30 1:49 ` [PATCH v3 27/33] global: " Simon Glass
2024-09-30 1:49 ` [PATCH v3 28/33] xpl: Define CONFIG_SPL_BUILD only for the SPL build Simon Glass
2024-09-30 1:49 ` [PATCH v3 29/33] kconfig: binman: Check for SPL instead of XPL Simon Glass
2024-09-30 1:49 ` [PATCH v3 30/33] global: Rename SPL_ to XPL_ Simon Glass
2024-09-30 1:49 ` [PATCH v3 31/33] global: Rename SPL_TPL_ to PHASE_ Simon Glass
2024-10-01 21:54 ` Tom Rini [this message]
2024-09-30 1:49 ` [PATCH v3 32/33] spl: Rename SPL_TPL_NAME and SPL_TPL_PROMPT Simon Glass
2024-09-30 1:49 ` [PATCH v3 33/33] qconfig: Update tool for new Makefile variables Simon Glass
2024-10-11 23:01 ` [PATCH v3 00/33] Tidy up use of 'SPL' and CONFIG_SPL_BUILD Tom Rini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20241001215429.GJ4737@bill-the-cat \
--to=trini@konsulko.com \
--cc=avkrasnov@salutedevices.com \
--cc=avromanov@salutedevices.com \
--cc=billy_tsai@aspeedtech.com \
--cc=bmeng.cn@gmail.com \
--cc=clamor95@gmail.com \
--cc=jagan@amarulasolutions.com \
--cc=jenneron@protonmail.com \
--cc=kever.yang@rock-chips.com \
--cc=kojima.masahisa@socionext.com \
--cc=konrad.dybcio@linaro.org \
--cc=michael@amarulasolutions.com \
--cc=michal.simek@amd.com \
--cc=mmkurbanov@sberdevices.ru \
--cc=mr.bossman075@gmail.com \
--cc=nicolas.ferre@microchip.com \
--cc=nm@ti.com \
--cc=patrick.delaunay@foss.st.com \
--cc=quentin.schulz@cherry.de \
--cc=randolph@andestech.com \
--cc=resch.max@gmail.com \
--cc=seashell11234455@gmail.com \
--cc=semen.protsenko@linaro.org \
--cc=sjg@chromium.org \
--cc=sr@denx.de \
--cc=sumit.garg@linaro.org \
--cc=u-boot@lists.denx.de \
--cc=vasileios.bimpikas@analog.com \
--cc=vigneshr@ti.com \
--cc=xypron.glpk@gmx.de \
--cc=ycliang@andestech.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.