All of lore.kernel.org
 help / color / mirror / Atom feed
From: Zhi Wang <zhiw@nvidia.com>
To: <nouveau@lists.freedesktop.org>
Cc: <airlied@gmail.com>, <daniel@ffwll.ch>, <dakr@kernel.org>,
	<bskeggs@nvidia.com>, <acurrid@nvidia.com>, <cjia@nvidia.com>,
	<smitra@nvidia.com>, <ankita@nvidia.com>, <aniketa@nvidia.com>,
	<kwankhede@nvidia.com>, <targupta@nvidia.com>, <zhiw@nvidia.com>,
	<zhiwang@kernel.org>
Subject: [PATCH v3 08/15] nvkm: remove the magic number in r535_gsp_rpc_push()
Date: Thu, 31 Oct 2024 01:52:43 -0700	[thread overview]
Message-ID: <20241031085250.2941482-9-zhiw@nvidia.com> (raw)
In-Reply-To: <20241031085250.2941482-1-zhiw@nvidia.com>

There has been a GSP_MSG_MAX_SIZE which represents the max size of a GSP
message element header. Use it instead of a magic number.

No functional change is intended.

Signed-off-by: Zhi Wang <zhiw@nvidia.com>
---
 drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c b/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c
index 8d7b884f5adb..5bc56a9ba3f8 100644
--- a/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c
+++ b/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c
@@ -796,7 +796,7 @@ r535_gsp_rpc_push(struct nvkm_gsp *gsp, void *payload, bool wait,
 {
 	struct nvfw_gsp_rpc *rpc = to_gsp_hdr(payload, rpc);
 	struct r535_gsp_msg *cmd = to_gsp_hdr(rpc, cmd);
-	const u32 max_msg_size = (16 * 0x1000) - sizeof(struct r535_gsp_msg);
+	const u32 max_msg_size = GSP_MSG_MAX_SIZE - sizeof(*cmd);
 	const u32 max_rpc_size = max_msg_size - sizeof(*rpc);
 	u32 rpc_size = rpc->length - sizeof(*rpc);
 	void *repv;
-- 
2.34.1


  parent reply	other threads:[~2024-10-31  8:53 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-10-31  8:52 [PATCH v3 00/15] NVKM GSP RPC kernel docs, cleanups and fixes Zhi Wang
2024-10-31  8:52 ` [PATCH v3 01/15] nvkm: add a kernel doc to introduce the GSP RPC Zhi Wang
2024-12-11 10:14   ` Danilo Krummrich
2024-12-13 14:11     ` Zhi Wang
2024-10-31  8:52 ` [PATCH v3 02/15] nvkm: rename "repc" to "gsp_rpc_len" on the GSP message recv path Zhi Wang
2024-12-11 10:26   ` Danilo Krummrich
2024-12-13 14:12     ` Zhi Wang
2024-10-31  8:52 ` [PATCH v3 03/15] nvkm: rename "argv" to what it represnts on the GSP message send path Zhi Wang
2024-10-31  8:52 ` [PATCH v3 04/15] nvkm: remove unused param repc in *rm_alloc_push() Zhi Wang
2024-10-31  8:52 ` [PATCH v3 05/15] nvkm: rename "argv" to what it represents in *rm_{alloc, ctrl}_*() Zhi Wang
2024-10-31  8:52 ` [PATCH v3 06/15] nvkm: rename "argc" to what it represents in GSP RPC routines Zhi Wang
2024-10-31  8:52 ` [PATCH v3 07/15] nvkm: fix the broken marco GSP_MSG_MAX_SIZE Zhi Wang
2024-10-31  8:52 ` Zhi Wang [this message]
2024-10-31  8:52 ` [PATCH v3 09/15] nvkm: refine the variable names in r535_gsp_rpc_push() Zhi Wang
2024-10-31  8:52 ` [PATCH v3 10/15] nvkm: refine the variable names in r535_gsp_msg_recv() Zhi Wang
2024-10-31 14:27   ` Timur Tabi
2024-10-31 15:49     ` Zhi Wang
2024-10-31 16:11       ` Timur Tabi
2024-10-31 18:18         ` Zhi Wang
2024-10-31  8:52 ` [PATCH v3 11/15] nvkm: rename the variable "cmd" to "msg" in r535_gsp_cmdq_{get, push}() Zhi Wang
2024-10-31  8:52 ` [PATCH v3 12/15] nvkm: factor out r535_gsp_msgq_peek() Zhi Wang
2024-12-11 13:16   ` Danilo Krummrich
2024-10-31  8:52 ` [PATCH v3 13/15] nvkm: factor out r535_gsp_msgq_recv_one_elem() Zhi Wang
2024-10-31  8:52 ` [PATCH v3 14/15] nvkm: support handling the return of large GSP message Zhi Wang
2024-10-31  8:52 ` [PATCH v3 15/15] nvkm: consume " Zhi Wang
2024-10-31  9:05 ` [PATCH v3 00/15] NVKM GSP RPC kernel docs, cleanups and fixes Danilo Krummrich

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20241031085250.2941482-9-zhiw@nvidia.com \
    --to=zhiw@nvidia.com \
    --cc=acurrid@nvidia.com \
    --cc=airlied@gmail.com \
    --cc=aniketa@nvidia.com \
    --cc=ankita@nvidia.com \
    --cc=bskeggs@nvidia.com \
    --cc=cjia@nvidia.com \
    --cc=dakr@kernel.org \
    --cc=daniel@ffwll.ch \
    --cc=kwankhede@nvidia.com \
    --cc=nouveau@lists.freedesktop.org \
    --cc=smitra@nvidia.com \
    --cc=targupta@nvidia.com \
    --cc=zhiwang@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.