From: Zhi Wang <zhiw@nvidia.com>
To: Timur Tabi <ttabi@nvidia.com>,
"nouveau@lists.freedesktop.org" <nouveau@lists.freedesktop.org>
Cc: Surath Mitra <smitra@nvidia.com>,
Andy Currid <ACurrid@nvidia.com>,
"Tarun Gupta (SW-GPU)" <targupta@nvidia.com>,
Ben Skeggs <bskeggs@nvidia.com>,
"zhiwang@kernel.org" <zhiwang@kernel.org>,
"airlied@gmail.com" <airlied@gmail.com>,
"dakr@kernel.org" <dakr@kernel.org>,
Ankit Agrawal <ankita@nvidia.com>,
Aniket Agashe <aniketa@nvidia.com>,
Kirti Wankhede <kwankhede@nvidia.com>,
"daniel@ffwll.ch" <daniel@ffwll.ch>, Neo Jia <cjia@nvidia.com>
Subject: Re: [PATCH v3 10/15] nvkm: refine the variable names in r535_gsp_msg_recv()
Date: Thu, 31 Oct 2024 18:18:43 +0000 [thread overview]
Message-ID: <9a1d62a6-fb4b-4f29-8abd-e9a324cf2668@nvidia.com> (raw)
In-Reply-To: <cd6253517fac8a1eb8065c8c58d88a588f43e27d.camel@nvidia.com>
On 31/10/2024 18.11, Timur Tabi wrote:
> On Thu, 2024-10-31 at 15:49 +0000, Zhi Wang wrote:
>> Nice catch!
>>
>> It should be fixed in the re-factor in PATCH 12, where
>> r535_gsp_msgq_wait() always returns an int (error code).
>
> I suspect that there are a lot of other places in the kernel, and not just
> Nouveau, where IS_ERR_OR_NULL() is used incorrectly.
>
> Just looking the kernel casually, it seems to me that many usages of
> IS_ERR_OR_NULL() are sloppy and should be changed to avoid that function.
> Returning NULL should mean something different from returning -ERROR.
Correct. Might need a re-visit of usage of IS_ERR_OR_NULL() at least in
nouveau.
next prev parent reply other threads:[~2024-10-31 18:18 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-31 8:52 [PATCH v3 00/15] NVKM GSP RPC kernel docs, cleanups and fixes Zhi Wang
2024-10-31 8:52 ` [PATCH v3 01/15] nvkm: add a kernel doc to introduce the GSP RPC Zhi Wang
2024-12-11 10:14 ` Danilo Krummrich
2024-12-13 14:11 ` Zhi Wang
2024-10-31 8:52 ` [PATCH v3 02/15] nvkm: rename "repc" to "gsp_rpc_len" on the GSP message recv path Zhi Wang
2024-12-11 10:26 ` Danilo Krummrich
2024-12-13 14:12 ` Zhi Wang
2024-10-31 8:52 ` [PATCH v3 03/15] nvkm: rename "argv" to what it represnts on the GSP message send path Zhi Wang
2024-10-31 8:52 ` [PATCH v3 04/15] nvkm: remove unused param repc in *rm_alloc_push() Zhi Wang
2024-10-31 8:52 ` [PATCH v3 05/15] nvkm: rename "argv" to what it represents in *rm_{alloc, ctrl}_*() Zhi Wang
2024-10-31 8:52 ` [PATCH v3 06/15] nvkm: rename "argc" to what it represents in GSP RPC routines Zhi Wang
2024-10-31 8:52 ` [PATCH v3 07/15] nvkm: fix the broken marco GSP_MSG_MAX_SIZE Zhi Wang
2024-10-31 8:52 ` [PATCH v3 08/15] nvkm: remove the magic number in r535_gsp_rpc_push() Zhi Wang
2024-10-31 8:52 ` [PATCH v3 09/15] nvkm: refine the variable names " Zhi Wang
2024-10-31 8:52 ` [PATCH v3 10/15] nvkm: refine the variable names in r535_gsp_msg_recv() Zhi Wang
2024-10-31 14:27 ` Timur Tabi
2024-10-31 15:49 ` Zhi Wang
2024-10-31 16:11 ` Timur Tabi
2024-10-31 18:18 ` Zhi Wang [this message]
2024-10-31 8:52 ` [PATCH v3 11/15] nvkm: rename the variable "cmd" to "msg" in r535_gsp_cmdq_{get, push}() Zhi Wang
2024-10-31 8:52 ` [PATCH v3 12/15] nvkm: factor out r535_gsp_msgq_peek() Zhi Wang
2024-12-11 13:16 ` Danilo Krummrich
2024-10-31 8:52 ` [PATCH v3 13/15] nvkm: factor out r535_gsp_msgq_recv_one_elem() Zhi Wang
2024-10-31 8:52 ` [PATCH v3 14/15] nvkm: support handling the return of large GSP message Zhi Wang
2024-10-31 8:52 ` [PATCH v3 15/15] nvkm: consume " Zhi Wang
2024-10-31 9:05 ` [PATCH v3 00/15] NVKM GSP RPC kernel docs, cleanups and fixes Danilo Krummrich
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9a1d62a6-fb4b-4f29-8abd-e9a324cf2668@nvidia.com \
--to=zhiw@nvidia.com \
--cc=ACurrid@nvidia.com \
--cc=airlied@gmail.com \
--cc=aniketa@nvidia.com \
--cc=ankita@nvidia.com \
--cc=bskeggs@nvidia.com \
--cc=cjia@nvidia.com \
--cc=dakr@kernel.org \
--cc=daniel@ffwll.ch \
--cc=kwankhede@nvidia.com \
--cc=nouveau@lists.freedesktop.org \
--cc=smitra@nvidia.com \
--cc=targupta@nvidia.com \
--cc=ttabi@nvidia.com \
--cc=zhiwang@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.