From: "Darrick J. Wong" <djwong@kernel.org>
To: Christoph Hellwig <hch@lst.de>
Cc: Carlos Maiolino <cem@kernel.org>, linux-xfs@vger.kernel.org
Subject: Re: [PATCH 3/3] xfs: remove the t_magic field in struct xfs_trans
Date: Mon, 6 Jan 2025 09:11:21 -0800 [thread overview]
Message-ID: <20250106171121.GA6174@frogsfrogsfrogs> (raw)
In-Reply-To: <20250106095044.847334-4-hch@lst.de>
On Mon, Jan 06, 2025 at 10:50:31AM +0100, Christoph Hellwig wrote:
> The t_magic field is only ever assigned to, but never read. Remove it.
>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
And it eliminates a 4-byte hole!
Reviewed-by: "Darrick J. Wong" <djwong@kernel.org>
--D
> ---
> fs/xfs/xfs_trans.c | 2 --
> fs/xfs/xfs_trans.h | 1 -
> 2 files changed, 3 deletions(-)
>
> diff --git a/fs/xfs/xfs_trans.c b/fs/xfs/xfs_trans.c
> index 4cd25717c9d1..786fb659ee3f 100644
> --- a/fs/xfs/xfs_trans.c
> +++ b/fs/xfs/xfs_trans.c
> @@ -100,7 +100,6 @@ xfs_trans_dup(
> /*
> * Initialize the new transaction structure.
> */
> - ntp->t_magic = XFS_TRANS_HEADER_MAGIC;
> ntp->t_mountp = tp->t_mountp;
> INIT_LIST_HEAD(&ntp->t_items);
> INIT_LIST_HEAD(&ntp->t_busy);
> @@ -275,7 +274,6 @@ xfs_trans_alloc(
> ASSERT(!(flags & XFS_TRANS_RES_FDBLKS) ||
> xfs_has_lazysbcount(mp));
>
> - tp->t_magic = XFS_TRANS_HEADER_MAGIC;
> tp->t_flags = flags;
> tp->t_mountp = mp;
> INIT_LIST_HEAD(&tp->t_items);
> diff --git a/fs/xfs/xfs_trans.h b/fs/xfs/xfs_trans.h
> index 71c2e82e4dad..2b366851e9a4 100644
> --- a/fs/xfs/xfs_trans.h
> +++ b/fs/xfs/xfs_trans.h
> @@ -122,7 +122,6 @@ void xfs_log_item_init(struct xfs_mount *mp, struct xfs_log_item *item,
> * This is the structure maintained for every active transaction.
> */
> typedef struct xfs_trans {
> - unsigned int t_magic; /* magic number */
> unsigned int t_log_res; /* amt of log space resvd */
> unsigned int t_log_count; /* count for perm log res */
> unsigned int t_blk_res; /* # of blocks resvd */
> --
> 2.45.2
>
>
next prev parent reply other threads:[~2025-01-06 17:11 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-06 9:50 trivial cleanups Christoph Hellwig
2025-01-06 9:50 ` [PATCH 1/3] xfs: mark xfs_dir_isempty static Christoph Hellwig
2025-01-06 17:07 ` Darrick J. Wong
2025-01-06 9:50 ` [PATCH 2/3] xfs: remove XFS_ILOG_NONCORE Christoph Hellwig
2025-01-06 17:09 ` Darrick J. Wong
2025-01-06 18:10 ` Christoph Hellwig
2025-01-06 9:50 ` [PATCH 3/3] xfs: remove the t_magic field in struct xfs_trans Christoph Hellwig
2025-01-06 17:11 ` Darrick J. Wong [this message]
2025-01-14 10:30 ` trivial cleanups Carlos Maiolino
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250106171121.GA6174@frogsfrogsfrogs \
--to=djwong@kernel.org \
--cc=cem@kernel.org \
--cc=hch@lst.de \
--cc=linux-xfs@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.