From: Zhi Wang <zhiw@nvidia.com>
To: <nouveau@lists.freedesktop.org>
Cc: <airlied@gmail.com>, <daniel@ffwll.ch>, <dakr@kernel.org>,
<bskeggs@nvidia.com>, <acurrid@nvidia.com>, <cjia@nvidia.com>,
<smitra@nvidia.com>, <ankita@nvidia.com>, <aniketa@nvidia.com>,
<kwankhede@nvidia.com>, <targupta@nvidia.com>, <zhiw@nvidia.com>,
<zhiwang@kernel.org>
Subject: [PATCH v4 09/15] drm/nouveau: refine the variable names in r535_gsp_rpc_push()
Date: Fri, 24 Jan 2025 10:29:52 -0800 [thread overview]
Message-ID: <20250124182958.2040494-10-zhiw@nvidia.com> (raw)
In-Reply-To: <20250124182958.2040494-1-zhiw@nvidia.com>
The variable names in r535_gsp_rpc_push() are quite confusing and some
of them are not representing what they really are.
Update the names and explanations in the decoder section of the
kernel doc. Refine the names to align with the terms in the kernel doc.
No functional change is intended.
Signed-off-by: Zhi Wang <zhiw@nvidia.com>
---
.../gpu/drm/nouveau/nvkm/subdev/gsp/r535.c | 27 ++++++++++---------
1 file changed, 15 insertions(+), 12 deletions(-)
diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c b/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c
index 442a424d0fed..49dfc1475973 100644
--- a/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c
+++ b/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c
@@ -108,6 +108,9 @@ extern struct dentry *nouveau_debugfs_root;
*
* Terminology:
*
+ * - gsp_msg(msg): GSP message element (element header + GSP RPC header +
+ * payload)
+ * - gsp_rpc(rpc): GSP RPC (RPC header + payload)
* - gsp_rpc_len: size of (GSP RPC header + payload)
* - params_size: size of params in the payload
* - payload_size: size of (header if exists + params) in the payload
@@ -795,30 +798,30 @@ r535_gsp_rpc_push(struct nvkm_gsp *gsp, void *payload, bool wait,
u32 gsp_rpc_len)
{
struct nvfw_gsp_rpc *rpc = to_gsp_hdr(payload, rpc);
- struct r535_gsp_msg *cmd = to_gsp_hdr(rpc, cmd);
- const u32 max_msg_size = GSP_MSG_MAX_SIZE - sizeof(*cmd);
- const u32 max_rpc_size = max_msg_size - sizeof(*rpc);
- u32 rpc_size = rpc->length - sizeof(*rpc);
+ struct r535_gsp_msg *msg = to_gsp_hdr(rpc, msg);
+ const u32 max_rpc_size = GSP_MSG_MAX_SIZE - sizeof(*msg);
+ const u32 max_payload_size = max_rpc_size - sizeof(*rpc);
+ u32 payload_size = rpc->length - sizeof(*rpc);
void *repv;
mutex_lock(&gsp->cmdq.mutex);
- if (rpc_size > max_rpc_size) {
+ if (payload_size > max_payload_size) {
const u32 fn = rpc->function;
/* Adjust length, and send initial RPC. */
- rpc->length = sizeof(*rpc) + max_rpc_size;
- cmd->checksum = rpc->length;
+ rpc->length = sizeof(*rpc) + max_payload_size;
+ msg->checksum = rpc->length;
repv = r535_gsp_rpc_send(gsp, payload, false, 0);
if (IS_ERR(repv))
goto done;
- payload += max_rpc_size;
- rpc_size -= max_rpc_size;
+ payload += max_payload_size;
+ payload_size -= max_payload_size;
/* Remaining chunks sent as CONTINUATION_RECORD RPCs. */
- while (rpc_size) {
- u32 size = min(rpc_size, max_rpc_size);
+ while (payload_size) {
+ u32 size = min(payload_size, max_payload_size);
void *next;
next = r535_gsp_rpc_get(gsp, NV_VGPU_MSG_FUNCTION_CONTINUATION_RECORD, size);
@@ -834,7 +837,7 @@ r535_gsp_rpc_push(struct nvkm_gsp *gsp, void *payload, bool wait,
goto done;
payload += size;
- rpc_size -= size;
+ payload_size -= size;
}
/* Wait for reply. */
--
2.34.1
next prev parent reply other threads:[~2025-01-24 18:30 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-24 18:29 [PATCH v4 00/15] NVKM GSP RPC kernel docs, cleanups and fixes Zhi Wang
2025-01-24 18:29 ` [PATCH v4 01/15] drm/nouveau: add a kernel doc to introduce the GSP RPC Zhi Wang
2025-01-24 18:29 ` [PATCH v4 02/15] drm/nouveau: rename "repc" to "gsp_rpc_len" on the GSP message recv path Zhi Wang
2025-01-24 18:29 ` [PATCH v4 03/15] drm/nouveau: rename "argv" to what it represents on the GSP message send path Zhi Wang
2025-01-24 18:29 ` [PATCH v4 04/15] drm/nouveau: remove unused param repc in *rm_alloc_push() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 05/15] drm/nouveau: rename "argv" to what it represents in *rm_{alloc, ctrl}_*() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 06/15] drm/nouveau: rename "argc" to what it represents in GSP RPC routines Zhi Wang
2025-01-24 18:29 ` [PATCH v4 07/15] drm/nouveau: fix the broken marco GSP_MSG_MAX_SIZE Zhi Wang
2025-01-24 18:29 ` [PATCH v4 08/15] drm/nouveau: remove the magic number in r535_gsp_rpc_push() Zhi Wang
2025-01-24 18:29 ` Zhi Wang [this message]
2025-01-24 18:29 ` [PATCH v4 10/15] drm/nouveau: refine the variable names in r535_gsp_msg_recv() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 11/15] drm/nouveau: rename the variable "cmd" to "msg" in r535_gsp_cmdq_{get, push}() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 12/15] drm/nouveau: factor out r535_gsp_msgq_peek() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 13/15] drm/nouveau: factor out r535_gsp_msgq_recv_one_elem() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 14/15] drm/nouveau: support handling the return of large GSP message Zhi Wang
2025-01-24 18:29 ` [PATCH v4 15/15] drm/nouveau: consume " Zhi Wang
2025-01-24 23:57 ` [PATCH v4 00/15] NVKM GSP RPC kernel docs, cleanups and fixes Danilo Krummrich
2025-01-25 12:52 ` Zhi Wang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250124182958.2040494-10-zhiw@nvidia.com \
--to=zhiw@nvidia.com \
--cc=acurrid@nvidia.com \
--cc=airlied@gmail.com \
--cc=aniketa@nvidia.com \
--cc=ankita@nvidia.com \
--cc=bskeggs@nvidia.com \
--cc=cjia@nvidia.com \
--cc=dakr@kernel.org \
--cc=daniel@ffwll.ch \
--cc=kwankhede@nvidia.com \
--cc=nouveau@lists.freedesktop.org \
--cc=smitra@nvidia.com \
--cc=targupta@nvidia.com \
--cc=zhiwang@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.