From: Zhi Wang <zhiw@nvidia.com>
To: <nouveau@lists.freedesktop.org>
Cc: <airlied@gmail.com>, <daniel@ffwll.ch>, <dakr@kernel.org>,
<bskeggs@nvidia.com>, <acurrid@nvidia.com>, <cjia@nvidia.com>,
<smitra@nvidia.com>, <ankita@nvidia.com>, <aniketa@nvidia.com>,
<kwankhede@nvidia.com>, <targupta@nvidia.com>, <zhiw@nvidia.com>,
<zhiwang@kernel.org>
Subject: [PATCH v4 07/15] drm/nouveau: fix the broken marco GSP_MSG_MAX_SIZE
Date: Fri, 24 Jan 2025 10:29:50 -0800 [thread overview]
Message-ID: <20250124182958.2040494-8-zhiw@nvidia.com> (raw)
In-Reply-To: <20250124182958.2040494-1-zhiw@nvidia.com>
The macro GSP_MSG_MAX_SIZE refers to another macro that doesn't exist.
It represents the max GSP message element size.
Fix the broken marco so it can be used to replace some magic numbers in
the code.
Signed-off-by: Zhi Wang <zhiw@nvidia.com>
---
drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c b/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c
index 92daed69cd46..dab0117d41fd 100644
--- a/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c
+++ b/drivers/gpu/drm/nouveau/nvkm/subdev/gsp/r535.c
@@ -61,7 +61,7 @@
extern struct dentry *nouveau_debugfs_root;
#define GSP_MSG_MIN_SIZE GSP_PAGE_SIZE
-#define GSP_MSG_MAX_SIZE GSP_PAGE_MIN_SIZE * 16
+#define GSP_MSG_MAX_SIZE (GSP_MSG_MIN_SIZE * 16)
/**
* DOC: GSP message queue element
--
2.34.1
next prev parent reply other threads:[~2025-01-24 18:30 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-24 18:29 [PATCH v4 00/15] NVKM GSP RPC kernel docs, cleanups and fixes Zhi Wang
2025-01-24 18:29 ` [PATCH v4 01/15] drm/nouveau: add a kernel doc to introduce the GSP RPC Zhi Wang
2025-01-24 18:29 ` [PATCH v4 02/15] drm/nouveau: rename "repc" to "gsp_rpc_len" on the GSP message recv path Zhi Wang
2025-01-24 18:29 ` [PATCH v4 03/15] drm/nouveau: rename "argv" to what it represents on the GSP message send path Zhi Wang
2025-01-24 18:29 ` [PATCH v4 04/15] drm/nouveau: remove unused param repc in *rm_alloc_push() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 05/15] drm/nouveau: rename "argv" to what it represents in *rm_{alloc, ctrl}_*() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 06/15] drm/nouveau: rename "argc" to what it represents in GSP RPC routines Zhi Wang
2025-01-24 18:29 ` Zhi Wang [this message]
2025-01-24 18:29 ` [PATCH v4 08/15] drm/nouveau: remove the magic number in r535_gsp_rpc_push() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 09/15] drm/nouveau: refine the variable names " Zhi Wang
2025-01-24 18:29 ` [PATCH v4 10/15] drm/nouveau: refine the variable names in r535_gsp_msg_recv() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 11/15] drm/nouveau: rename the variable "cmd" to "msg" in r535_gsp_cmdq_{get, push}() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 12/15] drm/nouveau: factor out r535_gsp_msgq_peek() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 13/15] drm/nouveau: factor out r535_gsp_msgq_recv_one_elem() Zhi Wang
2025-01-24 18:29 ` [PATCH v4 14/15] drm/nouveau: support handling the return of large GSP message Zhi Wang
2025-01-24 18:29 ` [PATCH v4 15/15] drm/nouveau: consume " Zhi Wang
2025-01-24 23:57 ` [PATCH v4 00/15] NVKM GSP RPC kernel docs, cleanups and fixes Danilo Krummrich
2025-01-25 12:52 ` Zhi Wang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250124182958.2040494-8-zhiw@nvidia.com \
--to=zhiw@nvidia.com \
--cc=acurrid@nvidia.com \
--cc=airlied@gmail.com \
--cc=aniketa@nvidia.com \
--cc=ankita@nvidia.com \
--cc=bskeggs@nvidia.com \
--cc=cjia@nvidia.com \
--cc=dakr@kernel.org \
--cc=daniel@ffwll.ch \
--cc=kwankhede@nvidia.com \
--cc=nouveau@lists.freedesktop.org \
--cc=smitra@nvidia.com \
--cc=targupta@nvidia.com \
--cc=zhiwang@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.