All of lore.kernel.org
 help / color / mirror / Atom feed
From: Tom Rini <trini@konsulko.com>
To: Simon Glass <sjg@chromium.org>
Cc: Dmitry Rokosov <ddrokosov@salutedevices.com>,
	Joao Marcos Costa <jmcosta944@gmail.com>,
	Guillaume La Roque <glaroque@baylibre.com>,
	Thomas Petazzoni <thomas.petazzoni@bootlin.com>,
	Miquel Raynal <miquel.raynal@bootlin.com>,
	Patrick Rudolph <patrick.rudolph@9elements.com>,
	William Zhang <william.zhang@broadcom.com>,
	Stephen Warren <swarren@nvidia.com>,
	Sean Anderson <sean.anderson@seco.com>,
	Richard Weinberger <richard@nod.at>,
	Michal Simek <michal.simek@amd.com>,
	Peter Robinson <pbrobinson@gmail.com>,
	Roger Knecht <rknecht@pm.me>,
	Julien Masson <jmasson@baylibre.com>,
	Weizhao Ouyang <o451686892@gmail.com>,
	Jerome Forissier <jerome.forissier@linaro.org>,
	Stephen Warren <swarren@wwwdotorg.org>,
	Tim Harvey <tharvey@gateworks.com>,
	Love Kumar <love.kumar@amd.com>,
	Igor Opaniuk <igor.opaniuk@gmail.com>,
	Sam Protsenko <semen.protsenko@linaro.org>,
	Andrew Goodbody <andrew.goodbody@linaro.org>,
	Caleb Connolly <caleb.connolly@linaro.org>,
	U-Boot Mailing List <u-boot@lists.denx.de>,
	Mattijs Korpershoek <mkorpershoek@baylibre.com>,
	Padmarao Begari <padmarao.begari@amd.com>,
	Heinrich Schuchardt <xypron.glpk@gmx.de>,
	linux-erofs@lists.ozlabs.org,
	Jens Wiklander <jens.wiklander@linaro.org>
Subject: Re: [PATCH 1/4] test/py: Shorten u_boot_console
Date: Sat, 25 Jan 2025 16:55:10 -0600	[thread overview]
Message-ID: <20250125225510.GJ60249@bill-the-cat> (raw)
In-Reply-To: <CAFLszTjG0P0bdwziV4irtiU1JGNMwnoiLO9xhPxLQa9GZPVBtA@mail.gmail.com>

[-- Attachment #1: Type: text/plain, Size: 1690 bytes --]

On Sat, Jan 25, 2025 at 03:42:00PM -0700, Simon Glass wrote:
> Hi Tom,
> 
> On Sat, 25 Jan 2025 at 14:51, Tom Rini <trini@konsulko.com> wrote:
> >
> > On Sat, Jan 25, 2025 at 02:31:36PM -0700, Simon Glass wrote:
> >
> > > This fixture name is quite long and results in lots of verbose code.
> > > We know this is U-Boot so the 'u_boot_' part is not necessary.
> > >
> > > But it is also a bit of a misnomer, since it provides access to all the
> > > information available to tests. It is not just the console.
> > >
> > > It would be too confusing to use con as it would be confused with
> > > config and it is probably too short.
> > >
> > > So shorten it to 'ubpy'.
> > >
> > > Signed-off-by: Simon Glass <sjg@chromium.org>
> > [snip]
> > >  102 files changed, 2591 insertions(+), 2591 deletions(-)
> >
> > First, I'm not sure I like "ubpy". I believe "u_boot_console" is because
> > it's how we interact with the stdin/stdout of the running U-Boot. And
> > indeed it provides more than that. But ubpy is too abstract and unclear,
> > and looking at the diffstat, I don't know that big global rename is
> > justified to save text space.
> 
> I actually get quite confused hunting around in the fixtures so I
> suspect others do too. I would like to settle on some better names.
> 
> Yes, I don't like ubpy much, either. Your favourite AI suggests
> 'fixture' or 'test_env', both I which I prefer. The only challenge is
> that 'env' has various other meanings in U-Boot.

Yes, until someone has a better suggestion than "ubpy", we should leave
things alone. "fixture" has its own meaning within pytest and so that
would also be confusing.

-- 
Tom

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 659 bytes --]

WARNING: multiple messages have this Message-ID (diff)
From: Tom Rini <trini@konsulko.com>
To: Simon Glass <sjg@chromium.org>
Cc: U-Boot Mailing List <u-boot@lists.denx.de>,
	Andrew Goodbody <andrew.goodbody@linaro.org>,
	Caleb Connolly <caleb.connolly@linaro.org>,
	Dmitry Rokosov <ddrokosov@salutedevices.com>,
	Guillaume La Roque <glaroque@baylibre.com>,
	Heinrich Schuchardt <xypron.glpk@gmx.de>,
	Huang Jianan <jnhuang95@gmail.com>,
	Igor Opaniuk <igor.opaniuk@gmail.com>,
	Jens Wiklander <jens.wiklander@linaro.org>,
	Jerome Forissier <jerome.forissier@linaro.org>,
	Joao Marcos Costa <jmcosta944@gmail.com>,
	Julien Masson <jmasson@baylibre.com>,
	Love Kumar <love.kumar@amd.com>,
	Mattijs Korpershoek <mkorpershoek@baylibre.com>,
	Michal Simek <michal.simek@amd.com>,
	Miquel Raynal <miquel.raynal@bootlin.com>,
	Padmarao Begari <padmarao.begari@amd.com>,
	Patrick Rudolph <patrick.rudolph@9elements.com>,
	Peter Robinson <pbrobinson@gmail.com>,
	Richard Weinberger <richard@nod.at>, Roger Knecht <rknecht@pm.me>,
	Sam Protsenko <semen.protsenko@linaro.org>,
	Sean Anderson <sean.anderson@seco.com>,
	Stephen Warren <swarren@nvidia.com>,
	Stephen Warren <swarren@wwwdotorg.org>,
	Thomas Petazzoni <thomas.petazzoni@bootlin.com>,
	Tim Harvey <tharvey@gateworks.com>,
	Weizhao Ouyang <o451686892@gmail.com>,
	William Zhang <william.zhang@broadcom.com>,
	linux-erofs@lists.ozlabs.org
Subject: Re: [PATCH 1/4] test/py: Shorten u_boot_console
Date: Sat, 25 Jan 2025 16:55:10 -0600	[thread overview]
Message-ID: <20250125225510.GJ60249@bill-the-cat> (raw)
In-Reply-To: <CAFLszTjG0P0bdwziV4irtiU1JGNMwnoiLO9xhPxLQa9GZPVBtA@mail.gmail.com>

[-- Attachment #1: Type: text/plain, Size: 1690 bytes --]

On Sat, Jan 25, 2025 at 03:42:00PM -0700, Simon Glass wrote:
> Hi Tom,
> 
> On Sat, 25 Jan 2025 at 14:51, Tom Rini <trini@konsulko.com> wrote:
> >
> > On Sat, Jan 25, 2025 at 02:31:36PM -0700, Simon Glass wrote:
> >
> > > This fixture name is quite long and results in lots of verbose code.
> > > We know this is U-Boot so the 'u_boot_' part is not necessary.
> > >
> > > But it is also a bit of a misnomer, since it provides access to all the
> > > information available to tests. It is not just the console.
> > >
> > > It would be too confusing to use con as it would be confused with
> > > config and it is probably too short.
> > >
> > > So shorten it to 'ubpy'.
> > >
> > > Signed-off-by: Simon Glass <sjg@chromium.org>
> > [snip]
> > >  102 files changed, 2591 insertions(+), 2591 deletions(-)
> >
> > First, I'm not sure I like "ubpy". I believe "u_boot_console" is because
> > it's how we interact with the stdin/stdout of the running U-Boot. And
> > indeed it provides more than that. But ubpy is too abstract and unclear,
> > and looking at the diffstat, I don't know that big global rename is
> > justified to save text space.
> 
> I actually get quite confused hunting around in the fixtures so I
> suspect others do too. I would like to settle on some better names.
> 
> Yes, I don't like ubpy much, either. Your favourite AI suggests
> 'fixture' or 'test_env', both I which I prefer. The only challenge is
> that 'env' has various other meanings in U-Boot.

Yes, until someone has a better suggestion than "ubpy", we should leave
things alone. "fixture" has its own meaning within pytest and so that
would also be confusing.

-- 
Tom

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 659 bytes --]

  reply	other threads:[~2025-01-25 22:55 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-01-25 21:31 [PATCH 0/4] test: A few quality-of-life improvements Simon Glass
2025-01-25 21:31 ` Simon Glass
2025-01-25 21:31 ` [PATCH 1/4] test/py: Shorten u_boot_console Simon Glass
2025-01-25 21:50   ` Tom Rini
2025-01-25 21:50     ` Tom Rini
2025-01-25 22:42     ` Simon Glass
2025-01-25 22:42       ` Simon Glass
2025-01-25 22:55       ` Tom Rini [this message]
2025-01-25 22:55         ` Tom Rini
2025-01-25 22:58         ` Simon Glass
2025-01-25 22:58           ` Simon Glass
2025-02-03  6:04           ` Love Kumar via Linux-erofs
2025-02-03  6:04             ` Love Kumar
2025-02-09 14:29             ` Simon Glass
2025-02-09 14:29               ` Simon Glass
2025-01-25 21:31 ` [PATCH 2/4] test: Drop u_boot_ prefix on test files Simon Glass
2025-01-25 21:46   ` Tom Rini
2025-01-25 22:41     ` Simon Glass
2025-01-25 22:57       ` Tom Rini
2025-01-25 22:59         ` Simon Glass
2025-01-25 21:31 ` [PATCH 3/4] test/py: Show info about module-loading Simon Glass
2025-01-25 21:43   ` Tom Rini
2025-01-25 23:00     ` Simon Glass
2025-01-25 23:02       ` Tom Rini
2025-01-25 23:39         ` Simon Glass
2025-01-25 23:53           ` Tom Rini
2025-01-25 21:31 ` [PATCH 4/4] test: Make net tests depend on CONFIG_CMD_NET Simon Glass
2025-01-25 21:44   ` Tom Rini
2025-01-25 22:47     ` Simon Glass
2025-01-25 22:50       ` Tom Rini
2025-01-25 22:56         ` Simon Glass
2025-01-25 23:00           ` Tom Rini
2025-02-15 13:02             ` Simon Glass
2025-02-15 14:37               ` Tom Rini
2025-02-15 17:21                 ` Simon Glass

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250125225510.GJ60249@bill-the-cat \
    --to=trini@konsulko.com \
    --cc=andrew.goodbody@linaro.org \
    --cc=caleb.connolly@linaro.org \
    --cc=ddrokosov@salutedevices.com \
    --cc=glaroque@baylibre.com \
    --cc=igor.opaniuk@gmail.com \
    --cc=jens.wiklander@linaro.org \
    --cc=jerome.forissier@linaro.org \
    --cc=jmasson@baylibre.com \
    --cc=jmcosta944@gmail.com \
    --cc=linux-erofs@lists.ozlabs.org \
    --cc=love.kumar@amd.com \
    --cc=michal.simek@amd.com \
    --cc=miquel.raynal@bootlin.com \
    --cc=mkorpershoek@baylibre.com \
    --cc=o451686892@gmail.com \
    --cc=padmarao.begari@amd.com \
    --cc=patrick.rudolph@9elements.com \
    --cc=pbrobinson@gmail.com \
    --cc=richard@nod.at \
    --cc=rknecht@pm.me \
    --cc=sean.anderson@seco.com \
    --cc=semen.protsenko@linaro.org \
    --cc=sjg@chromium.org \
    --cc=swarren@nvidia.com \
    --cc=swarren@wwwdotorg.org \
    --cc=tharvey@gateworks.com \
    --cc=thomas.petazzoni@bootlin.com \
    --cc=u-boot@lists.denx.de \
    --cc=william.zhang@broadcom.com \
    --cc=xypron.glpk@gmx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.