All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: qemu-devel@nongnu.org
Cc: stefanha@redhat.com, Zhang Boyang <zhangboyang.id@gmail.com>
Subject: [PULL v2 4/8] qapi/ui: Fix documentation of upper bound value in InputMoveEvent
Date: Mon, 10 Feb 2025 16:01:02 +0100	[thread overview]
Message-ID: <20250210150106.3924507-5-armbru@redhat.com> (raw)
In-Reply-To: <20250210150106.3924507-1-armbru@redhat.com>

From: Zhang Boyang <zhangboyang.id@gmail.com>

The upper bound of pointer position in InputMoveEvent should be 0x7fff,
according to INPUT_EVENT_ABS_MAX.

Signed-off-by: Zhang Boyang <zhangboyang.id@gmail.com>
Message-ID: <20250116104433.12114-1-zhangboyang.id@gmail.com>
Acked-by: Markus Armbruster <armbru@redhat.com>
[Phrasing tweak squashed in]
Signed-off-by: Markus Armbruster <armbru@redhat.com>
---
 qapi/ui.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/qapi/ui.json b/qapi/ui.json
index 460a26b981..c536d4e524 100644
--- a/qapi/ui.json
+++ b/qapi/ui.json
@@ -1133,7 +1133,7 @@
 # @axis: Which axis is referenced by @value.
 #
 # @value: Pointer position.  For absolute coordinates the valid range
-#     is 0 -> 0x7ffff
+#     is 0 to 0x7fff.
 #
 # Since: 2.0
 ##
-- 
2.48.1



  parent reply	other threads:[~2025-02-10 15:02 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-10 15:00 [PULL v2 0/8] QAPI patches patches for 2025-02-10 Markus Armbruster
2025-02-10 15:00 ` [PULL v2 1/8] qapi: Move include/qapi/qmp/ to include/qobject/ Markus Armbruster
2025-02-10 15:01 ` [PULL v2 2/8] qapi: Move and rename qapi/qmp/dispatch.h to qapi/qmp-registry.h Markus Armbruster
2025-02-10 15:01 ` [PULL v2 3/8] qapi: fix colon in Since tag section Markus Armbruster
2025-02-10 15:01 ` Markus Armbruster [this message]
2025-02-10 15:01 ` [PULL v2 5/8] qapi: cope with feature names containing a '-' Markus Armbruster
2025-02-10 15:01 ` [PULL v2 6/8] qapi: change 'unsigned special_features' to 'uint64_t features' Markus Armbruster
2025-02-10 15:01 ` [PULL v2 7/8] qapi: rename 'special_features' to 'features' Markus Armbruster
2025-02-10 15:01 ` [PULL v2 8/8] qapi: expose all schema features to code Markus Armbruster
2025-02-10 18:20 ` [PULL v2 0/8] QAPI patches patches for 2025-02-10 Stefan Hajnoczi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250210150106.3924507-5-armbru@redhat.com \
    --to=armbru@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=stefanha@redhat.com \
    --cc=zhangboyang.id@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.