From: Jonathan Cameron <jic23@kernel.org>
To: David Lechner <dlechner@baylibre.com>
Cc: "Linus Walleij" <linus.walleij@linaro.org>,
"Bartosz Golaszewski" <brgl@bgdev.pl>,
"Andy Shevchenko" <andy@kernel.org>,
"Geert Uytterhoeven" <geert@linux-m68k.org>,
"Lars-Peter Clausen" <lars@metafoo.de>,
"Michael Hennerich" <Michael.Hennerich@analog.com>,
"Ulf Hansson" <ulf.hansson@linaro.org>,
"Peter Rosin" <peda@axentia.se>, "Andrew Lunn" <andrew@lunn.ch>,
"Heiner Kallweit" <hkallweit1@gmail.com>,
"Russell King" <linux@armlinux.org.uk>,
"David S. Miller" <davem@davemloft.net>,
"Eric Dumazet" <edumazet@google.com>,
"Jakub Kicinski" <kuba@kernel.org>,
"Paolo Abeni" <pabeni@redhat.com>,
"Vinod Koul" <vkoul@kernel.org>,
"Kishon Vijay Abraham I" <kishon@kernel.org>,
"Nuno Sá" <nuno.sa@analog.com>,
"Liam Girdwood" <lgirdwood@gmail.com>,
"Mark Brown" <broonie@kernel.org>,
"Jaroslav Kysela" <perex@perex.cz>,
"Takashi Iwai" <tiwai@suse.com>,
linux-gpio@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-iio@vger.kernel.org, linux-mmc@vger.kernel.org,
netdev@vger.kernel.org, linux-phy@lists.infradead.org,
linux-sound@vger.kernel.org,
"Andy Shevchenko" <andy.shevchenko@gmail.com>,
"Jonathan Cameron" <Jonathan.Cameron@huawei.com>
Subject: Re: [PATCH v3 00/15] gpiolib: add gpiod_multi_set_value_cansleep
Date: Mon, 17 Feb 2025 13:21:52 +0000 [thread overview]
Message-ID: <20250217132152.29d86d6c@jic23-huawei> (raw)
In-Reply-To: <20250210-gpio-set-array-helper-v3-0-d6a673674da8@baylibre.com>
On Mon, 10 Feb 2025 16:33:26 -0600
David Lechner <dlechner@baylibre.com> wrote:
> This series was inspired by some minor annoyance I have experienced a
> few times in recent reviews.
>
> Calling gpiod_set_array_value_cansleep() can be quite verbose due to
> having so many parameters. In most cases, we already have a struct
> gpio_descs that contains the first 3 parameters so we end up with 3 (or
> often even 6) pointer indirections at each call site. Also, people have
> a tendency to want to hard-code the first argument instead of using
> struct gpio_descs.ndescs, often without checking that ndescs >= the
> hard-coded value.
>
> So I'm proposing that we add a gpiod_multi_set_value_cansleep()
> function that is a wrapper around gpiod_set_array_value_cansleep()
> that has struct gpio_descs as the first parameter to make it a bit
> easier to read the code and avoid the hard-coding temptation.
>
> I've just done gpiod_multi_set_value_cansleep() for now since there
> were over 10 callers of this one. There aren't as many callers of
> the get and atomic variants, but we can add those too if this seems
> like a useful thing to do.
>
> Maintainers, if you prefer to have this go through the gpio tree, please
> give your Acked-by:. Several maintainers have also requested an
> immutable branch, so I expect that will be made available. And if there
> is anything leftover after the next kernel release, I will resend it.
I've applied 7-10 to the IIO tree after merging the immutable tag with patch 1.
Jonathan
>
> ---
> Changes in v3:
> - Added IS_ERR_OR_NULL() check to gpiod_multi_set_value_cansleep()
> - Added new patches to clean up accessing bitmap directly (ts-nbus, ad2s1210).
> - Added function prefix for max3191x.
> - Removed unnecessary braces in ad7606 patch.
> - Picked up additional trailers.
> - Link to v2: https://lore.kernel.org/r/20250206-gpio-set-array-helper-v2-0-1c5f048f79c3@baylibre.com
>
> Changes in v2:
> - Renamed new function from gpiods_multi_set_value_cansleep() to
> gpiod_multi_set_value_cansleep()
> - Fixed typo in name of replaced function in all commit messages.
> - Picked up trailers.
> - Link to v1: https://lore.kernel.org/r/20250131-gpio-set-array-helper-v1-0-991c8ccb4d6e@baylibre.com
>
> ---
> David Lechner (15):
> gpiolib: add gpiod_multi_set_value_cansleep()
> auxdisplay: seg-led-gpio: use gpiod_multi_set_value_cansleep
> bus: ts-nbus: validate ts,data-gpios array size
> bus: ts-nbus: use gpiod_multi_set_value_cansleep
> bus: ts-nbus: use bitmap_get_value8()
> gpio: max3191x: use gpiod_multi_set_value_cansleep
> iio: adc: ad7606: use gpiod_multi_set_value_cansleep
> iio: amplifiers: hmc425a: use gpiod_multi_set_value_cansleep
> iio: resolver: ad2s1210: use gpiod_multi_set_value_cansleep
> iio: resolver: ad2s1210: use bitmap_write
> mmc: pwrseq_simple: use gpiod_multi_set_value_cansleep
> mux: gpio: use gpiod_multi_set_value_cansleep
> net: mdio: mux-gpio: use gpiod_multi_set_value_cansleep
> phy: mapphone-mdm6600: use gpiod_multi_set_value_cansleep
> ASoC: adau1701: use gpiod_multi_set_value_cansleep
>
> drivers/auxdisplay/seg-led-gpio.c | 3 +--
> drivers/bus/ts-nbus.c | 15 +++++++++------
> drivers/gpio/gpio-max3191x.c | 18 +++++++-----------
> drivers/iio/adc/ad7606.c | 3 +--
> drivers/iio/adc/ad7606_spi.c | 7 +++----
> drivers/iio/amplifiers/hmc425a.c | 3 +--
> drivers/iio/resolver/ad2s1210.c | 13 +++++--------
> drivers/mmc/core/pwrseq_simple.c | 3 +--
> drivers/mux/gpio.c | 4 +---
> drivers/net/mdio/mdio-mux-gpio.c | 3 +--
> drivers/phy/motorola/phy-mapphone-mdm6600.c | 4 +---
> include/linux/gpio/consumer.h | 11 +++++++++++
> sound/soc/codecs/adau1701.c | 4 +---
> 13 files changed, 43 insertions(+), 48 deletions(-)
> ---
> base-commit: df4b2bbff898227db0c14264ac7edd634e79f755
> change-id: 20250131-gpio-set-array-helper-bd4a328370d3
>
> Best regards,
WARNING: multiple messages have this Message-ID (diff)
From: Jonathan Cameron <jic23@kernel.org>
To: David Lechner <dlechner@baylibre.com>
Cc: "Linus Walleij" <linus.walleij@linaro.org>,
"Bartosz Golaszewski" <brgl@bgdev.pl>,
"Andy Shevchenko" <andy@kernel.org>,
"Geert Uytterhoeven" <geert@linux-m68k.org>,
"Lars-Peter Clausen" <lars@metafoo.de>,
"Michael Hennerich" <Michael.Hennerich@analog.com>,
"Ulf Hansson" <ulf.hansson@linaro.org>,
"Peter Rosin" <peda@axentia.se>, "Andrew Lunn" <andrew@lunn.ch>,
"Heiner Kallweit" <hkallweit1@gmail.com>,
"Russell King" <linux@armlinux.org.uk>,
"David S. Miller" <davem@davemloft.net>,
"Eric Dumazet" <edumazet@google.com>,
"Jakub Kicinski" <kuba@kernel.org>,
"Paolo Abeni" <pabeni@redhat.com>,
"Vinod Koul" <vkoul@kernel.org>,
"Kishon Vijay Abraham I" <kishon@kernel.org>,
"Nuno Sá" <nuno.sa@analog.com>,
"Liam Girdwood" <lgirdwood@gmail.com>,
"Mark Brown" <broonie@kernel.org>,
"Jaroslav Kysela" <perex@perex.cz>,
"Takashi Iwai" <tiwai@suse.com>,
linux-gpio@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-iio@vger.kernel.org, linux-mmc@vger.kernel.org,
netdev@vger.kernel.org, linux-phy@lists.infradead.org,
linux-sound@vger.kernel.org,
"Andy Shevchenko" <andy.shevchenko@gmail.com>,
"Jonathan Cameron" <Jonathan.Cameron@huawei.com>
Subject: Re: [PATCH v3 00/15] gpiolib: add gpiod_multi_set_value_cansleep
Date: Mon, 17 Feb 2025 13:21:52 +0000 [thread overview]
Message-ID: <20250217132152.29d86d6c@jic23-huawei> (raw)
In-Reply-To: <20250210-gpio-set-array-helper-v3-0-d6a673674da8@baylibre.com>
On Mon, 10 Feb 2025 16:33:26 -0600
David Lechner <dlechner@baylibre.com> wrote:
> This series was inspired by some minor annoyance I have experienced a
> few times in recent reviews.
>
> Calling gpiod_set_array_value_cansleep() can be quite verbose due to
> having so many parameters. In most cases, we already have a struct
> gpio_descs that contains the first 3 parameters so we end up with 3 (or
> often even 6) pointer indirections at each call site. Also, people have
> a tendency to want to hard-code the first argument instead of using
> struct gpio_descs.ndescs, often without checking that ndescs >= the
> hard-coded value.
>
> So I'm proposing that we add a gpiod_multi_set_value_cansleep()
> function that is a wrapper around gpiod_set_array_value_cansleep()
> that has struct gpio_descs as the first parameter to make it a bit
> easier to read the code and avoid the hard-coding temptation.
>
> I've just done gpiod_multi_set_value_cansleep() for now since there
> were over 10 callers of this one. There aren't as many callers of
> the get and atomic variants, but we can add those too if this seems
> like a useful thing to do.
>
> Maintainers, if you prefer to have this go through the gpio tree, please
> give your Acked-by:. Several maintainers have also requested an
> immutable branch, so I expect that will be made available. And if there
> is anything leftover after the next kernel release, I will resend it.
I've applied 7-10 to the IIO tree after merging the immutable tag with patch 1.
Jonathan
>
> ---
> Changes in v3:
> - Added IS_ERR_OR_NULL() check to gpiod_multi_set_value_cansleep()
> - Added new patches to clean up accessing bitmap directly (ts-nbus, ad2s1210).
> - Added function prefix for max3191x.
> - Removed unnecessary braces in ad7606 patch.
> - Picked up additional trailers.
> - Link to v2: https://lore.kernel.org/r/20250206-gpio-set-array-helper-v2-0-1c5f048f79c3@baylibre.com
>
> Changes in v2:
> - Renamed new function from gpiods_multi_set_value_cansleep() to
> gpiod_multi_set_value_cansleep()
> - Fixed typo in name of replaced function in all commit messages.
> - Picked up trailers.
> - Link to v1: https://lore.kernel.org/r/20250131-gpio-set-array-helper-v1-0-991c8ccb4d6e@baylibre.com
>
> ---
> David Lechner (15):
> gpiolib: add gpiod_multi_set_value_cansleep()
> auxdisplay: seg-led-gpio: use gpiod_multi_set_value_cansleep
> bus: ts-nbus: validate ts,data-gpios array size
> bus: ts-nbus: use gpiod_multi_set_value_cansleep
> bus: ts-nbus: use bitmap_get_value8()
> gpio: max3191x: use gpiod_multi_set_value_cansleep
> iio: adc: ad7606: use gpiod_multi_set_value_cansleep
> iio: amplifiers: hmc425a: use gpiod_multi_set_value_cansleep
> iio: resolver: ad2s1210: use gpiod_multi_set_value_cansleep
> iio: resolver: ad2s1210: use bitmap_write
> mmc: pwrseq_simple: use gpiod_multi_set_value_cansleep
> mux: gpio: use gpiod_multi_set_value_cansleep
> net: mdio: mux-gpio: use gpiod_multi_set_value_cansleep
> phy: mapphone-mdm6600: use gpiod_multi_set_value_cansleep
> ASoC: adau1701: use gpiod_multi_set_value_cansleep
>
> drivers/auxdisplay/seg-led-gpio.c | 3 +--
> drivers/bus/ts-nbus.c | 15 +++++++++------
> drivers/gpio/gpio-max3191x.c | 18 +++++++-----------
> drivers/iio/adc/ad7606.c | 3 +--
> drivers/iio/adc/ad7606_spi.c | 7 +++----
> drivers/iio/amplifiers/hmc425a.c | 3 +--
> drivers/iio/resolver/ad2s1210.c | 13 +++++--------
> drivers/mmc/core/pwrseq_simple.c | 3 +--
> drivers/mux/gpio.c | 4 +---
> drivers/net/mdio/mdio-mux-gpio.c | 3 +--
> drivers/phy/motorola/phy-mapphone-mdm6600.c | 4 +---
> include/linux/gpio/consumer.h | 11 +++++++++++
> sound/soc/codecs/adau1701.c | 4 +---
> 13 files changed, 43 insertions(+), 48 deletions(-)
> ---
> base-commit: df4b2bbff898227db0c14264ac7edd634e79f755
> change-id: 20250131-gpio-set-array-helper-bd4a328370d3
>
> Best regards,
--
linux-phy mailing list
linux-phy@lists.infradead.org
https://lists.infradead.org/mailman/listinfo/linux-phy
next prev parent reply other threads:[~2025-02-17 13:22 UTC|newest]
Thread overview: 100+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-10 22:33 [PATCH v3 00/15] gpiolib: add gpiod_multi_set_value_cansleep David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-10 22:33 ` [PATCH v3 01/15] gpiolib: add gpiod_multi_set_value_cansleep() David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-11 7:35 ` Geert Uytterhoeven
2025-02-11 7:35 ` Geert Uytterhoeven
2025-02-11 9:39 ` Andy Shevchenko
2025-02-11 9:39 ` Andy Shevchenko
2025-02-14 9:22 ` Linus Walleij
2025-02-14 9:22 ` Linus Walleij
2025-02-10 22:33 ` [PATCH v3 02/15] auxdisplay: seg-led-gpio: use gpiod_multi_set_value_cansleep David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-12 10:51 ` Andy Shevchenko
2025-02-12 10:51 ` Andy Shevchenko
2025-02-10 22:33 ` [PATCH v3 03/15] bus: ts-nbus: validate ts,data-gpios array size David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-10 22:33 ` [PATCH v3 04/15] bus: ts-nbus: use gpiod_multi_set_value_cansleep David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-10 22:33 ` [PATCH v3 05/15] bus: ts-nbus: use bitmap_get_value8() David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-11 9:40 ` Andy Shevchenko
2025-02-11 9:40 ` Andy Shevchenko
2025-02-20 10:17 ` Simon Horman
2025-02-20 10:17 ` Simon Horman
2025-02-20 12:06 ` Andy Shevchenko
2025-02-20 12:06 ` Andy Shevchenko
2025-02-20 17:16 ` David Lechner
2025-02-20 17:16 ` David Lechner
2025-02-20 17:32 ` David Lechner
2025-02-20 17:32 ` David Lechner
2025-02-21 9:24 ` Simon Horman
2025-02-21 9:24 ` Simon Horman
2025-02-10 22:33 ` [PATCH v3 06/15] gpio: max3191x: use gpiod_multi_set_value_cansleep David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-11 9:42 ` Andy Shevchenko
2025-02-11 9:42 ` Andy Shevchenko
2025-02-10 22:33 ` [PATCH v3 07/15] iio: adc: ad7606: " David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-17 13:18 ` Jonathan Cameron
2025-02-17 13:18 ` Jonathan Cameron
2025-02-10 22:33 ` [PATCH v3 08/15] iio: amplifiers: hmc425a: " David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-10 22:33 ` [PATCH v3 09/15] iio: resolver: ad2s1210: " David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-10 22:33 ` [PATCH v3 10/15] iio: resolver: ad2s1210: use bitmap_write David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-11 19:46 ` Jonathan Cameron
2025-02-11 19:46 ` Jonathan Cameron
2025-02-20 20:54 ` David Lechner
2025-02-20 20:54 ` David Lechner
2025-02-22 11:38 ` Jonathan Cameron
2025-02-22 11:38 ` Jonathan Cameron
2025-02-22 11:51 ` Jonathan Cameron
2025-02-22 11:51 ` Jonathan Cameron
2025-02-10 22:33 ` [PATCH v3 11/15] mmc: pwrseq_simple: use gpiod_multi_set_value_cansleep David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-10 22:33 ` [PATCH v3 12/15] mux: gpio: " David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-10 22:33 ` [PATCH v3 13/15] net: mdio: mux-gpio: " David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-10 22:33 ` [PATCH v3 14/15] phy: mapphone-mdm6600: " David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-13 17:21 ` Vinod Koul
2025-02-13 17:21 ` Vinod Koul
2025-02-10 22:33 ` [PATCH v3 15/15] ASoC: adau1701: " David Lechner
2025-02-10 22:33 ` David Lechner
2025-02-12 9:36 ` (subset) [PATCH v3 00/15] gpiolib: add gpiod_multi_set_value_cansleep Bartosz Golaszewski
2025-02-12 9:36 ` Bartosz Golaszewski
2025-02-12 9:36 ` Bartosz Golaszewski
2025-02-12 9:36 ` Bartosz Golaszewski
2025-02-13 17:25 ` David Lechner
2025-02-13 17:25 ` David Lechner
2025-02-13 17:37 ` Andy Shevchenko
2025-02-13 17:37 ` Andy Shevchenko
2025-02-13 17:42 ` Bartosz Golaszewski
2025-02-13 17:42 ` Bartosz Golaszewski
2025-02-13 17:52 ` Mark Brown
2025-02-13 17:52 ` Mark Brown
2025-02-13 17:58 ` Bartosz Golaszewski
2025-02-13 17:58 ` Bartosz Golaszewski
2025-02-13 18:04 ` Mark Brown
2025-02-13 18:04 ` Mark Brown
2025-02-13 18:26 ` Mark Brown
2025-02-13 18:26 ` Mark Brown
2025-02-14 10:20 ` Bartosz Golaszewski
2025-02-14 10:20 ` Bartosz Golaszewski
2025-02-14 14:35 ` Andy Shevchenko
2025-02-14 14:35 ` Andy Shevchenko
2025-02-14 14:37 ` Bartosz Golaszewski
2025-02-14 14:37 ` Bartosz Golaszewski
2025-02-16 14:23 ` Jonathan Cameron
2025-02-16 14:23 ` Jonathan Cameron
2025-02-16 15:55 ` Bartosz Golaszewski
2025-02-16 15:55 ` Bartosz Golaszewski
2025-02-17 13:11 ` Jonathan Cameron
2025-02-17 13:11 ` Jonathan Cameron
2025-02-17 13:24 ` Bartosz Golaszewski
2025-02-17 13:24 ` Bartosz Golaszewski
2025-02-17 13:21 ` Jonathan Cameron [this message]
2025-02-17 13:21 ` Jonathan Cameron
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250217132152.29d86d6c@jic23-huawei \
--to=jic23@kernel.org \
--cc=Jonathan.Cameron@huawei.com \
--cc=Michael.Hennerich@analog.com \
--cc=andrew@lunn.ch \
--cc=andy.shevchenko@gmail.com \
--cc=andy@kernel.org \
--cc=brgl@bgdev.pl \
--cc=broonie@kernel.org \
--cc=davem@davemloft.net \
--cc=dlechner@baylibre.com \
--cc=edumazet@google.com \
--cc=geert@linux-m68k.org \
--cc=hkallweit1@gmail.com \
--cc=kishon@kernel.org \
--cc=kuba@kernel.org \
--cc=lars@metafoo.de \
--cc=lgirdwood@gmail.com \
--cc=linus.walleij@linaro.org \
--cc=linux-gpio@vger.kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mmc@vger.kernel.org \
--cc=linux-phy@lists.infradead.org \
--cc=linux-sound@vger.kernel.org \
--cc=linux@armlinux.org.uk \
--cc=netdev@vger.kernel.org \
--cc=nuno.sa@analog.com \
--cc=pabeni@redhat.com \
--cc=peda@axentia.se \
--cc=perex@perex.cz \
--cc=tiwai@suse.com \
--cc=ulf.hansson@linaro.org \
--cc=vkoul@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.