From: Simon Horman <horms@kernel.org>
To: Martyna Szapar-Mudlaw <martyna.szapar-mudlaw@linux.intel.com>
Cc: intel-wired-lan@lists.osuosl.org, netdev@vger.kernel.org,
Mateusz Polchlopek <mateusz.polchlopek@intel.com>,
Marcin Szycik <marcin.szycik@linux.intel.com>,
Michal Swiatkowski <michal.swiatkowski@linux.intel.com>,
Jedrzej Jagielski <jedrzej.jagielski@intel.com>,
Przemek Kitszel <przemyslaw.kitszel@intel.com>,
Aleksandr Loktionov <aleksandr.loktionov@intel.com>
Subject: Re: [Intel-wired-lan] [iwl-next v2] ice: refactor the Tx scheduler feature
Date: Sun, 16 Mar 2025 13:15:45 +0000 [thread overview]
Message-ID: <20250316131545.GY4159220@kernel.org> (raw)
In-Reply-To: <20250307132555.119902-2-martyna.szapar-mudlaw@linux.intel.com>
On Fri, Mar 07, 2025 at 02:25:56PM +0100, Martyna Szapar-Mudlaw wrote:
> From: Mateusz Polchlopek <mateusz.polchlopek@intel.com>
>
> Simplify the code by eliminating an unnecessary wrapper function.
> Previously, ice_devlink_tx_sched_layers_get() acted as a thin wrapper
> around ice_get_tx_topo_user_sel(), adding no real value but increasing
> code complexity. Since both functions were only used once, the wrapper
> was redundant and contributed approximately 20 lines of unnecessary
> code. Remove ice_get_tx_topo_user_sel() and moves its instructions
> directly into ice_devlink_tx_sched_layers_get(), improving readability
> and reducing function jumps, without altering functionality.
Thanks, this explanation looks good to me.
>
> Also remove unnecessary comment and make usage of str_enabled_disabled() in
> ice_init_tx_topology().
Sorry for not noticing this in my review of v1,
but I would lean towards these changes being separate patches.
That not withstanding, this looks good to me.
Reviewed-by: Simon Horman <horms@kernel.org>
> Suggested-by: Marcin Szycik <marcin.szycik@linux.intel.com>
> Reviewed-by: Michal Swiatkowski <michal.swiatkowski@linux.intel.com>
> Reviewed-by: Jedrzej Jagielski <jedrzej.jagielski@intel.com>
> Reviewed-by: Przemek Kitszel <przemyslaw.kitszel@intel.com>
> Reviewed-by: Aleksandr Loktionov <aleksandr.loktionov@intel.com>
> Signed-off-by: Mateusz Polchlopek <mateusz.polchlopek@intel.com>
> Signed-off-by: Martyna Szapar-Mudlaw <martyna.szapar-mudlaw@linux.intel.com>
...
WARNING: multiple messages have this Message-ID (diff)
From: Simon Horman <horms@kernel.org>
To: Martyna Szapar-Mudlaw <martyna.szapar-mudlaw@linux.intel.com>
Cc: intel-wired-lan@lists.osuosl.org, netdev@vger.kernel.org,
Mateusz Polchlopek <mateusz.polchlopek@intel.com>,
Marcin Szycik <marcin.szycik@linux.intel.com>,
Michal Swiatkowski <michal.swiatkowski@linux.intel.com>,
Jedrzej Jagielski <jedrzej.jagielski@intel.com>,
Przemek Kitszel <przemyslaw.kitszel@intel.com>,
Aleksandr Loktionov <aleksandr.loktionov@intel.com>
Subject: Re: [iwl-next v2] ice: refactor the Tx scheduler feature
Date: Sun, 16 Mar 2025 13:15:45 +0000 [thread overview]
Message-ID: <20250316131545.GY4159220@kernel.org> (raw)
In-Reply-To: <20250307132555.119902-2-martyna.szapar-mudlaw@linux.intel.com>
On Fri, Mar 07, 2025 at 02:25:56PM +0100, Martyna Szapar-Mudlaw wrote:
> From: Mateusz Polchlopek <mateusz.polchlopek@intel.com>
>
> Simplify the code by eliminating an unnecessary wrapper function.
> Previously, ice_devlink_tx_sched_layers_get() acted as a thin wrapper
> around ice_get_tx_topo_user_sel(), adding no real value but increasing
> code complexity. Since both functions were only used once, the wrapper
> was redundant and contributed approximately 20 lines of unnecessary
> code. Remove ice_get_tx_topo_user_sel() and moves its instructions
> directly into ice_devlink_tx_sched_layers_get(), improving readability
> and reducing function jumps, without altering functionality.
Thanks, this explanation looks good to me.
>
> Also remove unnecessary comment and make usage of str_enabled_disabled() in
> ice_init_tx_topology().
Sorry for not noticing this in my review of v1,
but I would lean towards these changes being separate patches.
That not withstanding, this looks good to me.
Reviewed-by: Simon Horman <horms@kernel.org>
> Suggested-by: Marcin Szycik <marcin.szycik@linux.intel.com>
> Reviewed-by: Michal Swiatkowski <michal.swiatkowski@linux.intel.com>
> Reviewed-by: Jedrzej Jagielski <jedrzej.jagielski@intel.com>
> Reviewed-by: Przemek Kitszel <przemyslaw.kitszel@intel.com>
> Reviewed-by: Aleksandr Loktionov <aleksandr.loktionov@intel.com>
> Signed-off-by: Mateusz Polchlopek <mateusz.polchlopek@intel.com>
> Signed-off-by: Martyna Szapar-Mudlaw <martyna.szapar-mudlaw@linux.intel.com>
...
next prev parent reply other threads:[~2025-03-16 13:15 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-07 13:25 [Intel-wired-lan] [iwl-next v2] ice: refactor the Tx scheduler feature Martyna Szapar-Mudlaw
2025-03-07 13:25 ` Martyna Szapar-Mudlaw
2025-03-16 13:15 ` Simon Horman [this message]
2025-03-16 13:15 ` Simon Horman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250316131545.GY4159220@kernel.org \
--to=horms@kernel.org \
--cc=aleksandr.loktionov@intel.com \
--cc=intel-wired-lan@lists.osuosl.org \
--cc=jedrzej.jagielski@intel.com \
--cc=marcin.szycik@linux.intel.com \
--cc=martyna.szapar-mudlaw@linux.intel.com \
--cc=mateusz.polchlopek@intel.com \
--cc=michal.swiatkowski@linux.intel.com \
--cc=netdev@vger.kernel.org \
--cc=przemyslaw.kitszel@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.