From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: Ruben Wauters <rubenru09@aol.com>
Cc: Sudip Mukherjee <sudipm.mukherjee@gmail.com>,
Teddy Wang <teddy.wang@siliconmotion.com>,
Sudip Mukherjee <sudip.mukherjee@codethink.co.uk>,
linux-fbdev@vger.kernel.org, linux-staging@lists.linux.dev,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/8] staging: sm750fb: rename gDviCtrlChipName
Date: Fri, 18 Apr 2025 14:09:30 +0200 [thread overview]
Message-ID: <2025041801-reassign-wager-ea18@gregkh> (raw)
In-Reply-To: <6a47dc48a803b6a07a7fcd33eec8df9e60e86144.camel@aol.com>
On Fri, Apr 18, 2025 at 12:45:28PM +0100, Ruben Wauters wrote:
> On Fri, 2025-04-18 at 12:36 +0200, Greg Kroah-Hartman wrote:
> > On Thu, Apr 17, 2025 at 08:02:50PM +0100, Ruben Wauters wrote:
> > > Renames gDviCtrlChipName to dvi_controller_chip_name
> > > This fixes checkpatch.pl's camel case check.
> > >
> > > Signed-off-by: Ruben Wauters <rubenru09@aol.com>
> > >
> > > ---
> > >
> > > I changed the name to dvi_controller_chip_name as I
> > > believe it is somewhat more descriptive than
> > > g_dvi_ctrl_chip_name. If the second one is wanted instead
> > > please let me know and I will change it
> > > ---
> > > drivers/staging/sm750fb/ddk750_sii164.c | 4 ++--
> > > 1 file changed, 2 insertions(+), 2 deletions(-)
> > >
> > > diff --git a/drivers/staging/sm750fb/ddk750_sii164.c
> > > b/drivers/staging/sm750fb/ddk750_sii164.c
> > > index dd7811b18bf6..d4309e0d807f 100644
> > > --- a/drivers/staging/sm750fb/ddk750_sii164.c
> > > +++ b/drivers/staging/sm750fb/ddk750_sii164.c
> > > @@ -14,7 +14,7 @@
> > >
> > > #ifdef SII164_FULL_FUNCTIONS
> >
> > This is never defined, so instead of papering over variable names
> > that
> > are crazy, why not just remove all of the code in the blocks for this
> > define entirely?
>
> Given the amount of code that is never used and the time went into
> writing this, it does make me wonder whether this code *should* be used
> instead of being removed. I don't know exactly how it would be
> integrated however, removal as of now might be the easiest option, but
> I'm not entirely sure whether it would be the best option in terms of
> functionality.
Just remove it, odds are it was written a long time ago for other
hardware. If someone needs it in the future, the git history has it
there for their use.
thanks,
greg k-h
next prev parent reply other threads:[~2025-04-18 12:09 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20250417190302.13811-1-rubenru09.ref@aol.com>
2025-04-17 19:02 ` [PATCH 0/8] staging: sm750fb: cleanup ddk750_sii164 Ruben Wauters
2025-04-17 19:02 ` [PATCH 1/8] staging: sm250fb: remove USE_HW_I2C check Ruben Wauters
2025-04-18 10:33 ` Greg Kroah-Hartman
2025-04-18 11:42 ` Ruben Wauters
2025-04-17 19:02 ` [PATCH 2/8] staging: sm750fb: rename gDviCtrlChipName Ruben Wauters
2025-04-18 10:36 ` Greg Kroah-Hartman
2025-04-18 11:45 ` Ruben Wauters
2025-04-18 12:09 ` Greg Kroah-Hartman [this message]
2025-04-17 19:02 ` [PATCH 3/8] staging: sm750fb: rename vendorID to vendor_id Ruben Wauters
2025-04-18 10:37 ` Greg Kroah-Hartman
2025-04-17 19:02 ` [PATCH 4/8] staging: sm750fb: rename sii164_init_chip params Ruben Wauters
2025-04-17 19:02 ` [PATCH 5/8] staging: sm750fb: rename sii164_set_power's param Ruben Wauters
2025-04-18 10:34 ` Greg Kroah-Hartman
2025-04-17 19:02 ` [PATCH 6/8] staging: sm750fb: rename sii164SelectHotPlugDetectionMode Ruben Wauters
2025-04-17 19:02 ` [PATCH 7/8] staging: sm750fb: rename detectReg to detect_reg Ruben Wauters
2025-04-17 19:02 ` [PATCH 8/8] staging: sm750fb: rename hotPlugValue to hot_plug_value Ruben Wauters
2025-04-18 10:38 ` Greg Kroah-Hartman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2025041801-reassign-wager-ea18@gregkh \
--to=gregkh@linuxfoundation.org \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=rubenru09@aol.com \
--cc=sudip.mukherjee@codethink.co.uk \
--cc=sudipm.mukherjee@gmail.com \
--cc=teddy.wang@siliconmotion.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.