From: Lothar Rubusch <l.rubusch@gmail.com>
To: jic23@kernel.org, dlechner@baylibre.com, nuno.sa@analog.com,
andy@kernel.org, corbet@lwn.net, lucas.p.stankus@gmail.com,
lars@metafoo.de, Michael.Hennerich@analog.com
Cc: l.rubusch@gmail.com, linux-iio@vger.kernel.org,
linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: [PATCH v3 00/12] iio: accel: adxl313: add power-save on activity/inactivity
Date: Fri, 23 May 2025 22:35:11 +0000 [thread overview]
Message-ID: <20250523223523.35218-1-l.rubusch@gmail.com> (raw)
The patch set covers the following topics:
- add debug register and regmap cache
- prepare iio channel scan_type and scan_index
- prepare interrupt handling
- implement fifo with watermark
- add activity/inactivity together with auto-sleep with link bit
- documentation
Since activity and inactivity here are implemented covering all axis, I
assumed x&y&z. Thus the driver uses a fake channel for activity/inactiviy.
Signed-off-by: Lothar Rubusch <l.rubusch@gmail.com>
---
v2 -> v3:
- verify keeping trailing comma when it's multi-line assignment [v1 02/12]
- adxl313_set_fifo(): verify have two on one line to make it easier to read [v1 07/12]
- adxl313_fifo_transfer(): verify removal of useless initialization of ret [v1 07/12]
- adxl313_fifo_transfer(): verify usage of array_size() from overflow.h [v1 07/12]
- adxl313_fifo_transfer(): verify return 0 here [v1 07/12]
- adxl313_irq_handler(): verify "Why do we need the label?" / moving the call under the conditional [v1 07/12]
- verify reorganization of half condition for Activity [v1 09/12] and Inactivity [v1 10/12]
- verify usage of MICRO instead of 1000000
- adxl313_is_act_inact_en(): restructure according to return logic value, or negative error
- adxl313_set_act_inact_en(): restructure function, use regmap_assign_bits()
- adxl313_set_act_inact_en(): verify makeing it a logical split [v1 11/12]
- adxl313_fifo_transfer(): change iterator variable type from int to unsigned int [v2 07/12]
- adxl313_fifo_reset(): add comment on why reset status registers does not do error check ("At least comment...") [v2 07/12]
- adxl313_fifo_push(): change iterator variable from int to unsigned int [v2 08/12]
- adxl313_fifo_push(): remove duplicate check for samples being <0 [v2 08/12]
- apply regmap_assign_bits() in several places to replace regmap_update_bits() depending on bools
- adxl313_set_watermark(): rename mask variable to make it more comprehensive
- removal of duplicate blanks in various places (sry, my keyboard died) [v1 07/12]
v1 -> v2:
- usage of units.h
- simplify approach for return values
---
Lothar Rubusch (12):
iio: accel: adxl313: add debug register
iio: accel: adxl313: introduce channel scan_index
iio: accel: adxl313: configure scan type for buffer
iio: accel: adxl313: make use of regmap cache
iio: accel: adxl313: add function to enable measurement
iio: accel: adxl313: prepare interrupt handling
iio: accel: adxl313: add basic interrupt handling
iio: accel: adxl313: add FIFO watermark
iio: accel: adxl313: add activity sensing
iio: accel: adxl313: add inactivity sensing
iio: accel: adxl313: implement power-save on inactivity
docs: iio: add ADXL313 accelerometer
Documentation/iio/adxl313.rst | 196 ++++++++++
Documentation/iio/index.rst | 1 +
drivers/iio/accel/adxl313.h | 35 +-
drivers/iio/accel/adxl313_core.c | 625 ++++++++++++++++++++++++++++++-
drivers/iio/accel/adxl313_i2c.c | 6 +
drivers/iio/accel/adxl313_spi.c | 6 +
6 files changed, 859 insertions(+), 10 deletions(-)
create mode 100644 Documentation/iio/adxl313.rst
--
2.39.5
next reply other threads:[~2025-05-23 22:35 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-23 22:35 Lothar Rubusch [this message]
2025-05-23 22:35 ` [PATCH v3 01/12] iio: accel: adxl313: add debug register Lothar Rubusch
2025-05-23 22:35 ` [PATCH v3 02/12] iio: accel: adxl313: introduce channel scan_index Lothar Rubusch
2025-05-25 11:32 ` Jonathan Cameron
2025-05-23 22:35 ` [PATCH v3 03/12] iio: accel: adxl313: configure scan type for buffer Lothar Rubusch
2025-05-25 12:19 ` Jonathan Cameron
2025-05-23 22:35 ` [PATCH v3 04/12] iio: accel: adxl313: make use of regmap cache Lothar Rubusch
2025-05-25 12:22 ` Jonathan Cameron
2025-05-26 20:44 ` Lothar Rubusch
2025-05-23 22:35 ` [PATCH v3 05/12] iio: accel: adxl313: add function to enable measurement Lothar Rubusch
2025-05-25 12:26 ` Jonathan Cameron
2025-05-23 22:35 ` [PATCH v3 06/12] iio: accel: adxl313: prepare interrupt handling Lothar Rubusch
2025-05-25 12:33 ` Jonathan Cameron
2025-05-23 22:35 ` [PATCH v3 07/12] iio: accel: adxl313: add basic " Lothar Rubusch
2025-05-25 12:48 ` Jonathan Cameron
2025-05-25 12:56 ` Jonathan Cameron
2025-05-28 20:52 ` Lothar Rubusch
2025-05-31 16:33 ` Jonathan Cameron
2025-05-23 22:35 ` [PATCH v3 08/12] iio: accel: adxl313: add FIFO watermark Lothar Rubusch
2025-05-25 12:54 ` Jonathan Cameron
2025-05-23 22:35 ` [PATCH v3 09/12] iio: accel: adxl313: add activity sensing Lothar Rubusch
2025-05-25 13:03 ` Jonathan Cameron
2025-05-29 16:22 ` Lothar Rubusch
2025-05-31 16:34 ` Jonathan Cameron
2025-05-25 13:09 ` Jonathan Cameron
2025-05-23 22:35 ` [PATCH v3 10/12] iio: accel: adxl313: add inactivity sensing Lothar Rubusch
2025-05-25 13:11 ` Jonathan Cameron
2025-05-23 22:35 ` [PATCH v3 11/12] iio: accel: adxl313: implement power-save on inactivity Lothar Rubusch
2025-05-25 13:14 ` Jonathan Cameron
2025-05-23 22:35 ` [PATCH v3 12/12] docs: iio: add ADXL313 accelerometer Lothar Rubusch
2025-05-25 13:16 ` Jonathan Cameron
2025-05-26 3:44 ` Bagas Sanjaya
2025-05-25 12:49 ` [PATCH v3 00/12] iio: accel: adxl313: add power-save on activity/inactivity Jonathan Cameron
2025-05-25 14:54 ` Lothar Rubusch
2025-05-25 17:52 ` Jonathan Cameron
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250523223523.35218-1-l.rubusch@gmail.com \
--to=l.rubusch@gmail.com \
--cc=Michael.Hennerich@analog.com \
--cc=andy@kernel.org \
--cc=corbet@lwn.net \
--cc=dlechner@baylibre.com \
--cc=jic23@kernel.org \
--cc=lars@metafoo.de \
--cc=linux-doc@vger.kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lucas.p.stankus@gmail.com \
--cc=nuno.sa@analog.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.