All of lore.kernel.org
 help / color / mirror / Atom feed
From: khalid.datamax@gmail.com
To: sudipm.mukherjee@gmail.com
Cc: teddy.wang@siliconmotion.com, gregkh@linuxfoundation.org,
	linux-fbdev@vger.kernel.org, linux-staging@lists.linux.dev,
	linux-kernel@vger.kernel.org,
	Khalid Faisal <khalid.datamax@gmail.com>
Subject: [PATCH 0/1] staging: sm750fb: convert CamelCase function names to snake_case
Date: Sun,  1 Jun 2025 02:41:01 +0530	[thread overview]
Message-ID: <20250531211319.55682-1-khalid.datamax@gmail.com> (raw)

This patch cleans up the staging driver sm750fb by converting function names
that are currently in CamelCase to the preferred snake_case style, following
Linux kernel coding guidelines.

Specifically, it renames the following functions for consistency and readability:
- sii164GetDeviceID		-> sii164_get_device_id
- sii164ResetChip		-> sii164_reset_chip
- sii164GetChipString		-> sii164_get_chip_string
- sii164SetPower		-> sii164_set_power
- sii164EnableHotPlugDetection	-> sii164_enable_hot_plug_detection
- sii164IsConnected		-> sii164_is_connected
- sii164CheckInterrupt		-> sii164_check_interrupt
- sii164ClearInterrupt		-> sii164_clear_interrupt

This helps maintain uniformity with the rest of the kernel codebase and
improves maintainability.

Signed-off-by: Khalid Faisal <khalid.datamax@gmail.com>



             reply	other threads:[~2025-05-31 21:13 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-05-31 21:11 khalid.datamax [this message]
2025-05-31 21:11 ` [PATCH 0/1] staging: sm750fb: convert CamelCase function names to snake_case khalid.datamax
2025-05-31 21:11 ` [PATCH 1/1] " khalid.datamax
2025-06-19 15:32   ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250531211319.55682-1-khalid.datamax@gmail.com \
    --to=khalid.datamax@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-fbdev@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=sudipm.mukherjee@gmail.com \
    --cc=teddy.wang@siliconmotion.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.