All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christian Brauner <brauner@kernel.org>
To: "Darrick J. Wong" <djwong@kernel.org>
Cc: "Andrey Albershteyn" <aalbersh@redhat.com>,
	"Amir Goldstein" <amir73il@gmail.com>,
	"Arnd Bergmann" <arnd@arndb.de>,
	"Casey Schaufler" <casey@schaufler-ca.com>,
	"Jan Kara" <jack@suse.cz>, "Pali Rohár" <pali@kernel.org>,
	"Paul Moore" <paul@paul-moore.com>,
	linux-api@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-xfs@vger.kernel.org,
	selinux@vger.kernel.org,
	"Andrey Albershteyn" <aalbersh@kernel.org>
Subject: Re: [PATCH v6 6/6] fs: introduce file_getattr and file_setattr syscalls
Date: Wed, 2 Jul 2025 14:40:18 +0200	[thread overview]
Message-ID: <20250702-stagnation-dackel-294bb4cd9f3d@brauner> (raw)
In-Reply-To: <20250701184317.GQ10009@frogsfrogsfrogs>

> Er... "fsx_fileattr" is the struct that the system call uses?
> 
> That's a little confusing considering that xfs already has a
> xfs_fill_fsxattr function that actually fills a struct fileattr.
> That could be renamed xfs_fill_fileattr.
> 
> I dunno.  There's a part of me that would really rather that the
> file_getattr and file_setattr syscalls operate on a struct file_attr.

Agreed, I'm pretty sure I suggested this during an earlier review. Fits
in line with struct mount_attr and others. Fwiw, struct fileattr (the
kernel internal thing) should've really been struct file_kattr or struct
kernel_file_attr. This is a common pattern now:

struct mount_attr vs struct mount_kattr

struct clone_args vs struct kernel_clone_kargs

etc.

> 
> More whining/bikeshedding to come.
> 
> <snip stuff that looks ok to me>
> 
> <<well, I still dislike the CLASS(fd, fd)(fd) syntax...>>

Noted, and duly ignored...

> 
> > diff --git a/include/uapi/linux/fs.h b/include/uapi/linux/fs.h
> > index 0098b0ce8ccb..0784f2033ba4 100644
> > --- a/include/uapi/linux/fs.h
> > +++ b/include/uapi/linux/fs.h
> > @@ -148,6 +148,24 @@ struct fsxattr {
> >  	unsigned char	fsx_pad[8];
> >  };
> >  
> > +/*
> > + * Variable size structure for file_[sg]et_attr().
> > + *
> > + * Note. This is alternative to the structure 'struct fileattr'/'struct fsxattr'.
> > + * As this structure is passed to/from userspace with its size, this can
> > + * be versioned based on the size.
> > + */
> > +struct fsx_fileattr {
> > +	__u32	fsx_xflags;	/* xflags field value (get/set) */
> 
> Should this to be __u64 from the start?  Seeing as (a) this struct is

Agreed. I changed that.

  parent reply	other threads:[~2025-07-02 12:40 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-06-30 16:20 [PATCH v6 0/6] fs: introduce file_getattr and file_setattr syscalls Andrey Albershteyn
2025-06-30 16:20 ` [PATCH v6 1/6] fs: split fileattr related helpers into separate file Andrey Albershteyn
2025-07-01  5:39   ` Amir Goldstein
2025-07-01 12:38   ` Jan Kara
2025-07-01 18:13   ` Darrick J. Wong
2025-06-30 16:20 ` [PATCH v6 2/6] lsm: introduce new hooks for setting/getting inode fsxattr Andrey Albershteyn
2025-07-01 12:39   ` Jan Kara
2025-07-01 18:18   ` Darrick J. Wong
2025-07-02  8:47     ` Andrey Albershteyn
2025-06-30 16:20 ` [PATCH v6 3/6] selinux: implement inode_file_[g|s]etattr hooks Andrey Albershteyn
2025-06-30 16:20 ` [PATCH v6 4/6] fs: make vfs_fileattr_[get|set] return -EOPNOSUPP Andrey Albershteyn
2025-06-30 18:05   ` Pali Rohár
2025-07-01  6:05   ` Amir Goldstein
2025-07-01 12:51     ` Jan Kara
2025-07-01 14:16       ` Amir Goldstein
2025-07-01 12:52   ` Jan Kara
2025-07-01 18:18   ` Darrick J. Wong
2025-10-06 11:09   ` Jiri Slaby
2025-10-06 11:43     ` Arnd Bergmann
2025-10-06 15:39     ` Jan Kara
2025-10-06 18:52       ` Andrey Albershteyn
2025-10-07 11:00         ` Christian Brauner
2025-06-30 16:20 ` [PATCH v6 5/6] fs: prepare for extending file_get/setattr() Andrey Albershteyn
2025-07-01 13:06   ` Jan Kara
2025-07-01 18:31   ` Darrick J. Wong
2025-07-01 19:27     ` Amir Goldstein
2025-07-01 19:40       ` Darrick J. Wong
2025-07-01 19:54         ` Pali Rohár
2025-07-02  7:03           ` Amir Goldstein
2025-07-02  9:48             ` Amir Goldstein
2025-07-02 12:24               ` Christian Brauner
2025-06-30 16:20 ` [PATCH v6 6/6] fs: introduce file_getattr and file_setattr syscalls Andrey Albershteyn
2025-07-01 12:34   ` Christian Brauner
2025-07-02  9:13     ` Amir Goldstein
2025-07-01 13:24   ` Jan Kara
2025-07-01 18:43   ` Darrick J. Wong
2025-07-01 18:54     ` Pali Rohár
2025-07-01 19:08       ` Darrick J. Wong
2025-07-01 19:17         ` Pali Rohár
2025-07-02 12:40     ` Christian Brauner [this message]
2025-07-02 13:43       ` Amir Goldstein
2025-07-02 18:37         ` Darrick J. Wong
2025-07-03  8:28           ` Christian Brauner
2025-07-03  8:42             ` Amir Goldstein
2025-07-03  8:46               ` Christian Brauner
2025-07-03 22:35                 ` Darrick J. Wong
2025-07-01  6:11 ` [PATCH v6 0/6] " Amir Goldstein
2025-07-01 12:29 ` Christian Brauner
2025-07-07 12:05   ` Andrey Albershteyn
2025-07-07 12:19     ` Christian Brauner
2025-07-07 12:27       ` Andrey Albershteyn
2025-07-07 12:19 ` Christian Brauner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250702-stagnation-dackel-294bb4cd9f3d@brauner \
    --to=brauner@kernel.org \
    --cc=aalbersh@kernel.org \
    --cc=aalbersh@redhat.com \
    --cc=amir73il@gmail.com \
    --cc=arnd@arndb.de \
    --cc=casey@schaufler-ca.com \
    --cc=djwong@kernel.org \
    --cc=jack@suse.cz \
    --cc=linux-api@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=pali@kernel.org \
    --cc=paul@paul-moore.com \
    --cc=selinux@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.