From: Chris Morgan <macroalpha82@gmail.com>
To: linux-rockchip@lists.infradead.org
Cc: linux-pm@vger.kernel.org, devicetree@vger.kernel.org,
broonie@kernel.org, lee@kernel.org, lgirdwood@gmail.com,
sre@kernel.org, heiko@sntech.de, conor+dt@kernel.org,
krzk+dt@kernel.org, robh@kernel.org,
Chris Morgan <macromorgan@hotmail.com>
Subject: [PATCH V6 0/5] Add Texas Instruments BQ25703A Charger
Date: Tue, 12 Aug 2025 16:42:55 -0500 [thread overview]
Message-ID: <20250812214300.123129-1-macroalpha82@gmail.com> (raw)
From: Chris Morgan <macromorgan@hotmail.com>
Add support for the Texas Instruments BQ25703A charger manager. The
device integrates a boost converter with the charger manager. This
series adds the device as an MFD with separate regulator and power
supply drivers. This allows us to manage a circular dependency with
a type-c port manager which depends on the regulator for usb-otg
but supplies power to the BQ25703A charger.
---
Changes since RFC
- Corrected some minor issues with code and device-tree labels.
- Replaced most of the manufacturer specific device-tree properties
with monitored-battery properties.
Changes since V2
- Added reference to power-supply.yaml and removed note for i2c
address per recommendation from Sebastian.
- Corrected documentation error for charger driver found by kernel
test robot.
- Corrected duplicate POWER_SUPPLY_USB_TYPE_PD entry and corrected
ichg logic in power supply changed function.
- Corrected missing linux/bitfield.h header in regulator driver found
by kernel test robot.
Changes since V3
- Changed name of regulator from usb_otg_vbus to just vbus to align
with datasheet.
- Additional cleanup of the device tree documentation.
Changes since V4
- Replaced instances of dev_err followed by a return in the probe
functions with a return of dev_err_probe instead.
- Simplified cell definition of main driver for probe.
- Updated copyright year to 2025 on copyright strings.
Changes since V5
- Removed erroneous Reviewed-by tag from mfd patch.
- Made mfd_cells static const in mfd probe function.
- Removed unneeded enum from header file.
Chris Morgan (5):
dt-bindings: mfd: ti,bq25703a: Add TI BQ25703A Charger
mfd: bq257xx: Add support for BQ25703A core driver
power: supply: bq257xx: Add support for BQ257XX charger
regulator: bq257xx: Add bq257xx boost regulator driver
arm64: dts: rockchip: Add USB and charger to Gameforce Ace
.../devicetree/bindings/mfd/ti,bq25703a.yaml | 117 +++
.../dts/rockchip/rk3588s-gameforce-ace.dts | 122 +++
drivers/mfd/Kconfig | 11 +
drivers/mfd/Makefile | 1 +
drivers/mfd/bq257xx.c | 97 +++
drivers/power/supply/Kconfig | 7 +
drivers/power/supply/Makefile | 1 +
drivers/power/supply/bq257xx_charger.c | 750 ++++++++++++++++++
drivers/regulator/Kconfig | 8 +
drivers/regulator/Makefile | 1 +
drivers/regulator/bq257xx-regulator.c | 188 +++++
include/linux/mfd/bq257xx.h | 104 +++
12 files changed, 1407 insertions(+)
create mode 100644 Documentation/devicetree/bindings/mfd/ti,bq25703a.yaml
create mode 100644 drivers/mfd/bq257xx.c
create mode 100644 drivers/power/supply/bq257xx_charger.c
create mode 100644 drivers/regulator/bq257xx-regulator.c
create mode 100644 include/linux/mfd/bq257xx.h
--
2.43.0
WARNING: multiple messages have this Message-ID (diff)
From: Chris Morgan <macroalpha82@gmail.com>
To: linux-rockchip@lists.infradead.org
Cc: linux-pm@vger.kernel.org, devicetree@vger.kernel.org,
broonie@kernel.org, lee@kernel.org, lgirdwood@gmail.com,
sre@kernel.org, heiko@sntech.de, conor+dt@kernel.org,
krzk+dt@kernel.org, robh@kernel.org,
Chris Morgan <macromorgan@hotmail.com>
Subject: [PATCH V6 0/5] Add Texas Instruments BQ25703A Charger
Date: Tue, 12 Aug 2025 16:42:55 -0500 [thread overview]
Message-ID: <20250812214300.123129-1-macroalpha82@gmail.com> (raw)
From: Chris Morgan <macromorgan@hotmail.com>
Add support for the Texas Instruments BQ25703A charger manager. The
device integrates a boost converter with the charger manager. This
series adds the device as an MFD with separate regulator and power
supply drivers. This allows us to manage a circular dependency with
a type-c port manager which depends on the regulator for usb-otg
but supplies power to the BQ25703A charger.
---
Changes since RFC
- Corrected some minor issues with code and device-tree labels.
- Replaced most of the manufacturer specific device-tree properties
with monitored-battery properties.
Changes since V2
- Added reference to power-supply.yaml and removed note for i2c
address per recommendation from Sebastian.
- Corrected documentation error for charger driver found by kernel
test robot.
- Corrected duplicate POWER_SUPPLY_USB_TYPE_PD entry and corrected
ichg logic in power supply changed function.
- Corrected missing linux/bitfield.h header in regulator driver found
by kernel test robot.
Changes since V3
- Changed name of regulator from usb_otg_vbus to just vbus to align
with datasheet.
- Additional cleanup of the device tree documentation.
Changes since V4
- Replaced instances of dev_err followed by a return in the probe
functions with a return of dev_err_probe instead.
- Simplified cell definition of main driver for probe.
- Updated copyright year to 2025 on copyright strings.
Changes since V5
- Removed erroneous Reviewed-by tag from mfd patch.
- Made mfd_cells static const in mfd probe function.
- Removed unneeded enum from header file.
Chris Morgan (5):
dt-bindings: mfd: ti,bq25703a: Add TI BQ25703A Charger
mfd: bq257xx: Add support for BQ25703A core driver
power: supply: bq257xx: Add support for BQ257XX charger
regulator: bq257xx: Add bq257xx boost regulator driver
arm64: dts: rockchip: Add USB and charger to Gameforce Ace
.../devicetree/bindings/mfd/ti,bq25703a.yaml | 117 +++
.../dts/rockchip/rk3588s-gameforce-ace.dts | 122 +++
drivers/mfd/Kconfig | 11 +
drivers/mfd/Makefile | 1 +
drivers/mfd/bq257xx.c | 97 +++
drivers/power/supply/Kconfig | 7 +
drivers/power/supply/Makefile | 1 +
drivers/power/supply/bq257xx_charger.c | 750 ++++++++++++++++++
drivers/regulator/Kconfig | 8 +
drivers/regulator/Makefile | 1 +
drivers/regulator/bq257xx-regulator.c | 188 +++++
include/linux/mfd/bq257xx.h | 104 +++
12 files changed, 1407 insertions(+)
create mode 100644 Documentation/devicetree/bindings/mfd/ti,bq25703a.yaml
create mode 100644 drivers/mfd/bq257xx.c
create mode 100644 drivers/power/supply/bq257xx_charger.c
create mode 100644 drivers/regulator/bq257xx-regulator.c
create mode 100644 include/linux/mfd/bq257xx.h
--
2.43.0
_______________________________________________
Linux-rockchip mailing list
Linux-rockchip@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-rockchip
next reply other threads:[~2025-08-12 21:45 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-08-12 21:42 Chris Morgan [this message]
2025-08-12 21:42 ` [PATCH V6 0/5] Add Texas Instruments BQ25703A Charger Chris Morgan
2025-08-12 21:42 ` [PATCH V6 1/5] dt-bindings: mfd: ti,bq25703a: Add TI " Chris Morgan
2025-08-12 21:42 ` Chris Morgan
2025-08-12 21:42 ` [PATCH V6 2/5] mfd: bq257xx: Add support for BQ25703A core driver Chris Morgan
2025-08-12 21:42 ` Chris Morgan
2025-08-12 21:42 ` [PATCH V6 3/5] power: supply: bq257xx: Add support for BQ257XX charger Chris Morgan
2025-08-12 21:42 ` Chris Morgan
2025-08-18 7:58 ` kernel test robot
2025-08-18 8:22 ` Dan Carpenter
2025-08-18 8:22 ` Dan Carpenter
2025-08-18 15:26 ` Chris Morgan
2025-08-18 15:26 ` Chris Morgan
[not found] ` <aKNGCg2rWT7GLNnt@wintermute.localhost.fail>
2025-08-18 16:43 ` Chris Morgan
2025-08-18 16:43 ` Chris Morgan
2025-08-18 19:19 ` Dan Carpenter
2025-08-18 19:19 ` Dan Carpenter
2025-08-12 21:42 ` [PATCH V6 4/5] regulator: bq257xx: Add bq257xx boost regulator driver Chris Morgan
2025-08-12 21:42 ` Chris Morgan
2025-08-12 21:43 ` [PATCH V6 5/5] arm64: dts: rockchip: Add USB and charger to Gameforce Ace Chris Morgan
2025-08-12 21:43 ` Chris Morgan
-- strict thread matches above, loose matches on Subject: below --
2025-08-14 2:27 [PATCH V6 4/5] regulator: bq257xx: Add bq257xx boost regulator driver kernel test robot
2025-08-14 7:13 ` Dan Carpenter
2025-08-14 7:13 ` Dan Carpenter
2025-08-20 20:05 kernel test robot
2025-08-21 7:17 ` Dan Carpenter
2025-08-21 7:17 ` Dan Carpenter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250812214300.123129-1-macroalpha82@gmail.com \
--to=macroalpha82@gmail.com \
--cc=broonie@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=heiko@sntech.de \
--cc=krzk+dt@kernel.org \
--cc=lee@kernel.org \
--cc=lgirdwood@gmail.com \
--cc=linux-pm@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=macromorgan@hotmail.com \
--cc=robh@kernel.org \
--cc=sre@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.