From: Jakub Kicinski <kuba@kernel.org>
To: Ivan Vecera <ivecera@redhat.com>
Cc: Vadim Fedorenko <vadim.fedorenko@linux.dev>,
netdev@vger.kernel.org,
Arkadiusz Kubalewski <arkadiusz.kubalewski@intel.com>,
Jiri Pirko <jiri@resnulli.us>,
open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH net] dpll: fix clock quality level reporting
Date: Sun, 14 Sep 2025 13:03:17 -0700 [thread overview]
Message-ID: <20250914130317.09369dd0@kernel.org> (raw)
In-Reply-To: <11fbd6f4-0cab-48cb-83e8-f62adc0ed493@redhat.com>
On Sat, 13 Sep 2025 13:09:03 +0200 Ivan Vecera wrote:
> >> + DECLARE_BITMAP(qls, DPLL_CLOCK_QUALITY_LEVEL_MAX + 1) = { 0 };
> >> const struct dpll_device_ops *ops = dpll_device_ops(dpll);
> >> - DECLARE_BITMAP(qls, DPLL_CLOCK_QUALITY_LEVEL_MAX) = { 0 };
> >
> > I believe __DPLL_CLOCK_QUALITY_LEVEL_MAX should be used in both places
>
> I don't think so. I consider __DPLL_CLOCK_QUALITY_LEVEL_MAX to be an
> auxiliary value that should not be used directly.
>
> But it would be possible to rename it to DPLL_CLOCK_QUALITY_LEVEL_COUNT
> and use this.
>
> Thoughts?
I think we should leave it as is. The naming convention is a bit weird
but it's what has been done for Netlink historically
next prev parent reply other threads:[~2025-09-14 20:03 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-12 9:33 [PATCH net] dpll: fix clock quality level reporting Ivan Vecera
2025-09-12 10:51 ` Kubalewski, Arkadiusz
2025-09-12 19:37 ` Vadim Fedorenko
2025-09-13 11:09 ` Ivan Vecera
2025-09-14 20:03 ` Jakub Kicinski [this message]
2025-09-14 20:10 ` patchwork-bot+netdevbpf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250914130317.09369dd0@kernel.org \
--to=kuba@kernel.org \
--cc=arkadiusz.kubalewski@intel.com \
--cc=ivecera@redhat.com \
--cc=jiri@resnulli.us \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=vadim.fedorenko@linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.