All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] accel/ivpu: Refactor priority_bands_show for readability
@ 2025-09-15 10:34 Karol Wachowski
  2025-09-15 20:38 ` Lizhi Hou
  0 siblings, 1 reply; 3+ messages in thread
From: Karol Wachowski @ 2025-09-15 10:34 UTC (permalink / raw)
  To: dri-devel
  Cc: oded.gabbay, jeff.hugo, maciej.falkowski, lizhi.hou,
	Jacek Lawrynowicz, Karol Wachowski

From: Jacek Lawrynowicz <jacek.lawrynowicz@linux.intel.com>

Reduce code duplication and improve the overall readability of the debugfs
output for job scheduling priority bands.

Additionally fix clang-tidy warning about missing default case in the
switch statement.

Signed-off-by: Jacek Lawrynowicz <jacek.lawrynowicz@linux.intel.com>
Signed-off-by: Karol Wachowski <karol.wachowski@linux.intel.com>
---
 drivers/accel/ivpu/ivpu_debugfs.c | 38 ++++++++++++-------------------
 1 file changed, 14 insertions(+), 24 deletions(-)

diff --git a/drivers/accel/ivpu/ivpu_debugfs.c b/drivers/accel/ivpu/ivpu_debugfs.c
index cd24ccd20ba6..3bd85ee6c26b 100644
--- a/drivers/accel/ivpu/ivpu_debugfs.c
+++ b/drivers/accel/ivpu/ivpu_debugfs.c
@@ -398,35 +398,25 @@ static int dct_active_set(void *data, u64 active_percent)
 
 DEFINE_DEBUGFS_ATTRIBUTE(ivpu_dct_fops, dct_active_get, dct_active_set, "%llu\n");
 
+static void print_priority_band(struct seq_file *s, struct ivpu_hw_info *hw,
+				int band, const char *name)
+{
+	seq_printf(s, "%-9s: grace_period %9u process_grace_period %9u process_quantum %9u\n",
+		   name,
+		   hw->hws.grace_period[band],
+		   hw->hws.process_grace_period[band],
+		   hw->hws.process_quantum[band]);
+}
+
 static int priority_bands_show(struct seq_file *s, void *v)
 {
 	struct ivpu_device *vdev = s->private;
 	struct ivpu_hw_info *hw = vdev->hw;
 
-	for (int band = VPU_JOB_SCHEDULING_PRIORITY_BAND_IDLE;
-	     band < VPU_JOB_SCHEDULING_PRIORITY_BAND_COUNT; band++) {
-		switch (band) {
-		case VPU_JOB_SCHEDULING_PRIORITY_BAND_IDLE:
-			seq_puts(s, "Idle:     ");
-			break;
-
-		case VPU_JOB_SCHEDULING_PRIORITY_BAND_NORMAL:
-			seq_puts(s, "Normal:   ");
-			break;
-
-		case VPU_JOB_SCHEDULING_PRIORITY_BAND_FOCUS:
-			seq_puts(s, "Focus:    ");
-			break;
-
-		case VPU_JOB_SCHEDULING_PRIORITY_BAND_REALTIME:
-			seq_puts(s, "Realtime: ");
-			break;
-		}
-
-		seq_printf(s, "grace_period %9u process_grace_period %9u process_quantum %9u\n",
-			   hw->hws.grace_period[band], hw->hws.process_grace_period[band],
-			   hw->hws.process_quantum[band]);
-	}
+	print_priority_band(s, hw, VPU_JOB_SCHEDULING_PRIORITY_BAND_IDLE, "Idle");
+	print_priority_band(s, hw, VPU_JOB_SCHEDULING_PRIORITY_BAND_NORMAL, "Normal");
+	print_priority_band(s, hw, VPU_JOB_SCHEDULING_PRIORITY_BAND_FOCUS, "Focus");
+	print_priority_band(s, hw, VPU_JOB_SCHEDULING_PRIORITY_BAND_REALTIME, "Realtime");
 
 	return 0;
 }
-- 
2.43.0


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] accel/ivpu: Refactor priority_bands_show for readability
  2025-09-15 10:34 [PATCH] accel/ivpu: Refactor priority_bands_show for readability Karol Wachowski
@ 2025-09-15 20:38 ` Lizhi Hou
  2025-09-18  6:20   ` Karol Wachowski
  0 siblings, 1 reply; 3+ messages in thread
From: Lizhi Hou @ 2025-09-15 20:38 UTC (permalink / raw)
  To: Karol Wachowski, dri-devel
  Cc: oded.gabbay, jeff.hugo, maciej.falkowski, Jacek Lawrynowicz

Reviewed-by: Lizhi Hou <lizhi.hou@amd.com>

On 9/15/25 03:34, Karol Wachowski wrote:
> From: Jacek Lawrynowicz <jacek.lawrynowicz@linux.intel.com>
>
> Reduce code duplication and improve the overall readability of the debugfs
> output for job scheduling priority bands.
>
> Additionally fix clang-tidy warning about missing default case in the
> switch statement.
>
> Signed-off-by: Jacek Lawrynowicz <jacek.lawrynowicz@linux.intel.com>
> Signed-off-by: Karol Wachowski <karol.wachowski@linux.intel.com>
> ---
>   drivers/accel/ivpu/ivpu_debugfs.c | 38 ++++++++++++-------------------
>   1 file changed, 14 insertions(+), 24 deletions(-)
>
> diff --git a/drivers/accel/ivpu/ivpu_debugfs.c b/drivers/accel/ivpu/ivpu_debugfs.c
> index cd24ccd20ba6..3bd85ee6c26b 100644
> --- a/drivers/accel/ivpu/ivpu_debugfs.c
> +++ b/drivers/accel/ivpu/ivpu_debugfs.c
> @@ -398,35 +398,25 @@ static int dct_active_set(void *data, u64 active_percent)
>   
>   DEFINE_DEBUGFS_ATTRIBUTE(ivpu_dct_fops, dct_active_get, dct_active_set, "%llu\n");
>   
> +static void print_priority_band(struct seq_file *s, struct ivpu_hw_info *hw,
> +				int band, const char *name)
> +{
> +	seq_printf(s, "%-9s: grace_period %9u process_grace_period %9u process_quantum %9u\n",
> +		   name,
> +		   hw->hws.grace_period[band],
> +		   hw->hws.process_grace_period[band],
> +		   hw->hws.process_quantum[band]);
> +}
> +
>   static int priority_bands_show(struct seq_file *s, void *v)
>   {
>   	struct ivpu_device *vdev = s->private;
>   	struct ivpu_hw_info *hw = vdev->hw;
>   
> -	for (int band = VPU_JOB_SCHEDULING_PRIORITY_BAND_IDLE;
> -	     band < VPU_JOB_SCHEDULING_PRIORITY_BAND_COUNT; band++) {
> -		switch (band) {
> -		case VPU_JOB_SCHEDULING_PRIORITY_BAND_IDLE:
> -			seq_puts(s, "Idle:     ");
> -			break;
> -
> -		case VPU_JOB_SCHEDULING_PRIORITY_BAND_NORMAL:
> -			seq_puts(s, "Normal:   ");
> -			break;
> -
> -		case VPU_JOB_SCHEDULING_PRIORITY_BAND_FOCUS:
> -			seq_puts(s, "Focus:    ");
> -			break;
> -
> -		case VPU_JOB_SCHEDULING_PRIORITY_BAND_REALTIME:
> -			seq_puts(s, "Realtime: ");
> -			break;
> -		}
> -
> -		seq_printf(s, "grace_period %9u process_grace_period %9u process_quantum %9u\n",
> -			   hw->hws.grace_period[band], hw->hws.process_grace_period[band],
> -			   hw->hws.process_quantum[band]);
> -	}
> +	print_priority_band(s, hw, VPU_JOB_SCHEDULING_PRIORITY_BAND_IDLE, "Idle");
> +	print_priority_band(s, hw, VPU_JOB_SCHEDULING_PRIORITY_BAND_NORMAL, "Normal");
> +	print_priority_band(s, hw, VPU_JOB_SCHEDULING_PRIORITY_BAND_FOCUS, "Focus");
> +	print_priority_band(s, hw, VPU_JOB_SCHEDULING_PRIORITY_BAND_REALTIME, "Realtime");
>   
>   	return 0;
>   }

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] accel/ivpu: Refactor priority_bands_show for readability
  2025-09-15 20:38 ` Lizhi Hou
@ 2025-09-18  6:20   ` Karol Wachowski
  0 siblings, 0 replies; 3+ messages in thread
From: Karol Wachowski @ 2025-09-18  6:20 UTC (permalink / raw)
  To: Lizhi Hou, dri-devel
  Cc: oded.gabbay, jeff.hugo, maciej.falkowski, Jacek Lawrynowicz

Applied to drm-misc-next

On 9/15/2025 10:38 PM, Lizhi Hou wrote:
> Reviewed-by: Lizhi Hou <lizhi.hou@amd.com>
>
> On 9/15/25 03:34, Karol Wachowski wrote:
>> From: Jacek Lawrynowicz <jacek.lawrynowicz@linux.intel.com>
>>
>> Reduce code duplication and improve the overall readability of the
>> debugfs
>> output for job scheduling priority bands.
>>
>> Additionally fix clang-tidy warning about missing default case in the
>> switch statement.
>>
>> Signed-off-by: Jacek Lawrynowicz <jacek.lawrynowicz@linux.intel.com>
>> Signed-off-by: Karol Wachowski <karol.wachowski@linux.intel.com>
>> ---
>>   drivers/accel/ivpu/ivpu_debugfs.c | 38 ++++++++++++-------------------
>>   1 file changed, 14 insertions(+), 24 deletions(-)
>>
>> diff --git a/drivers/accel/ivpu/ivpu_debugfs.c
>> b/drivers/accel/ivpu/ivpu_debugfs.c
>> index cd24ccd20ba6..3bd85ee6c26b 100644
>> --- a/drivers/accel/ivpu/ivpu_debugfs.c
>> +++ b/drivers/accel/ivpu/ivpu_debugfs.c
>> @@ -398,35 +398,25 @@ static int dct_active_set(void *data, u64
>> active_percent)
>>     DEFINE_DEBUGFS_ATTRIBUTE(ivpu_dct_fops, dct_active_get,
>> dct_active_set, "%llu\n");
>>   +static void print_priority_band(struct seq_file *s, struct
>> ivpu_hw_info *hw,
>> +                int band, const char *name)
>> +{
>> +    seq_printf(s, "%-9s: grace_period %9u process_grace_period %9u
>> process_quantum %9u\n",
>> +           name,
>> +           hw->hws.grace_period[band],
>> +           hw->hws.process_grace_period[band],
>> +           hw->hws.process_quantum[band]);
>> +}
>> +
>>   static int priority_bands_show(struct seq_file *s, void *v)
>>   {
>>       struct ivpu_device *vdev = s->private;
>>       struct ivpu_hw_info *hw = vdev->hw;
>>   -    for (int band = VPU_JOB_SCHEDULING_PRIORITY_BAND_IDLE;
>> -         band < VPU_JOB_SCHEDULING_PRIORITY_BAND_COUNT; band++) {
>> -        switch (band) {
>> -        case VPU_JOB_SCHEDULING_PRIORITY_BAND_IDLE:
>> -            seq_puts(s, "Idle:     ");
>> -            break;
>> -
>> -        case VPU_JOB_SCHEDULING_PRIORITY_BAND_NORMAL:
>> -            seq_puts(s, "Normal:   ");
>> -            break;
>> -
>> -        case VPU_JOB_SCHEDULING_PRIORITY_BAND_FOCUS:
>> -            seq_puts(s, "Focus:    ");
>> -            break;
>> -
>> -        case VPU_JOB_SCHEDULING_PRIORITY_BAND_REALTIME:
>> -            seq_puts(s, "Realtime: ");
>> -            break;
>> -        }
>> -
>> -        seq_printf(s, "grace_period %9u process_grace_period %9u
>> process_quantum %9u\n",
>> -               hw->hws.grace_period[band],
>> hw->hws.process_grace_period[band],
>> -               hw->hws.process_quantum[band]);
>> -    }
>> +    print_priority_band(s, hw,
>> VPU_JOB_SCHEDULING_PRIORITY_BAND_IDLE, "Idle");
>> +    print_priority_band(s, hw,
>> VPU_JOB_SCHEDULING_PRIORITY_BAND_NORMAL, "Normal");
>> +    print_priority_band(s, hw,
>> VPU_JOB_SCHEDULING_PRIORITY_BAND_FOCUS, "Focus");
>> +    print_priority_band(s, hw,
>> VPU_JOB_SCHEDULING_PRIORITY_BAND_REALTIME, "Realtime");
>>         return 0;
>>   }

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2025-09-18  6:20 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-09-15 10:34 [PATCH] accel/ivpu: Refactor priority_bands_show for readability Karol Wachowski
2025-09-15 20:38 ` Lizhi Hou
2025-09-18  6:20   ` Karol Wachowski

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.