All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v3 0/6] VFS: more prep for change to directory locking
@ 2025-09-15  2:13 NeilBrown
  2025-09-15  2:13 ` [PATCH v3 1/6] VFS/ovl: add lookup_one_positive_killable() NeilBrown
                   ` (5 more replies)
  0 siblings, 6 replies; 11+ messages in thread
From: NeilBrown @ 2025-09-15  2:13 UTC (permalink / raw)
  To: Alexander Viro, Christian Brauner, Amir Goldstein, Jeff Layton
  Cc: Jan Kara, linux-fsdevel

This is a re-revised selection of cleanups and API renaming which continues
my work to centralise locking of create/remove/rename operations.

I've dropped the simple_end_creating etc changes which conflict with some of Al's work,
I've added a note to the first patch explaining that the linked list
does not need locking, and I've added a patch to rename start_creating() in debugfs
so the name can be used elsewhere in later patches.

Thanks,
NeilBrown

 [PATCH v3 1/6] VFS/ovl: add lookup_one_positive_killable()
 [PATCH v3 2/6] VFS: discard err2 in filename_create()
 [PATCH v3 3/6] VFS: unify old_mnt_idmap and new_mnt_idmap in
 [PATCH v3 4/6] VFS/audit: introduce kern_path_parent() for audit
 [PATCH v3 5/6] VFS: rename kern_path_locked() and related functions.
 [PATCH v3 6/6] debugfs: rename start_creating() to debugfs_start_creating()

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2025-09-21 10:22 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-09-15  2:13 [PATCH v3 0/6] VFS: more prep for change to directory locking NeilBrown
2025-09-15  2:13 ` [PATCH v3 1/6] VFS/ovl: add lookup_one_positive_killable() NeilBrown
2025-09-15  2:13 ` [PATCH v3 2/6] VFS: discard err2 in filename_create() NeilBrown
2025-09-15  2:13 ` [PATCH v3 3/6] VFS: unify old_mnt_idmap and new_mnt_idmap in renamedata NeilBrown
2025-09-15  2:13 ` [PATCH v3 4/6] VFS/audit: introduce kern_path_parent() for audit NeilBrown
2025-09-15  2:13 ` [PATCH v3 5/6] VFS: rename kern_path_locked() and related functions NeilBrown
2025-09-21  9:43   ` kernel test robot
2025-09-21 10:22     ` NeilBrown
2025-09-15  2:13 ` [PATCH v3 6/6] debugfs: rename start_creating() to debugfs_start_creating() NeilBrown
2025-09-19  5:06   ` Al Viro
2025-09-19 22:49     ` NeilBrown

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.