From: Jakub Kicinski <kuba@kernel.org>
To: Mark Bloch <mbloch@nvidia.com>
Cc: Jiri Pirko <jiri@resnulli.us>, Eric Dumazet <edumazet@google.com>,
Paolo Abeni <pabeni@redhat.com>, Simon Horman <horms@kernel.org>,
Saeed Mahameed <saeedm@nvidia.com>,
Leon Romanovsky <leon@kernel.org>,
Tariq Toukan <tariqt@nvidia.com>,
Andrew Lunn <andrew+netdev@lunn.ch>,
Jonathan Corbet <corbet@lwn.net>,
Shuah Khan <skhan@linuxfoundation.org>,
netdev@vger.kernel.org, linux-rdma@vger.kernel.org,
linux-doc@vger.kernel.org, Jiri Pirko <jiri@nvidia.com>
Subject: Re: [PATCH net-next V7 4/4] devlink: Apply eswitch mode boot defaults
Date: Mon, 27 Jul 2026 13:10:33 -0700 [thread overview]
Message-ID: <20260727131033.237f70b6@kernel.org> (raw)
In-Reply-To: <c6c0d67c-d832-49a1-b62a-57fa6ee56a47@nvidia.com>
On Sat, 25 Jul 2026 09:51:34 +0300 Mark Bloch wrote:
> So I think you and Jiri have different views on the basic design
> here. It's hard to respin the series when addressing one review
> takes it back to something the other reviewer objected to.
It'd be great if Jiri, an nVidia employee and a devlink "maintainer",
paid attention to at the very least revisions of nvidia's patches
touching devlink. We discussed this on a prior revision and he didn't
say anything.
> How about I drop the driver API from this series and submit it as
> a follow-up? This series would only have the generic workqueue
> fallback.
>
> But where should the work be queued?
> - devl_register()
> - devl_unlock()?
>
> Can we settle that before I post the next version, so we don't go
> in circles again?
Maybe a middle ground would be to add a dedicated devl_init_unlock()*
were we can stick such init? Slap a WARN_ON(!registered) in the normal
unlock? I don't want the normal unlock to grow in complexity like
rtnl_unlock ended up growing.
* better name welcome
BTW AI reported that we reset the mode on reinit request. Based on
the code this is entirely intentional but would be good to document?
prev parent reply other threads:[~2026-07-27 20:10 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-16 8:48 [PATCH net-next V7 0/4] devlink: Add boot-time eswitch mode defaults Mark Bloch
2026-07-16 8:48 ` [PATCH net-next V7 1/4] net/mlx5: Clear FW reset-in-progress bit before reload Mark Bloch
2026-07-16 8:48 ` [PATCH net-next V7 2/4] devlink: Factor out eswitch mode setting Mark Bloch
2026-07-16 8:48 ` [PATCH net-next V7 3/4] devlink: Parse eswitch mode boot defaults Mark Bloch
2026-07-16 8:48 ` [PATCH net-next V7 4/4] devlink: Apply " Mark Bloch
2026-07-24 23:11 ` Jakub Kicinski
2026-07-25 6:51 ` Mark Bloch
2026-07-27 20:10 ` Jakub Kicinski [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260727131033.237f70b6@kernel.org \
--to=kuba@kernel.org \
--cc=andrew+netdev@lunn.ch \
--cc=corbet@lwn.net \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=jiri@nvidia.com \
--cc=jiri@resnulli.us \
--cc=leon@kernel.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-rdma@vger.kernel.org \
--cc=mbloch@nvidia.com \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=saeedm@nvidia.com \
--cc=skhan@linuxfoundation.org \
--cc=tariqt@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.