From: sashiko-bot@kernel.org
To: "Pawel Zalewski (The Capable Hub)" <pzalewski@thegoodpenguin.co.uk>
Cc: cassel@kernel.org, linux-ide@vger.kernel.org, dlemoal@kernel.org
Subject: Re: [PATCH 1/2] ata: use named initializers for acpi_device_id
Date: Mon, 03 Aug 2026 15:14:16 +0000 [thread overview]
Message-ID: <20260803151417.3DB001F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260803-ata-acpi-v1-1-f606afaacad1@thegoodpenguin.co.uk>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] Incomplete refactoring: ahci_seattle.c was missed when unifying acpi_device_id initialization.
--
--- Patch [1]: [PATCH 1/2] ata: use named initializers for acpi_device_id ---
commit f6b3d365ff5924969c9b77b57308411fcb82b7e1
Author: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
ata: use named initializers for acpi_device_id
This commit updates acpi_device_id initializers in the ATA subsystem
to use named fields. It also unifies the list terminators across these
files to have a single space between the brackets.
> ata: use named initializers for acpi_device_id
>
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base.
>
> While we are at it - unify the list terminator to have
> a single space between the brackets and no trailing
> comma.
[Severity: Low]
Was ahci_seattle.c missed during this refactoring?
It appears drivers/ata/ahci_seattle.c still contains an old style
initializer and a list terminator without a space:
drivers/ata/ahci_seattle.c:ahci_acpi_match() {
static const struct acpi_device_id ahci_acpi_match[] = {
{ "AMDI0600", 0 },
{}
};
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
>
> diff --git a/drivers/ata/ahci_platform.c b/drivers/ata/ahci_platform.c
> index c18054333f7c9..d97f0ad3b4cd7 100644
> --- a/drivers/ata/ahci_platform.c
> +++ b/drivers/ata/ahci_platform.c
[ ... ]
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260803-ata-acpi-v1-0-f606afaacad1@thegoodpenguin.co.uk?part=1
next prev parent reply other threads:[~2026-08-03 15:14 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-03 15:03 [PATCH 0/2] ata: use named initializers for acpi_device_id Pawel Zalewski via B4 Relay
2026-08-03 15:03 ` Pawel Zalewski (The Capable Hub)
2026-08-03 15:03 ` [PATCH 1/2] " Pawel Zalewski via B4 Relay
2026-08-03 15:03 ` Pawel Zalewski (The Capable Hub)
2026-08-03 15:14 ` sashiko-bot [this message]
2026-08-03 19:58 ` Niklas Cassel
2026-08-04 6:09 ` Pawel Zalewski
2026-08-04 7:01 ` Niklas Cassel
2026-08-03 15:03 ` [PATCH 2/2] ata: ahci_seattle: drop unused acpi_device_id::driver_data Pawel Zalewski via B4 Relay
2026-08-03 15:03 ` Pawel Zalewski (The Capable Hub)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260803151417.3DB001F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=cassel@kernel.org \
--cc=dlemoal@kernel.org \
--cc=linux-ide@vger.kernel.org \
--cc=pzalewski@thegoodpenguin.co.uk \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.