All of lore.kernel.org
 help / color / mirror / Atom feed
From: Niklas Cassel <cassel@kernel.org>
To: sashiko-reviews@lists.linux.dev
Cc: "Pawel Zalewski (The Capable Hub)"
	<pzalewski@thegoodpenguin.co.uk>,
	linux-ide@vger.kernel.org, dlemoal@kernel.org
Subject: Re: [PATCH 1/2] ata: use named initializers for acpi_device_id
Date: Mon, 3 Aug 2026 21:58:15 +0200	[thread overview]
Message-ID: <anDy13qZ6rr1tFqO@ryzen> (raw)
In-Reply-To: <20260803151417.3DB001F000E9@smtp.kernel.org>

On Mon, Aug 03, 2026 at 03:14:16PM +0000, sashiko-bot@kernel.org wrote:
> Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
> - [Low] Incomplete refactoring: ahci_seattle.c was missed when unifying acpi_device_id initialization.
> --
> 
> --- Patch [1]: [PATCH 1/2] ata: use named initializers for acpi_device_id ---
> commit f6b3d365ff5924969c9b77b57308411fcb82b7e1
> Author: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
> 
> ata: use named initializers for acpi_device_id
> 
> This commit updates acpi_device_id initializers in the ATA subsystem
> to use named fields. It also unifies the list terminators across these
> files to have a single space between the brackets.
> 
> > ata: use named initializers for acpi_device_id
> > 
> > Use a named initializer for the acpi_device_id fields which
> > makes the code more readable and consistent with how lists
> > are initialized in the rest of the kernel code base.
> > 
> > While we are at it - unify the list terminator to have
> > a single space between the brackets and no trailing
> > comma.
> 
> [Severity: Low]
> Was ahci_seattle.c missed during this refactoring? 
> 
> It appears drivers/ata/ahci_seattle.c still contains an old style
> initializer and a list terminator without a space:
> 
> drivers/ata/ahci_seattle.c:ahci_acpi_match() {
> static const struct acpi_device_id ahci_acpi_match[] = {
> 	{ "AMDI0600", 0 },
> 	{}


The series looks good to me.

I do kind of agree with Sashiko that ahci_seattle.c could have been fixed
in patch 1/2 (rather than fixing ahci_seattle.c in patch 2/2).

drivers/ata/ahci_seattle.c:ahci_acpi_match() {
static const struct acpi_device_id ahci_acpi_match[] = {
	{ "AMDI0600", 0 },
	{}

Having a .driver_data of 0 is redundant, regardless if the driver uses it
or not, since the struct is defined as static, and is thus guaranteed to
be zero-initialized.


Kind regards,
Niklas

  reply	other threads:[~2026-08-03 19:58 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-03 15:03 [PATCH 0/2] ata: use named initializers for acpi_device_id Pawel Zalewski via B4 Relay
2026-08-03 15:03 ` Pawel Zalewski (The Capable Hub)
2026-08-03 15:03 ` [PATCH 1/2] " Pawel Zalewski via B4 Relay
2026-08-03 15:03   ` Pawel Zalewski (The Capable Hub)
2026-08-03 15:14   ` sashiko-bot
2026-08-03 19:58     ` Niklas Cassel [this message]
2026-08-04  6:09       ` Pawel Zalewski
2026-08-04  7:01         ` Niklas Cassel
2026-08-03 15:03 ` [PATCH 2/2] ata: ahci_seattle: drop unused acpi_device_id::driver_data Pawel Zalewski via B4 Relay
2026-08-03 15:03   ` Pawel Zalewski (The Capable Hub)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=anDy13qZ6rr1tFqO@ryzen \
    --to=cassel@kernel.org \
    --cc=dlemoal@kernel.org \
    --cc=linux-ide@vger.kernel.org \
    --cc=pzalewski@thegoodpenguin.co.uk \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.