All of lore.kernel.org
 help / color / mirror / Atom feed
* + docs-mm-ksm-use-the-renamed-ksm-structure-names.patch added to mm-new branch
@ 2026-09-05 23:16 Andrew Morton
  0 siblings, 0 replies; only message in thread
From: Andrew Morton @ 2026-09-05 23:16 UTC (permalink / raw)
  To: mm-commits, rdunlap, kmehltretter, akpm


The patch titled
     Subject: docs/mm: ksm: use the renamed ksm structure names
has been added to the -mm mm-new branch.  Its filename is
     docs-mm-ksm-use-the-renamed-ksm-structure-names.patch

This patch will shortly appear at
     https://git.kernel.org/pub/scm/linux/kernel/git/akpm/25-new.git/tree/patches/docs-mm-ksm-use-the-renamed-ksm-structure-names.patch

This patch will later appear in the mm-new branch at
    git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm

Note, mm-new is a provisional staging ground for work-in-progress
patches, and acceptance into mm-new is a notification for others take
notice and to finish up reviews.  Please do not hesitate to respond to
review feedback and post updated versions to replace or incrementally
fixup patches in mm-new.

The mm-new branch of mm.git is not included in linux-next

If a few days of testing in mm-new is successful, the patch will me moved
into mm.git's mm-unstable branch, which is included in linux-next

Before you just go and hit "reply", please:
   a) Consider who else should be cc'ed
   b) Prefer to cc a suitable mailing list as well
   c) Ideally: find the original patch on the mailing list and do a
      reply-to-all to that, adding suitable additional cc's

*** Remember to use Documentation/process/submit-checklist.rst when testing your code ***

The -mm tree is included into linux-next via various
branches at git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm
and is updated there most days

------------------------------------------------------
From: Karl Mehltretter <kmehltretter@gmail.com>
Subject: docs/mm: ksm: use the renamed ksm structure names
Date: Sat, 5 Sep 2026 10:40:34 +0200

The Reference section of ksm.rst asks mm/ksm.c for mm_slot, stable_node
and rmap_item.  Commit 21fbd59136e0 ("ksm: add the ksm prefix to the names
of the ksm private structures") renamed them to ksm_mm_slot,
ksm_stable_node and ksm_rmap_item.  Since then only ksm_scan is rendered
and the three structures are missing from the generated documentation.

Use the current names.

Link: https://lore.kernel.org/20260905084034.39521-1-kmehltretter@gmail.com
Fixes: 21fbd59136e0 ("ksm: add the ksm prefix to the names of the ksm private structures")
Assisted-by: LLM
Signed-off-by: Karl Mehltretter <kmehltretter@gmail.com>
Reviewed-by: Randy Dunlap <rdunlap@infradead.org>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
---

 Documentation/mm/ksm.rst |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--- a/Documentation/mm/ksm.rst~docs-mm-ksm-use-the-renamed-ksm-structure-names
+++ a/Documentation/mm/ksm.rst
@@ -78,7 +78,7 @@ The frequency of such scans is defined b
 Reference
 ---------
 .. kernel-doc:: mm/ksm.c
-   :functions: mm_slot ksm_scan stable_node rmap_item
+   :functions: ksm_mm_slot ksm_scan ksm_stable_node ksm_rmap_item
 
 --
 Izik Eidus,
_

Patches currently in -mm which might be from kmehltretter@gmail.com are

docs-mm-ksm-use-the-renamed-ksm-structure-names.patch
klist-avoid-accesses-after-waking-klist_remove.patch
squashfs-fix-fragment-index-table-sizing-overflow-on-32-bit.patch
squashfs-make-the-fragment-index-table-bounds-check-overflow-safe.patch
fork-honor-task_structs-declared-alignment.patch


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2026-09-05 23:16 UTC | newest]

Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-09-05 23:16 + docs-mm-ksm-use-the-renamed-ksm-structure-names.patch added to mm-new branch Andrew Morton

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.