All of lore.kernel.org
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Heiko Carstens" <hca@linux.ibm.com>
Cc: "Alexander Gordeev" <agordeev@linux.ibm.com>,
	"Christian Borntraeger" <borntraeger@linux.ibm.com>,
	"Heiko Carstens" <hca@linux.ibm.com>,
	"Vasily Gorbik" <gor@linux.ibm.com>,
	linux-s390@vger.kernel.org
Subject: Re: [PATCH v2 07/12] s390/percpu: Use __PCPU_BEGIN() and __PCPU_END() for inline assemblies
Date: Fri, 18 Sep 2026 08:54:58 +0000	[thread overview]
Message-ID: <20260918085459.2B4FC1F000FF@smtp.kernel.org> (raw)
In-Reply-To: <20260918084842.2333237-8-hca@linux.ibm.com>

> Replace the use of MVIY_PERCPU(), AG_ALT(), and MVIY_ALT() within all
> percpu inline assemblies with __PCPU_BEGIN() and __PCPU_END(), since
> the begin and end of each inline assembly is the same.
> 
> Also use consistent names: e.g. __PCPU_MVIY() and __PCPU_AG() instead of
> the previous MVIY_PERCPU() and AG_ALT().
> 
> Furthermore extract DEFINE_GR_NUM and UNDEF_GR_NUM which are used to
> convert register strings to register numbers.
> 
> All of this should make the code more readable. No functional change.
> 
> Signed-off-by: Heiko Carstens <hca@linux.ibm.com>

Sashiko has reviewed this patch and found no issues. It looks great!

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260918084842.2333237-1-hca@linux.ibm.com?part=7


  reply	other threads:[~2026-09-18  8:54 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-18  8:48 [PATCH v2 00/12] s390: More this_cpu_*() changes Heiko Carstens
2026-09-18  8:48 ` [PATCH v2 01/12] s390/percpu: Fix comment typo Heiko Carstens
2026-09-18  8:51   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 02/12] s390/percpu: Add sanity check to GEN_MVIY macro Heiko Carstens
2026-09-18  8:54   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 03/12] s390/lowcore: Remove _AC() from LOWCORE_ALT_ADDRESS Heiko Carstens
2026-09-18  8:55   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 04/12] s390/percpu: Let MVIY_PERCPU() calculate alternative displacement Heiko Carstens
2026-09-18  8:56   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 05/12] s390/percpu/lowcore: Add and use LC_PERCPU lowcore offset defines Heiko Carstens
2026-09-18  8:55   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 06/12] s390/percpu: Rename inline assembly symbolic names Heiko Carstens
2026-09-18  8:51   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 07/12] s390/percpu: Use __PCPU_BEGIN() and __PCPU_END() for inline assemblies Heiko Carstens
2026-09-18  8:54   ` sashiko-bot [this message]
2026-09-18  8:48 ` [PATCH v2 08/12] s390/percpu: Use percpu code section for this_cpu_cmpxchg128() Heiko Carstens
2026-09-18  8:56   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 09/12] s390/percpu: Use percpu code section for this_cpu_xchg() Heiko Carstens
2026-09-18  8:56   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 10/12] s390/percpu: Use percpu code section for this_cpu_cmpxchg() Heiko Carstens
2026-09-18  8:55   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 11/12] s390: Add CC_HAS_ASM_M_FORMAT_FLAG config option Heiko Carstens
2026-09-18  8:53   ` sashiko-bot
2026-09-18  8:48 ` [PATCH v2 12/12] s390/percpu: Rework to simplify percpu_entry() and percpu_exit() Heiko Carstens
2026-09-18  9:01   ` sashiko-bot
2026-09-18  9:53   ` Heiko Carstens
2026-09-18 10:40   ` Mark Rutland
2026-09-18 11:02     ` Heiko Carstens
2026-09-18 10:31 ` [PATCH v2 00/12] s390: More this_cpu_*() changes Mark Rutland
2026-09-18 10:59   ` Heiko Carstens
2026-09-18 11:24     ` Mark Rutland

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260918085459.2B4FC1F000FF@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=agordeev@linux.ibm.com \
    --cc=borntraeger@linux.ibm.com \
    --cc=gor@linux.ibm.com \
    --cc=hca@linux.ibm.com \
    --cc=linux-s390@vger.kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.