From: Alexander Stein <alexander.stein@ew.tq-group.com>
To: Richard Leitner <richard.leitner@linux.dev>
Cc: Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Shawn Guo <shawnguo@kernel.org>,
Sascha Hauer <s.hauer@pengutronix.de>,
Fabio Estevam <festevam@gmail.com>,
Pengutronix Kernel Team <kernel@pengutronix.de>,
NXP Linux Team <linux-imx@nxp.com>,
devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 2/2] arm64: dts: freescale: Add LVDS overlay for TQMa8MPxL
Date: Mon, 02 Jan 2023 10:07:26 +0100 [thread overview]
Message-ID: <2222186.iZASKD2KPV@steina-w> (raw)
In-Reply-To: <Y6F27Wzaal76/lU5@g0hl1n.net>
Hello Richard,
Am Dienstag, 20. Dezember 2022, 09:48:45 CET schrieb Richard Leitner:
> Hi Alexander,
>
> thanks for the series.
>
> On Thu, Dec 08, 2022 at 10:08:42AM +0100, Alexander Stein wrote:
> > This adds an overlay for the supported LVDS display tianma tm070jvhg33.
> > The display timings have to be specified explicitly. Using the typical
> > pixel clock, the LDB clock can not be configured as the 7-fold of that.
> > By setting pixel clock to 74.25 MHz, LDB can be configured to exactly
> > 519.75 MHz.
> >
> > Signed-off-by: Alexander Stein <alexander.stein@ew.tq-group.com>
> > ---
> > To be hold I'm unsure where to list the overlays. I checked other overlays
> > and opted to added them at the end of imx8mp section.
> >
> > arch/arm64/boot/dts/freescale/Makefile | 4 ++
> > .../imx8mp-tqma8mpql-mba8mpxl-lvds.dtso | 61 +++++++++++++++++++
> > 2 files changed, 65 insertions(+)
> > create mode 100644
> > arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso
> ...
>
> > diff --git
> > a/arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso
> > b/arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso new
> > file mode 100644
> > index 0000000000000..ea44d605342ba
> > --- /dev/null
> > +++ b/arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso
> > @@ -0,0 +1,61 @@
> > +// SPDX-License-Identifier: (GPL-2.0-or-later OR MIT)
> > +/*
> > + * Copyright (c) 2022 TQ-Systems GmbH <linux@ew.tq-group.com>,
> > + * D-82229 Seefeld, Germany.
> > + * Author: Alexander Stein
> > + */
> > +
> > +/dts-v1/;
> > +/plugin/;
> > +
> > +&{/} {
> > + compatible = "tq,imx8mp-tqma8mpql-mba8mpxl", "tq,imx8mp-tqma8mpql",
> > "fsl,imx8mp"; +};
> > +
> > +&backlight_lvds {
> > + status = "okay";
> > +};
> > +
> > +&display {
> > + compatible = "tianma,tm070jvhg33";
> > + status = "okay";
> > +
> > + panel-timing {
> > + clock-frequency = <74250000>;
> > + hactive = <1280>;
> > + vactive = <800>;
> > + hfront-porch = <64>;
> > + hback-porch = <5>;
> > + hsync-len = <1>;
> > + vfront-porch = <40>;
> > + vback-porch = <2>;
> > + vsync-len = <1>;
> > + de-active = <1>;
> > + };
> > +
> > + port {
> > + panel_in_lvds0: endpoint {
> > + remote-endpoint = <&ldb_lvds_ch0>;
> > + };
> > + };
> > +};
> > +
> > +&lcdif2 {
> > + status = "okay";
> > +};
> > +
> > +&lvds_bridge {
> > + status = "okay";
> > +
> > + ports {
> > + port@1 {
> > + ldb_lvds_ch0: endpoint {
> > + remote-endpoint = <&panel_in_lvds0>;
> > + };
> > + };
> > + };
> > +};
>
> Wouldn't it be possible and easier to read if this was &ldb_lvds_ch0
> only instead of the "whole" &lvds_bridge?
>
> &ldb_lvds_ch0 {
> remote-endpoint = <&panel_in_lvds0>;
> };
Yes it is possible and easier to read. Unfortunately dtbs_check will raise the
follwing warnings when doing so:
> arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtbo: Warning
(graph_port): /fragment@4: graph port node name should be 'port'
> ../arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso:
47.15-49.3: Warning (graph_endpoint): /fragment@4/__overlay__: graph endpoint
node name should be 'endpoint'
> ../arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso:
47.15-49.3: Warning (graph_endpoint): /fragment@4/__overlay__: graph
connection to node '/fragment@2/__overlay__/port/endpoint' is not
bidirectional
I'm not sure which way is the preferred/correct one or if this is just an
issue in dtc, raising the warnings.
Best regards,
Alexander
> > +
> > +&pwm2 {
> > + status = "okay";
> > +};
>
> regards;rl
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
WARNING: multiple messages have this Message-ID (diff)
From: Alexander Stein <alexander.stein@ew.tq-group.com>
To: Richard Leitner <richard.leitner@linux.dev>
Cc: Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Shawn Guo <shawnguo@kernel.org>,
Sascha Hauer <s.hauer@pengutronix.de>,
Fabio Estevam <festevam@gmail.com>,
Pengutronix Kernel Team <kernel@pengutronix.de>,
NXP Linux Team <linux-imx@nxp.com>,
devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 2/2] arm64: dts: freescale: Add LVDS overlay for TQMa8MPxL
Date: Mon, 02 Jan 2023 10:07:26 +0100 [thread overview]
Message-ID: <2222186.iZASKD2KPV@steina-w> (raw)
In-Reply-To: <Y6F27Wzaal76/lU5@g0hl1n.net>
Hello Richard,
Am Dienstag, 20. Dezember 2022, 09:48:45 CET schrieb Richard Leitner:
> Hi Alexander,
>
> thanks for the series.
>
> On Thu, Dec 08, 2022 at 10:08:42AM +0100, Alexander Stein wrote:
> > This adds an overlay for the supported LVDS display tianma tm070jvhg33.
> > The display timings have to be specified explicitly. Using the typical
> > pixel clock, the LDB clock can not be configured as the 7-fold of that.
> > By setting pixel clock to 74.25 MHz, LDB can be configured to exactly
> > 519.75 MHz.
> >
> > Signed-off-by: Alexander Stein <alexander.stein@ew.tq-group.com>
> > ---
> > To be hold I'm unsure where to list the overlays. I checked other overlays
> > and opted to added them at the end of imx8mp section.
> >
> > arch/arm64/boot/dts/freescale/Makefile | 4 ++
> > .../imx8mp-tqma8mpql-mba8mpxl-lvds.dtso | 61 +++++++++++++++++++
> > 2 files changed, 65 insertions(+)
> > create mode 100644
> > arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso
> ...
>
> > diff --git
> > a/arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso
> > b/arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso new
> > file mode 100644
> > index 0000000000000..ea44d605342ba
> > --- /dev/null
> > +++ b/arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso
> > @@ -0,0 +1,61 @@
> > +// SPDX-License-Identifier: (GPL-2.0-or-later OR MIT)
> > +/*
> > + * Copyright (c) 2022 TQ-Systems GmbH <linux@ew.tq-group.com>,
> > + * D-82229 Seefeld, Germany.
> > + * Author: Alexander Stein
> > + */
> > +
> > +/dts-v1/;
> > +/plugin/;
> > +
> > +&{/} {
> > + compatible = "tq,imx8mp-tqma8mpql-mba8mpxl", "tq,imx8mp-tqma8mpql",
> > "fsl,imx8mp"; +};
> > +
> > +&backlight_lvds {
> > + status = "okay";
> > +};
> > +
> > +&display {
> > + compatible = "tianma,tm070jvhg33";
> > + status = "okay";
> > +
> > + panel-timing {
> > + clock-frequency = <74250000>;
> > + hactive = <1280>;
> > + vactive = <800>;
> > + hfront-porch = <64>;
> > + hback-porch = <5>;
> > + hsync-len = <1>;
> > + vfront-porch = <40>;
> > + vback-porch = <2>;
> > + vsync-len = <1>;
> > + de-active = <1>;
> > + };
> > +
> > + port {
> > + panel_in_lvds0: endpoint {
> > + remote-endpoint = <&ldb_lvds_ch0>;
> > + };
> > + };
> > +};
> > +
> > +&lcdif2 {
> > + status = "okay";
> > +};
> > +
> > +&lvds_bridge {
> > + status = "okay";
> > +
> > + ports {
> > + port@1 {
> > + ldb_lvds_ch0: endpoint {
> > + remote-endpoint = <&panel_in_lvds0>;
> > + };
> > + };
> > + };
> > +};
>
> Wouldn't it be possible and easier to read if this was &ldb_lvds_ch0
> only instead of the "whole" &lvds_bridge?
>
> &ldb_lvds_ch0 {
> remote-endpoint = <&panel_in_lvds0>;
> };
Yes it is possible and easier to read. Unfortunately dtbs_check will raise the
follwing warnings when doing so:
> arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtbo: Warning
(graph_port): /fragment@4: graph port node name should be 'port'
> ../arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso:
47.15-49.3: Warning (graph_endpoint): /fragment@4/__overlay__: graph endpoint
node name should be 'endpoint'
> ../arch/arm64/boot/dts/freescale/imx8mp-tqma8mpql-mba8mpxl-lvds.dtso:
47.15-49.3: Warning (graph_endpoint): /fragment@4/__overlay__: graph
connection to node '/fragment@2/__overlay__/port/endpoint' is not
bidirectional
I'm not sure which way is the preferred/correct one or if this is just an
issue in dtc, raising the warnings.
Best regards,
Alexander
> > +
> > +&pwm2 {
> > + status = "okay";
> > +};
>
> regards;rl
next prev parent reply other threads:[~2023-01-02 9:09 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-12-08 9:08 [PATCH 1/2] arm64: dts: imx8mp: Add LCDIF2 & LDB nodes Alexander Stein
2022-12-08 9:08 ` Alexander Stein
2022-12-08 9:08 ` [PATCH 2/2] arm64: dts: freescale: Add LVDS overlay for TQMa8MPxL Alexander Stein
2022-12-08 9:08 ` Alexander Stein
2022-12-20 8:48 ` Richard Leitner
2022-12-20 8:48 ` Richard Leitner
2023-01-02 9:07 ` Alexander Stein [this message]
2023-01-02 9:07 ` Alexander Stein
2022-12-20 13:00 ` [PATCH 1/2] arm64: dts: imx8mp: Add LCDIF2 & LDB nodes Richard Leitner
2022-12-20 13:00 ` Richard Leitner
2023-01-24 14:26 ` Rasmus Villemoes
2023-01-24 14:26 ` Rasmus Villemoes
2023-01-25 14:29 ` Shawn Guo
2023-01-25 14:29 ` Shawn Guo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2222186.iZASKD2KPV@steina-w \
--to=alexander.stein@ew.tq-group.com \
--cc=devicetree@vger.kernel.org \
--cc=festevam@gmail.com \
--cc=kernel@pengutronix.de \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-imx@nxp.com \
--cc=richard.leitner@linux.dev \
--cc=robh+dt@kernel.org \
--cc=s.hauer@pengutronix.de \
--cc=shawnguo@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.