From: Nicolas Frattaroli <frattaroli.nicolas@gmail.com>
To: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>,
Philipp Zabel <p.zabel@pengutronix.de>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Heiko Stuebner <heiko@sntech.de>,
Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
Cc: Ezequiel Garcia <ezequiel@collabora.com>,
linux-media@vger.kernel.org, linux-rockchip@lists.infradead.org,
devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 1/3] dt-bindings: media: rockchip-vpu: Add RK3568 VEPU compatible
Date: Wed, 11 May 2022 18:37:54 +0200 [thread overview]
Message-ID: <2486415.XAZu0pfo7u@archbook> (raw)
In-Reply-To: <bc4c395d-4e21-1d15-96be-00a5cad1d6f7@linaro.org>
On Mittwoch, 11. Mai 2022 18:00:09 CEST Krzysztof Kozlowski wrote:
> On 11/05/2022 17:53, Nicolas Frattaroli wrote:
> > The RK3568 and RK3566 have a Hantro VPU node solely dedicated to
> > encoding. This patch adds a compatible for it, and also allows
> > the bindings to only come with a vepu interrupt.
> >
> > Signed-off-by: Nicolas Frattaroli <frattaroli.nicolas@gmail.com>
> > ---
> > .../devicetree/bindings/media/rockchip-vpu.yaml | 17 ++++++++++++++++-
> > 1 file changed, 16 insertions(+), 1 deletion(-)
> >
> > diff --git a/Documentation/devicetree/bindings/media/rockchip-vpu.yaml b/Documentation/devicetree/bindings/media/rockchip-vpu.yaml
> > index bacb60a34989..965ca80b5cea 100644
> > --- a/Documentation/devicetree/bindings/media/rockchip-vpu.yaml
> > +++ b/Documentation/devicetree/bindings/media/rockchip-vpu.yaml
> > @@ -22,6 +22,7 @@ properties:
> > - rockchip,rk3288-vpu
> > - rockchip,rk3328-vpu
> > - rockchip,rk3399-vpu
> > + - rockchip,rk3568-vepu
> > - rockchip,px30-vpu
> > - items:
> > - const: rockchip,rk3188-vpu
> > @@ -39,7 +40,9 @@ properties:
> >
> > interrupt-names:
> > oneOf:
> > - - const: vdpu
> > + - enum:
> > + - vdpu
> > + - vepu
> > - items:
> > - const: vepu
> > - const: vdpu
> > @@ -76,6 +79,18 @@ required:
> >
> > additionalProperties: false
> >
> > +allOf:
> > + # compatibles that end in -vepu should only have the vepu interrupt
> > + - if:
> > + properties:
> > + compatible:
> > + contains:
> > + pattern: "^[a-zA-Z0-9\\-,_.]+\\-vepu$"
>
> Why not listing the compatible how I asked? This is the common way of
> handling allOf:if:then per variant.
Because I was afraid that if this wasn't general enough to apply to all
future vepu-only instances of Hantro, then my patch might be bikeshed
into requiring a v4. Clearly, my worries had the opposite effect.
Also because I thought it was cool to use a pattern for this to enforce
consistent naming in the bindings.
>
> https://lore.kernel.org/all/ea94f18d-3172-98bb-0892-a98236a08018@linaro.org/
>
> Your patches do not apply on next, so the set might not have been tested
> by Rob's bot.
Good to know. Once I send out v4 in a few days and maybe after some more
opinions so I can stop bombarding the mailing list with tiny revisions
of the same patch set, I will base it on linux-next.
I'm happy to report though that this passes dt_binding_check with W=1
without adding any new warnings. I do actually run those checks (and
checkpatch) before submitting.
>
> Best regards,
> Krzysztof
>
Regards,
Nicolas Frattaroli
_______________________________________________
Linux-rockchip mailing list
Linux-rockchip@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-rockchip
WARNING: multiple messages have this Message-ID (diff)
From: Nicolas Frattaroli <frattaroli.nicolas@gmail.com>
To: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>,
Philipp Zabel <p.zabel@pengutronix.de>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Heiko Stuebner <heiko@sntech.de>,
Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
Cc: Ezequiel Garcia <ezequiel@collabora.com>,
linux-media@vger.kernel.org, linux-rockchip@lists.infradead.org,
devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 1/3] dt-bindings: media: rockchip-vpu: Add RK3568 VEPU compatible
Date: Wed, 11 May 2022 18:37:54 +0200 [thread overview]
Message-ID: <2486415.XAZu0pfo7u@archbook> (raw)
In-Reply-To: <bc4c395d-4e21-1d15-96be-00a5cad1d6f7@linaro.org>
On Mittwoch, 11. Mai 2022 18:00:09 CEST Krzysztof Kozlowski wrote:
> On 11/05/2022 17:53, Nicolas Frattaroli wrote:
> > The RK3568 and RK3566 have a Hantro VPU node solely dedicated to
> > encoding. This patch adds a compatible for it, and also allows
> > the bindings to only come with a vepu interrupt.
> >
> > Signed-off-by: Nicolas Frattaroli <frattaroli.nicolas@gmail.com>
> > ---
> > .../devicetree/bindings/media/rockchip-vpu.yaml | 17 ++++++++++++++++-
> > 1 file changed, 16 insertions(+), 1 deletion(-)
> >
> > diff --git a/Documentation/devicetree/bindings/media/rockchip-vpu.yaml b/Documentation/devicetree/bindings/media/rockchip-vpu.yaml
> > index bacb60a34989..965ca80b5cea 100644
> > --- a/Documentation/devicetree/bindings/media/rockchip-vpu.yaml
> > +++ b/Documentation/devicetree/bindings/media/rockchip-vpu.yaml
> > @@ -22,6 +22,7 @@ properties:
> > - rockchip,rk3288-vpu
> > - rockchip,rk3328-vpu
> > - rockchip,rk3399-vpu
> > + - rockchip,rk3568-vepu
> > - rockchip,px30-vpu
> > - items:
> > - const: rockchip,rk3188-vpu
> > @@ -39,7 +40,9 @@ properties:
> >
> > interrupt-names:
> > oneOf:
> > - - const: vdpu
> > + - enum:
> > + - vdpu
> > + - vepu
> > - items:
> > - const: vepu
> > - const: vdpu
> > @@ -76,6 +79,18 @@ required:
> >
> > additionalProperties: false
> >
> > +allOf:
> > + # compatibles that end in -vepu should only have the vepu interrupt
> > + - if:
> > + properties:
> > + compatible:
> > + contains:
> > + pattern: "^[a-zA-Z0-9\\-,_.]+\\-vepu$"
>
> Why not listing the compatible how I asked? This is the common way of
> handling allOf:if:then per variant.
Because I was afraid that if this wasn't general enough to apply to all
future vepu-only instances of Hantro, then my patch might be bikeshed
into requiring a v4. Clearly, my worries had the opposite effect.
Also because I thought it was cool to use a pattern for this to enforce
consistent naming in the bindings.
>
> https://lore.kernel.org/all/ea94f18d-3172-98bb-0892-a98236a08018@linaro.org/
>
> Your patches do not apply on next, so the set might not have been tested
> by Rob's bot.
Good to know. Once I send out v4 in a few days and maybe after some more
opinions so I can stop bombarding the mailing list with tiny revisions
of the same patch set, I will base it on linux-next.
I'm happy to report though that this passes dt_binding_check with W=1
without adding any new warnings. I do actually run those checks (and
checkpatch) before submitting.
>
> Best regards,
> Krzysztof
>
Regards,
Nicolas Frattaroli
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
WARNING: multiple messages have this Message-ID (diff)
From: Nicolas Frattaroli <frattaroli.nicolas@gmail.com>
To: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>,
Philipp Zabel <p.zabel@pengutronix.de>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Heiko Stuebner <heiko@sntech.de>,
Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
Cc: Ezequiel Garcia <ezequiel@collabora.com>,
linux-media@vger.kernel.org, linux-rockchip@lists.infradead.org,
devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 1/3] dt-bindings: media: rockchip-vpu: Add RK3568 VEPU compatible
Date: Wed, 11 May 2022 18:37:54 +0200 [thread overview]
Message-ID: <2486415.XAZu0pfo7u@archbook> (raw)
In-Reply-To: <bc4c395d-4e21-1d15-96be-00a5cad1d6f7@linaro.org>
On Mittwoch, 11. Mai 2022 18:00:09 CEST Krzysztof Kozlowski wrote:
> On 11/05/2022 17:53, Nicolas Frattaroli wrote:
> > The RK3568 and RK3566 have a Hantro VPU node solely dedicated to
> > encoding. This patch adds a compatible for it, and also allows
> > the bindings to only come with a vepu interrupt.
> >
> > Signed-off-by: Nicolas Frattaroli <frattaroli.nicolas@gmail.com>
> > ---
> > .../devicetree/bindings/media/rockchip-vpu.yaml | 17 ++++++++++++++++-
> > 1 file changed, 16 insertions(+), 1 deletion(-)
> >
> > diff --git a/Documentation/devicetree/bindings/media/rockchip-vpu.yaml b/Documentation/devicetree/bindings/media/rockchip-vpu.yaml
> > index bacb60a34989..965ca80b5cea 100644
> > --- a/Documentation/devicetree/bindings/media/rockchip-vpu.yaml
> > +++ b/Documentation/devicetree/bindings/media/rockchip-vpu.yaml
> > @@ -22,6 +22,7 @@ properties:
> > - rockchip,rk3288-vpu
> > - rockchip,rk3328-vpu
> > - rockchip,rk3399-vpu
> > + - rockchip,rk3568-vepu
> > - rockchip,px30-vpu
> > - items:
> > - const: rockchip,rk3188-vpu
> > @@ -39,7 +40,9 @@ properties:
> >
> > interrupt-names:
> > oneOf:
> > - - const: vdpu
> > + - enum:
> > + - vdpu
> > + - vepu
> > - items:
> > - const: vepu
> > - const: vdpu
> > @@ -76,6 +79,18 @@ required:
> >
> > additionalProperties: false
> >
> > +allOf:
> > + # compatibles that end in -vepu should only have the vepu interrupt
> > + - if:
> > + properties:
> > + compatible:
> > + contains:
> > + pattern: "^[a-zA-Z0-9\\-,_.]+\\-vepu$"
>
> Why not listing the compatible how I asked? This is the common way of
> handling allOf:if:then per variant.
Because I was afraid that if this wasn't general enough to apply to all
future vepu-only instances of Hantro, then my patch might be bikeshed
into requiring a v4. Clearly, my worries had the opposite effect.
Also because I thought it was cool to use a pattern for this to enforce
consistent naming in the bindings.
>
> https://lore.kernel.org/all/ea94f18d-3172-98bb-0892-a98236a08018@linaro.org/
>
> Your patches do not apply on next, so the set might not have been tested
> by Rob's bot.
Good to know. Once I send out v4 in a few days and maybe after some more
opinions so I can stop bombarding the mailing list with tiny revisions
of the same patch set, I will base it on linux-next.
I'm happy to report though that this passes dt_binding_check with W=1
without adding any new warnings. I do actually run those checks (and
checkpatch) before submitting.
>
> Best regards,
> Krzysztof
>
Regards,
Nicolas Frattaroli
next prev parent reply other threads:[~2022-05-11 16:39 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-05-11 15:53 [PATCH v3 0/3] Enable JPEG Encoder on RK3566/RK3568 Nicolas Frattaroli
2022-05-11 15:53 ` Nicolas Frattaroli
2022-05-11 15:53 ` Nicolas Frattaroli
2022-05-11 15:53 ` [PATCH v3 1/3] dt-bindings: media: rockchip-vpu: Add RK3568 VEPU compatible Nicolas Frattaroli
2022-05-11 15:53 ` Nicolas Frattaroli
2022-05-11 15:53 ` Nicolas Frattaroli
2022-05-11 16:00 ` Krzysztof Kozlowski
2022-05-11 16:00 ` Krzysztof Kozlowski
2022-05-11 16:00 ` Krzysztof Kozlowski
2022-05-11 16:37 ` Nicolas Frattaroli [this message]
2022-05-11 16:37 ` Nicolas Frattaroli
2022-05-11 16:37 ` Nicolas Frattaroli
2022-05-11 16:55 ` Krzysztof Kozlowski
2022-05-11 16:55 ` Krzysztof Kozlowski
2022-05-11 16:55 ` Krzysztof Kozlowski
2022-05-11 15:53 ` [PATCH v3 2/3] media: hantro: Add support for RK356x encoder Nicolas Frattaroli
2022-05-11 15:53 ` Nicolas Frattaroli
2022-05-11 15:53 ` Nicolas Frattaroli
2022-05-11 15:53 ` [PATCH v3 3/3] arm64: dts: rockchip: Add Hantro encoder node to rk356x Nicolas Frattaroli
2022-05-11 15:53 ` Nicolas Frattaroli
2022-05-11 15:53 ` Nicolas Frattaroli
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2486415.XAZu0pfo7u@archbook \
--to=frattaroli.nicolas@gmail.com \
--cc=devicetree@vger.kernel.org \
--cc=ezequiel@collabora.com \
--cc=ezequiel@vanguardiasur.com.ar \
--cc=heiko@sntech.de \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=krzysztof.kozlowski@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=mchehab@kernel.org \
--cc=p.zabel@pengutronix.de \
--cc=robh+dt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.