From: David Lechner <dlechner@baylibre.com>
To: Andrew Lunn <andrew@lunn.ch>
Cc: "Linus Walleij" <linus.walleij@linaro.org>,
"Bartosz Golaszewski" <brgl@bgdev.pl>,
"Andy Shevchenko" <andy@kernel.org>,
"Geert Uytterhoeven" <geert@linux-m68k.org>,
"Lars-Peter Clausen" <lars@metafoo.de>,
"Michael Hennerich" <Michael.Hennerich@analog.com>,
"Jonathan Cameron" <jic23@kernel.org>,
"Ulf Hansson" <ulf.hansson@linaro.org>,
"Peter Rosin" <peda@axentia.se>,
"Heiner Kallweit" <hkallweit1@gmail.com>,
"Russell King" <linux@armlinux.org.uk>,
"David S. Miller" <davem@davemloft.net>,
"Eric Dumazet" <edumazet@google.com>,
"Jakub Kicinski" <kuba@kernel.org>,
"Paolo Abeni" <pabeni@redhat.com>,
"Vinod Koul" <vkoul@kernel.org>,
"Kishon Vijay Abraham I" <kishon@kernel.org>,
"Nuno Sá" <nuno.sa@analog.com>,
"Liam Girdwood" <lgirdwood@gmail.com>,
"Mark Brown" <broonie@kernel.org>,
"Jaroslav Kysela" <perex@perex.cz>,
"Takashi Iwai" <tiwai@suse.com>,
linux-gpio@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-iio@vger.kernel.org, linux-mmc@vger.kernel.org,
netdev@vger.kernel.org, linux-phy@lists.infradead.org,
linux-sound@vger.kernel.org
Subject: Re: [PATCH 00/13] gpiolib: add gpiods_set_array_value_cansleep
Date: Fri, 31 Jan 2025 14:51:52 -0600 [thread overview]
Message-ID: <2715ead8-cf6d-4b44-b6e3-343cb6489eca@baylibre.com> (raw)
In-Reply-To: <4ad45123-134a-4544-ad0a-24371105d96f@lunn.ch>
On 1/31/25 2:38 PM, Andrew Lunn wrote:
>> So I'm proposing that we add a gpiods_set_array_value_cansleep()
>> function that is a wrapper around gpiod_set_array_value_cansleep()
>> that has struct gpio_descs as the first parameter to make it a bit
>> easier to read the code and avoid the hard-coding temptation.
>
> This looks reasonable.
>
> How do you plan to get it merged, since you cross a lot of subsystems
> here.
>
> Andrew
Since these are mostly small changes and most of the touched drivers aren't
seeing much action, I think it would be OK for as much as possible to go through
the GPIO tree.
We might need an immutable branch from that though since I know that iio: adc:
ad7606 is currently being actively worked on.
If there are any patches leftover that don't get acked to go through the GPIO
tree, I can resubmit them after the next kernel release cycle since none of
this is urgent anyway.
WARNING: multiple messages have this Message-ID (diff)
From: David Lechner <dlechner@baylibre.com>
To: Andrew Lunn <andrew@lunn.ch>
Cc: "Linus Walleij" <linus.walleij@linaro.org>,
"Bartosz Golaszewski" <brgl@bgdev.pl>,
"Andy Shevchenko" <andy@kernel.org>,
"Geert Uytterhoeven" <geert@linux-m68k.org>,
"Lars-Peter Clausen" <lars@metafoo.de>,
"Michael Hennerich" <Michael.Hennerich@analog.com>,
"Jonathan Cameron" <jic23@kernel.org>,
"Ulf Hansson" <ulf.hansson@linaro.org>,
"Peter Rosin" <peda@axentia.se>,
"Heiner Kallweit" <hkallweit1@gmail.com>,
"Russell King" <linux@armlinux.org.uk>,
"David S. Miller" <davem@davemloft.net>,
"Eric Dumazet" <edumazet@google.com>,
"Jakub Kicinski" <kuba@kernel.org>,
"Paolo Abeni" <pabeni@redhat.com>,
"Vinod Koul" <vkoul@kernel.org>,
"Kishon Vijay Abraham I" <kishon@kernel.org>,
"Nuno Sá" <nuno.sa@analog.com>,
"Liam Girdwood" <lgirdwood@gmail.com>,
"Mark Brown" <broonie@kernel.org>,
"Jaroslav Kysela" <perex@perex.cz>,
"Takashi Iwai" <tiwai@suse.com>,
linux-gpio@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-iio@vger.kernel.org, linux-mmc@vger.kernel.org,
netdev@vger.kernel.org, linux-phy@lists.infradead.org,
linux-sound@vger.kernel.org
Subject: Re: [PATCH 00/13] gpiolib: add gpiods_set_array_value_cansleep
Date: Fri, 31 Jan 2025 14:51:52 -0600 [thread overview]
Message-ID: <2715ead8-cf6d-4b44-b6e3-343cb6489eca@baylibre.com> (raw)
In-Reply-To: <4ad45123-134a-4544-ad0a-24371105d96f@lunn.ch>
On 1/31/25 2:38 PM, Andrew Lunn wrote:
>> So I'm proposing that we add a gpiods_set_array_value_cansleep()
>> function that is a wrapper around gpiod_set_array_value_cansleep()
>> that has struct gpio_descs as the first parameter to make it a bit
>> easier to read the code and avoid the hard-coding temptation.
>
> This looks reasonable.
>
> How do you plan to get it merged, since you cross a lot of subsystems
> here.
>
> Andrew
Since these are mostly small changes and most of the touched drivers aren't
seeing much action, I think it would be OK for as much as possible to go through
the GPIO tree.
We might need an immutable branch from that though since I know that iio: adc:
ad7606 is currently being actively worked on.
If there are any patches leftover that don't get acked to go through the GPIO
tree, I can resubmit them after the next kernel release cycle since none of
this is urgent anyway.
--
linux-phy mailing list
linux-phy@lists.infradead.org
https://lists.infradead.org/mailman/listinfo/linux-phy
next prev parent reply other threads:[~2025-01-31 20:51 UTC|newest]
Thread overview: 74+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-31 20:24 [PATCH 00/13] gpiolib: add gpiods_set_array_value_cansleep David Lechner
2025-01-31 20:24 ` David Lechner
2025-01-31 20:24 ` [PATCH 01/13] gpiolib: add gpiods_set_array_value_cansleep() David Lechner
2025-01-31 20:24 ` David Lechner
2025-02-02 10:06 ` Andy Shevchenko
2025-02-02 10:06 ` Andy Shevchenko
2025-01-31 20:24 ` [PATCH 02/13] auxdisplay: seg-led-gpio: use gpiods_set_array_value_cansleep David Lechner
2025-01-31 20:24 ` David Lechner
2025-02-02 10:08 ` Andy Shevchenko
2025-02-02 10:08 ` Andy Shevchenko
2025-02-03 10:34 ` Geert Uytterhoeven
2025-02-03 10:34 ` Geert Uytterhoeven
2025-02-03 12:10 ` Andy Shevchenko
2025-02-03 12:10 ` Andy Shevchenko
2025-01-31 20:24 ` [PATCH 03/13] bus: ts-nbus: validate ts,data-gpios array size David Lechner
2025-01-31 20:24 ` David Lechner
2025-01-31 20:24 ` [PATCH 04/13] bus: ts-nbus: use gpiods_set_array_value_cansleep David Lechner
2025-01-31 20:24 ` David Lechner
2025-01-31 20:24 ` [PATCH 05/13] gpio: max3191x: " David Lechner
2025-01-31 20:24 ` David Lechner
2025-02-02 10:12 ` Andy Shevchenko
2025-02-02 10:12 ` Andy Shevchenko
2025-01-31 20:24 ` [PATCH 06/13] iio: adc: ad7606: " David Lechner
2025-01-31 20:24 ` David Lechner
2025-01-31 20:24 ` [PATCH 07/13] iio: amplifiers: hmc425a: " David Lechner
2025-01-31 20:24 ` David Lechner
2025-01-31 20:24 ` [PATCH 08/13] iio: resolver: ad2s1210: " David Lechner
2025-01-31 20:24 ` David Lechner
2025-01-31 20:24 ` [PATCH 09/13] mmc: pwrseq_simple: " David Lechner
2025-01-31 20:24 ` David Lechner
2025-02-04 15:37 ` Ulf Hansson
2025-02-04 15:37 ` Ulf Hansson
2025-01-31 20:24 ` [PATCH 10/13] mux: gpio: " David Lechner
2025-01-31 20:24 ` David Lechner
2025-02-01 0:34 ` Peter Rosin
2025-02-01 0:34 ` Peter Rosin
2025-01-31 20:24 ` [PATCH 11/13] net: mdio: mux-gpio: " David Lechner
2025-01-31 20:24 ` David Lechner
2025-01-31 20:24 ` [PATCH 12/13] phy: mapphone-mdm6600: " David Lechner
2025-01-31 20:24 ` David Lechner
2025-02-02 10:20 ` Andy Shevchenko
2025-02-02 10:20 ` Andy Shevchenko
2025-01-31 20:24 ` [PATCH 13/13] ASoC: adau1701: " David Lechner
2025-01-31 20:24 ` David Lechner
2025-02-02 10:24 ` Andy Shevchenko
2025-02-02 10:24 ` Andy Shevchenko
2025-02-03 12:24 ` Mark Brown
2025-02-03 12:24 ` Mark Brown
2025-01-31 20:38 ` [PATCH 00/13] gpiolib: add gpiods_set_array_value_cansleep Andrew Lunn
2025-01-31 20:38 ` Andrew Lunn
2025-01-31 20:51 ` David Lechner [this message]
2025-01-31 20:51 ` David Lechner
2025-02-01 12:45 ` Jonathan Cameron
2025-02-01 12:45 ` Jonathan Cameron
2025-01-31 22:45 ` Linus Walleij
2025-01-31 22:45 ` Linus Walleij
2025-02-01 10:36 ` Bartosz Golaszewski
2025-02-01 10:36 ` Bartosz Golaszewski
2025-02-01 15:10 ` Andy Shevchenko
2025-02-01 15:10 ` Andy Shevchenko
2025-02-01 16:09 ` David Lechner
2025-02-01 16:09 ` David Lechner
2025-02-01 16:14 ` Bartosz Golaszewski
2025-02-01 16:14 ` Bartosz Golaszewski
2025-02-01 16:17 ` David Lechner
2025-02-01 16:17 ` David Lechner
2025-02-01 16:22 ` Bartosz Golaszewski
2025-02-01 16:22 ` Bartosz Golaszewski
2025-02-01 19:47 ` Andy Shevchenko
2025-02-01 19:47 ` Andy Shevchenko
2025-02-03 22:39 ` David Lechner
2025-02-03 22:39 ` David Lechner
2025-02-04 8:52 ` Bartosz Golaszewski
2025-02-04 8:52 ` Bartosz Golaszewski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2715ead8-cf6d-4b44-b6e3-343cb6489eca@baylibre.com \
--to=dlechner@baylibre.com \
--cc=Michael.Hennerich@analog.com \
--cc=andrew@lunn.ch \
--cc=andy@kernel.org \
--cc=brgl@bgdev.pl \
--cc=broonie@kernel.org \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=geert@linux-m68k.org \
--cc=hkallweit1@gmail.com \
--cc=jic23@kernel.org \
--cc=kishon@kernel.org \
--cc=kuba@kernel.org \
--cc=lars@metafoo.de \
--cc=lgirdwood@gmail.com \
--cc=linus.walleij@linaro.org \
--cc=linux-gpio@vger.kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mmc@vger.kernel.org \
--cc=linux-phy@lists.infradead.org \
--cc=linux-sound@vger.kernel.org \
--cc=linux@armlinux.org.uk \
--cc=netdev@vger.kernel.org \
--cc=nuno.sa@analog.com \
--cc=pabeni@redhat.com \
--cc=peda@axentia.se \
--cc=perex@perex.cz \
--cc=tiwai@suse.com \
--cc=ulf.hansson@linaro.org \
--cc=vkoul@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.