All of lore.kernel.org
 help / color / mirror / Atom feed
From: Damien Le Moal <dlemoal@kernel.org>
To: Niklas Cassel <cassel@kernel.org>,
	Stefan Hajnoczi <stefanha@redhat.com>,
	 Kevin Wolf <kwolf@redhat.com>, Hanna Reitz <hreitz@redhat.com>,
	"Michael S. Tsirkin" <mst@redhat.com>
Cc: Sam Li <faithilikerun@gmail.com>,
	qemu-block@nongnu.org, qemu-devel@nongnu.org
Subject: Re: [PATCH 02/12] virtio-blk: do not merge writes across a zone boundary
Date: Fri, 28 Aug 2026 15:02:42 +0900	[thread overview]
Message-ID: <2c5edc3b-87cd-49e0-81d4-06c0036831f5@kernel.org> (raw)
In-Reply-To: <20260825205748.679968-3-cassel@kernel.org>

On 8/26/26 05:57, Niklas Cassel wrote:
> From: Sam Li <faithilikerun@gmail.com>
> 
> virtio_blk_submit_multireq() fuses adjacent in-zone requests into a
> single request. On a zoned backend, a merged zone append request
> that straddles a zone boundary is rejected by the device because
> each write must stay within a single zone.
> 
> Add a bail condition to the merge coalescer: if combining the
> candidate request into the current batch would cross a zone
> boundary, flush the current batch and start a new one.
> 
> Signed-off-by: Sam Li <faithilikerun@gmail.com>
> Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com>
> Reviewed-by: Niklas Cassel <cassel@kernel.org>
> Signed-off-by: Niklas Cassel <cassel@kernel.org>

Looks good.

Reviewed-by: Damien Le Moal <dlemoal@kernel.org>

A couple of minor nit below.

> @@ -309,17 +312,34 @@ static void virtio_blk_submit_multireq(VirtIOBlock *s, MultiReqBuffer *mrb)
>      for (i = 0; i < mrb->num_reqs; i++) {
>          VirtIOBlockReq *req = mrb->reqs[i];
>          if (num_reqs > 0) {
> +            zone_cross = false;

Move this as a else of the if below.

> +
> +            /*
> +             * On zoned backends, a single backend write/read must not span
> +             * a zone boundary. Bail out of merging if combining req into
> +             * the current batch would straddle a zone.
> +             */
> +            if (zone_size > 0) {
> +                zone_sector = zone_size / BDRV_SECTOR_SIZE;

Super confusing name. Can we have this be zone_nr_sectors ?

> +                end_sector = req->sector_num
> +                                + req->qiov.size / BDRV_SECTOR_SIZE - 1;
> +                zone_cross = (sector_num / zone_sector) !=
> +                             (end_sector / zone_sector);
> +            }

-- 
Damien Le Moal
Western Digital Research


  reply	other threads:[~2026-08-28  6:03 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-25 20:57 [PATCH 00/12] block: fix the zone write granularity and the zone append limit Niklas Cassel
2026-08-25 20:57 ` [PATCH 01/12] block: widen BlockLimits.zone_size to uint64_t Niklas Cassel
2026-08-28  5:58   ` Damien Le Moal
2026-08-25 20:57 ` [PATCH 02/12] virtio-blk: do not merge writes across a zone boundary Niklas Cassel
2026-08-28  6:02   ` Damien Le Moal [this message]
2026-08-25 20:57 ` [PATCH 03/12] file-posix: fix zone write granularity assignment for zoned block devices Niklas Cassel
2026-08-25 20:57 ` [PATCH 04/12] virtio-blk: report the effective zone write granularity Niklas Cassel
2026-08-28  6:03   ` Damien Le Moal
2026-08-25 20:57 ` [PATCH 05/12] virtio-blk: check the write granularity of writes to sequential zones Niklas Cassel
2026-08-28  6:07   ` Damien Le Moal
2026-08-28  6:09     ` Damien Le Moal
2026-08-25 20:57 ` [PATCH 06/12] hw/block: reject a zoned device whose write pointers are unaddressable Niklas Cassel
2026-08-28  6:12   ` Damien Le Moal
2026-08-25 20:57 ` [PATCH 07/12] block: reject zone appends that are not a multiple of the sector size Niklas Cassel
2026-08-28  6:13   ` Damien Le Moal
2026-08-25 20:57 ` [PATCH 08/12] file-posix: remove the zone append write granularity check Niklas Cassel
2026-08-28  6:14   ` Damien Le Moal
2026-08-25 20:57 ` [PATCH 09/12] file-posix: base the zone append limit on the transfer limit Niklas Cassel
2026-08-28  6:17   ` Damien Le Moal
2026-08-25 20:57 ` [PATCH 10/12] virtio-blk: derive the maximum zone append size Niklas Cassel
2026-08-28  6:18   ` Damien Le Moal
2026-08-25 20:57 ` [PATCH 11/12] file-posix: reject a zone append past the device capacity Niklas Cassel
2026-08-28  6:18   ` Damien Le Moal
2026-08-25 20:57 ` [PATCH 12/12] file-posix: reject a zone append to a full or conventional zone Niklas Cassel
2026-08-28  6:19   ` Damien Le Moal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2c5edc3b-87cd-49e0-81d4-06c0036831f5@kernel.org \
    --to=dlemoal@kernel.org \
    --cc=cassel@kernel.org \
    --cc=faithilikerun@gmail.com \
    --cc=hreitz@redhat.com \
    --cc=kwolf@redhat.com \
    --cc=mst@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=stefanha@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.