All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/7] Add SDCA DAI ops helpers
@ 2025-07-07 12:41 Charles Keepax
  2025-07-07 12:41 ` [PATCH 1/7] ASoC: SDCA: Allow read-only controls to be deferrable Charles Keepax
                   ` (8 more replies)
  0 siblings, 9 replies; 12+ messages in thread
From: Charles Keepax @ 2025-07-07 12:41 UTC (permalink / raw)
  To: broonie
  Cc: lgirdwood, yung-chuan.liao, pierre-louis.bossart, peter.ujfalusi,
	patches, linux-sound

First, a couple of minor code fixups to already submitted code. Then
some patches to add new DAI ops helpers for the SDCA stuff, these allow
configuring things like the sample rate and finding out which SoundWire
port should be used for a specific SDCA streaming input/output terminal.
Still a few bits of outstanding work here (propogation of Cluster
information particularly) but his should be good enough to get some
basic use-cases working.

Hopefully we are getting fairly close to completing a first version of
the SDCA work now. Should be one more series to add FDL (firmware
downloading), then we should be able to send a first version of the
actual SDCA class driver itself.

Thanks,
Charles

Charles Keepax (7):
  ASoC: SDCA: Allow read-only controls to be deferrable
  ASoC: SDCA: Remove overly chatty input pin list warning
  ASoC: SDCA: Move SDCA search functions and export
  ASoC: soc-dai: Add private data to snd_soc_dai
  ASoC: SDCA: Add helper to add DAI constraints
  ASoC: SDCA: Add a helper to get the SoundWire port number
  ASoC: SDCA: Add hw_params() helper function

 include/sound/sdca_asoc.h       |  19 ++
 include/sound/sdca_function.h   |  31 +++
 include/sound/soc-dai.h         |   3 +
 sound/soc/sdca/sdca_asoc.c      | 427 +++++++++++++++++++++++++++-----
 sound/soc/sdca/sdca_functions.c |  72 +++++-
 5 files changed, 490 insertions(+), 62 deletions(-)

-- 
2.39.5


^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2025-07-21  9:58 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-07-07 12:41 [PATCH 0/7] Add SDCA DAI ops helpers Charles Keepax
2025-07-07 12:41 ` [PATCH 1/7] ASoC: SDCA: Allow read-only controls to be deferrable Charles Keepax
2025-07-07 12:41 ` [PATCH 2/7] ASoC: SDCA: Remove overly chatty input pin list warning Charles Keepax
2025-07-07 12:41 ` [PATCH 3/7] ASoC: SDCA: Move SDCA search functions and export Charles Keepax
2025-07-07 12:41 ` [PATCH 4/7] ASoC: soc-dai: Add private data to snd_soc_dai Charles Keepax
2025-07-07 12:41 ` [PATCH 5/7] ASoC: SDCA: Add helper to add DAI constraints Charles Keepax
2025-07-07 12:41 ` [PATCH 6/7] ASoC: SDCA: Add a helper to get the SoundWire port number Charles Keepax
2025-07-07 12:41 ` [PATCH 7/7] ASoC: SDCA: Add hw_params() helper function Charles Keepax
2025-07-15 17:58 ` [PATCH 0/7] Add SDCA DAI ops helpers Pierre-Louis Bossart
2025-07-16  8:28   ` Charles Keepax
2025-07-21  9:55     ` Pierre-Louis Bossart
2025-07-16 18:41 ` Mark Brown

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.