All of lore.kernel.org
 help / color / mirror / Atom feed
From: <Tudor.Ambarus@microchip.com>
To: <michael@walle.cc>, <vigneshr@ti.com>
Cc: richard@nod.at, computersforpeace@gmail.com,
	linux-mtd@lists.infradead.org, linux-kernel@vger.kernel.org,
	miquel.raynal@bootlin.com
Subject: Re: [PATCH 2/2] mtd: spi-nor: fix locking argument in spi_nor_is_locked()
Date: Mon, 13 Jan 2020 11:09:04 +0000	[thread overview]
Message-ID: <5175555.c6S9m0lmIv@localhost.localdomain> (raw)
In-Reply-To: <7344bb68b2714755a736e8d27e06aa8e@walle.cc>

On Monday, January 13, 2020 12:19:47 PM EET Michael Walle wrote:
> EXTERNAL EMAIL: Do not click links or open attachments unless you know the
> content is safe
> Am 2020-01-13 11:10, schrieb Tudor.Ambarus@microchip.com:
> > Hi, Michael,
> > 
> > On Wednesday, January 8, 2020 12:23:17 AM EET Michael Walle wrote:
> >> diff --git a/include/linux/mtd/spi-nor.h b/include/linux/mtd/spi-nor.h
> >> index b661fd948a25..a8fcb1d70510 100644
> >> --- a/include/linux/mtd/spi-nor.h
> >> +++ b/include/linux/mtd/spi-nor.h
> >> @@ -235,6 +235,7 @@ enum spi_nor_ops {
> >> 
> >>         SPI_NOR_OPS_ERASE,
> >>         SPI_NOR_OPS_LOCK,
> >>         SPI_NOR_OPS_UNLOCK,
> >> 
> >> +       SPI_NOR_OPS_IS_LOCKED,
> >> 
> >>  };
> > 
> > There is no NOR controller that uses this enum, can we get rid of it?
> 
> you mean the second argument of the spi_nor_lock_and_prep() and
> spi_nor_unlock_and_unprep()? sure. But it removes information from the

yes

> prepare() callback. like in "prepare what?". From what I see its only

Prepare the controller for whatever op. As I see, it is used for taking a bus 
mutex and for enabling some clock.
 
> used for locking. Maybe then rename it to prepare_lock and
> prepare_unlock.
> 

I would keep the function name as it is. Maybe Vignesh has some other opinion 
on this?

Cheers,
ta



______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

WARNING: multiple messages have this Message-ID (diff)
From: <Tudor.Ambarus@microchip.com>
To: <michael@walle.cc>, <vigneshr@ti.com>
Cc: <linux-mtd@lists.infradead.org>, <linux-kernel@vger.kernel.org>,
	<miquel.raynal@bootlin.com>, <richard@nod.at>,
	<computersforpeace@gmail.com>
Subject: Re: [PATCH 2/2] mtd: spi-nor: fix locking argument in spi_nor_is_locked()
Date: Mon, 13 Jan 2020 11:09:04 +0000	[thread overview]
Message-ID: <5175555.c6S9m0lmIv@localhost.localdomain> (raw)
In-Reply-To: <7344bb68b2714755a736e8d27e06aa8e@walle.cc>

On Monday, January 13, 2020 12:19:47 PM EET Michael Walle wrote:
> EXTERNAL EMAIL: Do not click links or open attachments unless you know the
> content is safe
> Am 2020-01-13 11:10, schrieb Tudor.Ambarus@microchip.com:
> > Hi, Michael,
> > 
> > On Wednesday, January 8, 2020 12:23:17 AM EET Michael Walle wrote:
> >> diff --git a/include/linux/mtd/spi-nor.h b/include/linux/mtd/spi-nor.h
> >> index b661fd948a25..a8fcb1d70510 100644
> >> --- a/include/linux/mtd/spi-nor.h
> >> +++ b/include/linux/mtd/spi-nor.h
> >> @@ -235,6 +235,7 @@ enum spi_nor_ops {
> >> 
> >>         SPI_NOR_OPS_ERASE,
> >>         SPI_NOR_OPS_LOCK,
> >>         SPI_NOR_OPS_UNLOCK,
> >> 
> >> +       SPI_NOR_OPS_IS_LOCKED,
> >> 
> >>  };
> > 
> > There is no NOR controller that uses this enum, can we get rid of it?
> 
> you mean the second argument of the spi_nor_lock_and_prep() and
> spi_nor_unlock_and_unprep()? sure. But it removes information from the

yes

> prepare() callback. like in "prepare what?". From what I see its only

Prepare the controller for whatever op. As I see, it is used for taking a bus 
mutex and for enabling some clock.
 
> used for locking. Maybe then rename it to prepare_lock and
> prepare_unlock.
> 

I would keep the function name as it is. Maybe Vignesh has some other opinion 
on this?

Cheers,
ta



  reply	other threads:[~2020-01-13 11:09 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-07 22:23 [PATCH 1/2] mtd: spi-nor: fix spi_nor_lock_and_prep() usage Michael Walle
2020-01-07 22:23 ` Michael Walle
2020-01-07 22:23 ` [PATCH 2/2] mtd: spi-nor: fix locking argument in spi_nor_is_locked() Michael Walle
2020-01-07 22:23   ` Michael Walle
2020-01-13 10:10   ` Tudor.Ambarus
2020-01-13 10:10     ` Tudor.Ambarus
2020-01-13 10:19     ` Michael Walle
2020-01-13 10:19       ` Michael Walle
2020-01-13 11:09       ` Tudor.Ambarus [this message]
2020-01-13 11:09         ` Tudor.Ambarus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5175555.c6S9m0lmIv@localhost.localdomain \
    --to=tudor.ambarus@microchip.com \
    --cc=computersforpeace@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=michael@walle.cc \
    --cc=miquel.raynal@bootlin.com \
    --cc=richard@nod.at \
    --cc=vigneshr@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.