From: "Philippe Mathieu-Daudé" <philmd@oss.qualcomm.com>
To: Alistair <alistair@alistair23.me>,
stephensportia@gmail.com, qemu-devel@nongnu.org,
Bin Meng <bin.meng@processmission.com>
Cc: "Palmer Dabbelt" <palmer@dabbelt.com>,
"Peter Maydell" <peter.maydell@linaro.org>,
"Jamin Lin" <jamin_lin@aspeedtech.com>,
qemu-ppc@nongnu.org, "Cédric Le Goater" <clg@kaod.org>,
"Steven Lee" <steven_lee@aspeedtech.com>,
"Andrew Jeffery" <andrew@codeconstruct.com.au>,
"Harsh Prateek Bora" <harshpb@linux.ibm.com>,
"Subbaraya Sundeep" <sundeep.lkml@gmail.com>,
"Troy Lee" <leetroy@gmail.com>,
"Edgar E. Iglesias" <edgar.iglesias@gmail.com>,
"Philippe Mathieu-Daudé" <philmd@mailo.com>,
"Strahinja Jankovic" <strahinja.p.jankovic@gmail.com>,
qemu-arm@nongnu.org, "Tyrone Ting" <kfting@nuvoton.com>,
"Nicholas Piggin" <npiggin@gmail.com>,
"Aditya Gupta" <adityag@linux.ibm.com>,
"Kane Chen" <kane_chen@aspeedtech.com>,
"Francisco Iglesias" <francisco.iglesias@amd.com>,
"Joel Stanley" <joel@jms.id.au>, "Hao Wu" <wuhaotsh@google.com>,
"Glenn Miles" <milesg@linux.ibm.com>,
qemu-riscv@nongnu.org,
"Jean-Christophe Dubois" <jcd@tribudubois.net>,
"Portia Stephens" <portias@oss.tenstorrent.com>
Subject: Re: [PATCH 0/4] Rename ssi_transfer to ssi_transfer8
Date: Thu, 27 Aug 2026 12:31:57 +0200 [thread overview]
Message-ID: <53ce22e0-a26e-4641-ba20-0ae65b290bc7@oss.qualcomm.com> (raw)
In-Reply-To: <d88347aa69db68c498b593eabcd2377413ff4af5.camel@alistair23.me>
Hi Alistair,
On 27/8/26 07:37, Alistair wrote:
> On Tue, 2026-08-25 at 14:04 +1000, stephensportia@gmail.com wrote:
>> From: Portia Stephens <portias@oss.tenstorrent.com>
>>
>> The ssi_transfer function comments say that it takes a word varying
>> between 8-bits and 32-bits. ssi_transfer takes a 32-bit arg to
>> transfer
>> but there is no means to indicate the number of bits that should
>> actually be transferred. All child classes of SSI_PERIPHERAL class
>> have
>> transfer functions that, despite accepting a 32-bit tx, only transfer
>> a
>> single byte; m25p80_transfer8(), ssi_sd_transfer(),
>> ssd0323_transfer().
>>
>> The current implementation depends on the SSI model to know
>> what peripheral model will be attached and what transfer size it
>> expects which is error prone. If a SSI_PERIPHERAL model was written
>> that
>> accepted 32-bit transfers, it could not attach to any existing SSI
>> models.
>>
>> This change updates the the naming of ssi_transfer to ssi_transfer8,
>> as
>> well as changes the return value and transmit argument to be 8-bit.
>>
>> Most ssi models handle this correctly already, sending a single byte
>> at
>> a time. There are a few models that are written to support non 8-bit
>> transfers but there are no in-tree use cases that connect a
>> peripheral
>> to the SSI device. These have been updated to use 8-bit transfers.
>>
>> Portia Stephens (4):
>> hw/ssi: Rename ssi_transfer to ssi_transfer8
>> hw/ssi/pl022: Fix dropped upper bytes of ssi transfer
>> hw/arm/strongarm: Fix dropped upper byte of ssi transfer
>> hw/ssi/pnv_spi: Fix dropped upper bytes of ssi transfer
>
> Thanks!
>
> Applied to riscv-to-apply.next
Can you hold on before merging this please (or drop it from
your riscv queue)? I tagged this series to review but didn't
got a sufficient large enough slot to look at it.
In short, the reason I think this isn't the correct way to go
is SPI "words" can be any number of bits. While QEMU only
models 8-bit word devices, I have be working with 16-bit and
even 24-bit words ones, so I believe the current implementation
is right. I have be thinking of a better way to model this
granularity in our class hooks, but haven't find a good one yet.
Restricting some devices to 8-bit to simplify them move part
of the complexity to the host controller so I'm not sure it
is useful. I'll return with clearer comments when I get more
time.
Thanks,
Phil.
next prev parent reply other threads:[~2026-08-27 10:32 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-25 4:04 [PATCH 0/4] Rename ssi_transfer to ssi_transfer8 stephensportia
2026-08-25 4:04 ` [PATCH 1/4] hw/ssi: " stephensportia
2026-08-27 5:25 ` Alistair
2026-08-25 4:04 ` [PATCH 2/4] hw/ssi/pl022: Fix dropped upper bytes of ssi transfer stephensportia
2026-08-27 5:27 ` Alistair
2026-08-25 4:04 ` [PATCH 3/4] hw/arm/strongarm: Fix dropped upper byte " stephensportia
2026-08-27 5:29 ` Alistair
2026-08-27 9:09 ` Peter Maydell
2026-08-27 10:53 ` Portia Stephens
2026-08-27 11:04 ` Peter Maydell
2026-08-25 4:04 ` [PATCH 4/4] hw/ssi/pnv_spi: Fix dropped upper bytes " stephensportia
2026-08-27 5:31 ` Alistair
2026-08-27 5:37 ` [PATCH 0/4] Rename ssi_transfer to ssi_transfer8 Alistair
2026-08-27 9:20 ` Peter Maydell
2026-08-27 11:06 ` Alistair
2026-08-27 10:31 ` Philippe Mathieu-Daudé [this message]
2026-08-27 9:19 ` Peter Maydell
2026-08-27 10:35 ` Philippe Mathieu-Daudé
2026-08-27 10:37 ` Portia Stephens
2026-08-27 10:53 ` Peter Maydell
2026-08-27 11:03 ` Alistair
2026-08-27 11:17 ` Peter Maydell
2026-08-28 0:07 ` Alistair
2026-08-31 13:00 ` Cédric Le Goater
2026-09-01 8:56 ` Bin Meng
2026-08-27 12:52 ` Portia Stephens
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=53ce22e0-a26e-4641-ba20-0ae65b290bc7@oss.qualcomm.com \
--to=philmd@oss.qualcomm.com \
--cc=adityag@linux.ibm.com \
--cc=alistair@alistair23.me \
--cc=andrew@codeconstruct.com.au \
--cc=bin.meng@processmission.com \
--cc=clg@kaod.org \
--cc=edgar.iglesias@gmail.com \
--cc=francisco.iglesias@amd.com \
--cc=harshpb@linux.ibm.com \
--cc=jamin_lin@aspeedtech.com \
--cc=jcd@tribudubois.net \
--cc=joel@jms.id.au \
--cc=kane_chen@aspeedtech.com \
--cc=kfting@nuvoton.com \
--cc=leetroy@gmail.com \
--cc=milesg@linux.ibm.com \
--cc=npiggin@gmail.com \
--cc=palmer@dabbelt.com \
--cc=peter.maydell@linaro.org \
--cc=philmd@mailo.com \
--cc=portias@oss.tenstorrent.com \
--cc=qemu-arm@nongnu.org \
--cc=qemu-devel@nongnu.org \
--cc=qemu-ppc@nongnu.org \
--cc=qemu-riscv@nongnu.org \
--cc=stephensportia@gmail.com \
--cc=steven_lee@aspeedtech.com \
--cc=strahinja.p.jankovic@gmail.com \
--cc=sundeep.lkml@gmail.com \
--cc=wuhaotsh@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.