All of lore.kernel.org
 help / color / mirror / Atom feed
From: Matthieu Baerts <matttbe@kernel.org>
To: Geliang Tang <geliang@kernel.org>, mptcp@lists.linux.dev
Cc: Geliang Tang <tanggeliang@kylinos.cn>
Subject: Re: [PATCH mptcp-next 1/3] mptcp: rename add_addr_timeout to add_addr_timeout_max
Date: Wed, 30 Jul 2025 11:22:49 +0200	[thread overview]
Message-ID: <55c6f823-a02b-4521-a406-b91f0d26a2c7@kernel.org> (raw)
In-Reply-To: <ce610ee45e07da2680d5838fd605b1c26543782a.1753777199.git.tanggeliang@kylinos.cn>

Hi Geliang,

On 29/07/2025 10:22, Geliang Tang wrote:
> From: Geliang Tang <tanggeliang@kylinos.cn>
> 
> This renames the MPTCP sysctl variable to better reflect its purpose as
> the maximum ADD_ADDR retransmission timeout.

I don't think we can rename a sysctl knob: it is sort of part of the API
as it is exposed. Either we deprecate it with a warning in the doc +
pr_warn() somewhere, or use it as a max value without renaming it (at
least not renaming the exposed variable: .procname).

I think it should be fine to use it as a max value because it was set to
TCP_RTO_MAX by default, and this timeout is in second. If you do that,
you can probably squash patch 1 and 2.

Cheers,
Matt
-- 
Sponsored by the NGI0 Core fund.


  reply	other threads:[~2025-07-30  9:22 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-29  8:22 [PATCH mptcp-next 0/3] mptcp: improve ADD_ADDR timeout handling Geliang Tang
2025-07-29  8:22 ` [PATCH mptcp-next 1/3] mptcp: rename add_addr_timeout to add_addr_timeout_max Geliang Tang
2025-07-30  9:22   ` Matthieu Baerts [this message]
2025-07-29  8:22 ` [PATCH mptcp-next 2/3] mptcp: make ADD_ADDR timeout adaptive to subflow RTT Geliang Tang
2025-07-30  9:26   ` Matthieu Baerts
2025-07-29  8:22 ` [PATCH mptcp-next 3/3] selftests: mptcp: update for add_addr_timeout_max rename Geliang Tang
2025-07-30  9:26   ` Matthieu Baerts
2025-07-29 10:24 ` [PATCH mptcp-next 0/3] mptcp: improve ADD_ADDR timeout handling MPTCP CI
2025-07-30  9:20 ` Matthieu Baerts

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=55c6f823-a02b-4521-a406-b91f0d26a2c7@kernel.org \
    --to=matttbe@kernel.org \
    --cc=geliang@kernel.org \
    --cc=mptcp@lists.linux.dev \
    --cc=tanggeliang@kylinos.cn \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.