All of lore.kernel.org
 help / color / mirror / Atom feed
From: Nicola Vetrini <nicola.vetrini@bugseng.com>
To: Andrew Cooper <andrew.cooper3@citrix.com>
Cc: "Stefano Stabellini" <sstabellini@kernel.org>,
	Xen-devel <xen-devel@lists.xenproject.org>,
	"Jan Beulich" <JBeulich@suse.com>,
	"Roger Pau Monné" <roger.pau@citrix.com>, "Wei Liu" <wl@xen.org>,
	"Julien Grall" <julien@xen.org>,
	"Volodymyr Babchuk" <Volodymyr_Babchuk@epam.com>,
	"Bertrand Marquis" <bertrand.marquis@arm.com>,
	"Michal Orzel" <michal.orzel@amd.com>,
	"Oleksii Kurochko" <oleksii.kurochko@gmail.com>,
	"Shawn Anastasio" <sanastasio@raptorengineering.com>,
	"consulting @ bugseng . com" <consulting@bugseng.com>,
	"Simone Ballarin" <simone.ballarin@bugseng.com>,
	"Federico Serafini" <federico.serafini@bugseng.com>
Subject: Re: [PATCH v2 06/13] xen/bitops: Implement ffs() in common logic
Date: Sat, 01 Jun 2024 09:51:16 +0200	[thread overview]
Message-ID: <59dc805e3401a47668a162f4f35adba7@bugseng.com> (raw)
In-Reply-To: <f7ea72c3-45ef-43cb-ab57-b375a4fbc683@citrix.com>

[-- Attachment #1: Type: text/plain, Size: 3165 bytes --]

On 2024-05-31 10:48, Andrew Cooper wrote:
> On 31/05/2024 9:34 am, Andrew Cooper wrote:
>> On 31/05/2024 7:56 am, Nicola Vetrini wrote:
>>> On 2024-05-31 03:14, Stefano Stabellini wrote:
>>>> On Fri, 24 May 2024, Andrew Cooper wrote:
>>>>> Perform constant-folding unconditionally, rather than having it
>>>>> implemented
>>>>> inconsistency between architectures.
>>>>> 
>>>>> Confirm the expected behaviour with compile time and boot time 
>>>>> tests.
>>>>> 
>>>>> For non-constant inputs, use arch_ffs() if provided but fall back 
>>>>> to
>>>>> generic_ffsl() if not.  In particular, RISC-V doesn't have a 
>>>>> builtin
>>>>> that
>>>>> works in all configurations.
>>>>> 
>>>>> For x86, rename ffs() to arch_ffs() and adjust the prototype.
>>>>> 
>>>>> For PPC, __builtin_ctz() is 1/3 of the size of size of the 
>>>>> transform to
>>>>> generic_fls().  Drop the definition entirely.  ARM too benefits in
>>>>> the general
>>>>> case by using __builtin_ctz(), but less dramatically because it 
>>>>> using
>>>>> optimised asm().
>>>>> 
>>>>> Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com>
>>>> This patch made me realize that we should add __builtin_ctz,
>>>> __builtin_constant_p and always_inline to
>>>> docs/misra/C-language-toolchain.rst as they don't seem to be 
>>>> currently
>>>> documented and they are not part of the C standard
>>>> 
>>>> Patch welcome :-)
>>>> 
>>> I can send a patch for the builtins.
>> That's very kind of you.
>> 
>> In total by the end of this series, we've got __builtin_constant_p() 
>> (definitely used elsewhere already), and 
>> __builtin_{ffs,ctz,clz}{,l}() 
>> (3x primitives, 2x input types).
>> 
>> If we're going for a list of the primitive operations, lets add
>> __builtin_popcnt{,l}() too right away, because if it weren't for 4.19
>> code freeze, I'd have cleaned up the hweight() helpers too.
> 
> Oh, and it's worth noting that __builtin_{ctz,clz}{,l}() have explicit
> UB if given an input of 0.  (Sadly, even on architectures where the
> underlying instruction emitted is safe with a 0 input. [0])
> 
> This is why every patch in the series using them checks for nonzero 
> input.
> 
> UBSAN (with an adequate compiler) will instrument this, and Xen has
> __ubsan_handle_invalid_builtin() to diagnose these.
> 
> ~Andrew
> 
> [0] It turns out that Clang has a 2-argument form of the builtin with
> the second being the "value forwarded" in case the first is 0.  I've 
> not
> investigated whether GCC has the same.

Hmm, maybe then it's best if builtins are listed in a separate section 
in that file, for ease of browsing. Xen also uses (conditionally) 
__builtin_mem*, __builtin_str* and others, so if all nonstandard 
intrinsics should be listed (as opposed to the ones in some way relevant 
for MISRA violations, which was the original scope of the document), 
then a subset of the attached list would be needed. There are a handful 
only used in ppc, and since the document only covers x86 and arm, those 
should be ignored for the time being.

Anyway, I'll send an RFC next week to decide the best route.

-- 
Nicola Vetrini, BSc
Software Engineer, BUGSENG srl (https://bugseng.com)

[-- Attachment #2: builtins.txt --]
[-- Type: text/plain, Size: 724 bytes --]

0|$ git grep -E -o "__builtin[a-z_]+" -- xen | cut -d':' -f2 | sort -u
__builtin_bswap
__builtin_clz
__builtin_clzll
__builtin_constant_p
__builtin_ctz
__builtin_ctzll
__builtin_expect
__builtin_frame_address
__builtin_has_attribute
__builtin_memchr
__builtin_memcmp
__builtin_memcpy
__builtin_memmove
__builtin_memset
__builtin_offsetof
__builtin_popcount
__builtin_popcountll
__builtin_prefetch
__builtin_return_address
__builtin_strcasecmp
__builtin_strchr
__builtin_strcmp
__builtin_strlen
__builtin_strncasecmp
__builtin_strncmp
__builtin_strrchr
__builtin_strstr
__builtin_trap
__builtin_types_compatible_p
__builtin_unreachable
__builtin_va_arg
__builtin_va_copy
__builtin_va_end
__builtin_va_list
__builtin_va_start

  reply	other threads:[~2024-06-01  7:51 UTC|newest]

Thread overview: 50+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-05-24 20:03 [PATCH v2 for-4.19 00/13] xen/bitops: Untangle ffs()/fls() infrastructure Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 01/13] ppc/boot: Run constructors on boot Andrew Cooper
2024-05-29 19:35   ` Shawn Anastasio
2024-05-24 20:03 ` [PATCH v2 02/13] xen/bitops: Cleanup ahead of rearrangements Andrew Cooper
2024-05-27  8:24   ` Jan Beulich
2024-05-31 22:41     ` Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 03/13] ARM/bitops: Change find_first_set_bit() to be a define Andrew Cooper
2024-05-31  0:57   ` Stefano Stabellini
2024-05-24 20:03 ` [PATCH v2 04/13] xen/page_alloc: Coerce min(flsl(), foo) expressions to being unsigned Andrew Cooper
2024-05-27  6:26   ` Jan Beulich
2024-05-29 19:07     ` Andrew Cooper
2024-05-29 19:19       ` Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 05/13] xen/bitops: Implement generic_f?sl() in lib/ Andrew Cooper
2024-05-27  8:44   ` Jan Beulich
2024-05-28 13:20     ` Andrew Cooper
2024-05-31  1:03     ` Stefano Stabellini
2024-05-24 20:03 ` [PATCH v2 06/13] xen/bitops: Implement ffs() in common logic Andrew Cooper
2024-05-27 12:33   ` Jan Beulich
2024-05-31  1:14   ` Stefano Stabellini
2024-05-31  6:56     ` Nicola Vetrini
2024-05-31  8:34       ` Andrew Cooper
2024-05-31  8:48         ` Andrew Cooper
2024-06-01  7:51           ` Nicola Vetrini [this message]
2024-05-24 20:03 ` [PATCH v2 07/13] x86/bitops: Improve arch_ffs() in the general case Andrew Cooper
2024-05-27 12:40   ` Jan Beulich
2024-05-27 13:27   ` Jan Beulich
2024-05-27 13:37     ` Jan Beulich
2024-05-28 12:30       ` Andrew Cooper
2024-05-28 13:12         ` Jan Beulich
2024-06-01  1:47           ` Andrew Cooper
2024-06-03  6:24             ` Jan Beulich
2024-05-24 20:03 ` [PATCH v2 08/13] xen/bitops: Implement ffsl() in common logic Andrew Cooper
2024-05-27 12:43   ` Jan Beulich
2024-05-31  1:15     ` Stefano Stabellini
2024-05-24 20:03 ` [PATCH v2 09/13] xen/bitops: Replace find_first_set_bit() with ffsl() - 1 Andrew Cooper
2024-05-27 12:57   ` Jan Beulich
2024-05-24 20:03 ` [PATCH v2 10/13] xen/bitops: Delete find_first_set_bit() Andrew Cooper
2024-05-27 12:58   ` Jan Beulich
2024-05-29 22:17     ` Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 11/13] xen/bitops: Implement fls()/flsl() in common logic Andrew Cooper
2024-05-27 13:38   ` Jan Beulich
2024-05-24 20:03 ` [PATCH v2 12/13] xen/bitops: Clean up ffs64()/fls64() definitions Andrew Cooper
2024-05-27 13:44   ` Jan Beulich
2024-06-01 12:57     ` Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 13/13] xen/bitops: Rearrange the top of xen/bitops.h Andrew Cooper
2024-05-27 13:50   ` Jan Beulich
2024-05-27 13:51 ` [PATCH v2 for-4.19 00/13] xen/bitops: Untangle ffs()/fls() infrastructure Oleksii K.
2024-05-28 14:22 ` [PATCH v2 for-4.19 0.5/13] xen: Introduce CONFIG_SELF_TESTS Andrew Cooper
2024-05-29  7:13   ` Jan Beulich
2024-05-29  7:30   ` Oleksii K.

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=59dc805e3401a47668a162f4f35adba7@bugseng.com \
    --to=nicola.vetrini@bugseng.com \
    --cc=JBeulich@suse.com \
    --cc=Volodymyr_Babchuk@epam.com \
    --cc=andrew.cooper3@citrix.com \
    --cc=bertrand.marquis@arm.com \
    --cc=consulting@bugseng.com \
    --cc=federico.serafini@bugseng.com \
    --cc=julien@xen.org \
    --cc=michal.orzel@amd.com \
    --cc=oleksii.kurochko@gmail.com \
    --cc=roger.pau@citrix.com \
    --cc=sanastasio@raptorengineering.com \
    --cc=simone.ballarin@bugseng.com \
    --cc=sstabellini@kernel.org \
    --cc=wl@xen.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.