From: Nicola Vetrini <nicola.vetrini@bugseng.com>
To: Stefano Stabellini <sstabellini@kernel.org>
Cc: "Andrew Cooper" <andrew.cooper3@citrix.com>,
Xen-devel <xen-devel@lists.xenproject.org>,
"Jan Beulich" <JBeulich@suse.com>,
"Roger Pau Monné" <roger.pau@citrix.com>, "Wei Liu" <wl@xen.org>,
"Julien Grall" <julien@xen.org>,
"Volodymyr Babchuk" <Volodymyr_Babchuk@epam.com>,
"Bertrand Marquis" <bertrand.marquis@arm.com>,
"Michal Orzel" <michal.orzel@amd.com>,
"Oleksii Kurochko" <oleksii.kurochko@gmail.com>,
"Shawn Anastasio" <sanastasio@raptorengineering.com>,
"consulting @ bugseng . com" <consulting@bugseng.com>,
"Simone Ballarin" <simone.ballarin@bugseng.com>,
"Federico Serafini" <federico.serafini@bugseng.com>
Subject: Re: [PATCH v2 06/13] xen/bitops: Implement ffs() in common logic
Date: Fri, 31 May 2024 08:56:42 +0200 [thread overview]
Message-ID: <7b974b36b89c216379b86170af9de451@bugseng.com> (raw)
In-Reply-To: <alpine.DEB.2.22.394.2405301809170.2557291@ubuntu-linux-20-04-desktop>
On 2024-05-31 03:14, Stefano Stabellini wrote:
> On Fri, 24 May 2024, Andrew Cooper wrote:
>> Perform constant-folding unconditionally, rather than having it
>> implemented
>> inconsistency between architectures.
>>
>> Confirm the expected behaviour with compile time and boot time tests.
>>
>> For non-constant inputs, use arch_ffs() if provided but fall back to
>> generic_ffsl() if not. In particular, RISC-V doesn't have a builtin
>> that
>> works in all configurations.
>>
>> For x86, rename ffs() to arch_ffs() and adjust the prototype.
>>
>> For PPC, __builtin_ctz() is 1/3 of the size of size of the transform
>> to
>> generic_fls(). Drop the definition entirely. ARM too benefits in the
>> general
>> case by using __builtin_ctz(), but less dramatically because it using
>> optimised asm().
>>
>> Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com>
>
> This patch made me realize that we should add __builtin_ctz,
> __builtin_constant_p and always_inline to
> docs/misra/C-language-toolchain.rst as they don't seem to be currently
> documented and they are not part of the C standard
>
> Patch welcome :-)
>
I can send a patch for the builtins. I think that for attributes it was
decided to document the use of the __attribute__ token, rather than
listing all the attributes used by Xen
> Reviewed-by: Stefano Stabellini <sstabellini@kernel.org>
>
>
>> ---
>> CC: Jan Beulich <JBeulich@suse.com>
>> CC: Roger Pau Monné <roger.pau@citrix.com>
>> CC: Wei Liu <wl@xen.org>
>> CC: Stefano Stabellini <sstabellini@kernel.org>
>> CC: Julien Grall <julien@xen.org>
>> CC: Volodymyr Babchuk <Volodymyr_Babchuk@epam.com>
>> CC: Bertrand Marquis <bertrand.marquis@arm.com>
>> CC: Michal Orzel <michal.orzel@amd.com>
>> CC: Oleksii Kurochko <oleksii.kurochko@gmail.com>
>> CC: Shawn Anastasio <sanastasio@raptorengineering.com>
>> CC: consulting@bugseng.com <consulting@bugseng.com>
>> CC: Simone Ballarin <simone.ballarin@bugseng.com>
>> CC: Federico Serafini <federico.serafini@bugseng.com>
>> CC: Nicola Vetrini <nicola.vetrini@bugseng.com>
>>
>> v2:
>> * Fall back to generic, not builtin.
>> * Extend the testing with multi-bit values.
>> * Use always_inline for x86
>> * Defer x86 optimisation to a later change
>> ---
>> xen/arch/arm/include/asm/bitops.h | 2 +-
>> xen/arch/ppc/include/asm/bitops.h | 2 +-
>> xen/arch/x86/include/asm/bitops.h | 3 ++-
>> xen/common/Makefile | 1 +
>> xen/common/bitops.c | 19 +++++++++++++++++++
>> xen/include/xen/bitops.h | 17 +++++++++++++++++
>> 6 files changed, 41 insertions(+), 3 deletions(-)
>> create mode 100644 xen/common/bitops.c
>>
>> diff --git a/xen/arch/arm/include/asm/bitops.h
>> b/xen/arch/arm/include/asm/bitops.h
>> index ec1cf7b9b323..a88ec2612e16 100644
>> --- a/xen/arch/arm/include/asm/bitops.h
>> +++ b/xen/arch/arm/include/asm/bitops.h
>> @@ -157,7 +157,7 @@ static inline int fls(unsigned int x)
>> }
>>
>>
>> -#define ffs(x) ({ unsigned int __t = (x); fls(ISOLATE_LSB(__t)); })
>> +#define arch_ffs(x) ((x) ? 1 + __builtin_ctz(x) : 0)
>> #define ffsl(x) ({ unsigned long __t = (x); flsl(ISOLATE_LSB(__t));
>> })
>>
>> /**
>> diff --git a/xen/arch/ppc/include/asm/bitops.h
>> b/xen/arch/ppc/include/asm/bitops.h
>> index ab692d01717b..5c36a6cc0ce3 100644
>> --- a/xen/arch/ppc/include/asm/bitops.h
>> +++ b/xen/arch/ppc/include/asm/bitops.h
>> @@ -173,7 +173,7 @@ static inline int __test_and_clear_bit(int nr,
>> volatile void *addr)
>>
>> #define flsl(x) generic_flsl(x)
>> #define fls(x) generic_flsl(x)
>> -#define ffs(x) ({ unsigned int t_ = (x); fls(t_ & -t_); })
>> +#define arch_ffs(x) ((x) ? 1 + __builtin_ctz(x) : 0)
>> #define ffsl(x) ({ unsigned long t_ = (x); flsl(t_ & -t_); })
>>
>> /**
>> diff --git a/xen/arch/x86/include/asm/bitops.h
>> b/xen/arch/x86/include/asm/bitops.h
>> index 5a71afbc89d5..122767fc0d10 100644
>> --- a/xen/arch/x86/include/asm/bitops.h
>> +++ b/xen/arch/x86/include/asm/bitops.h
>> @@ -430,7 +430,7 @@ static inline int ffsl(unsigned long x)
>> return (int)r+1;
>> }
>>
>> -static inline int ffs(unsigned int x)
>> +static always_inline unsigned int arch_ffs(unsigned int x)
>> {
>> int r;
>>
>> @@ -440,6 +440,7 @@ static inline int ffs(unsigned int x)
>> "1:" : "=r" (r) : "rm" (x));
>> return r + 1;
>> }
>> +#define arch_ffs arch_ffs
>>
>> /**
>> * fls - find last bit set
>> diff --git a/xen/common/Makefile b/xen/common/Makefile
>> index d512cad5243f..21a4fb4c7166 100644
>> --- a/xen/common/Makefile
>> +++ b/xen/common/Makefile
>> @@ -1,5 +1,6 @@
>> obj-$(CONFIG_ARGO) += argo.o
>> obj-y += bitmap.o
>> +obj-bin-$(CONFIG_DEBUG) += bitops.init.o
>> obj-$(CONFIG_GENERIC_BUG_FRAME) += bug.o
>> obj-$(CONFIG_HYPFS_CONFIG) += config_data.o
>> obj-$(CONFIG_CORE_PARKING) += core_parking.o
>> diff --git a/xen/common/bitops.c b/xen/common/bitops.c
>> new file mode 100644
>> index 000000000000..8c161b8ea7fa
>> --- /dev/null
>> +++ b/xen/common/bitops.c
>> @@ -0,0 +1,19 @@
>> +#include <xen/bitops.h>
>> +#include <xen/boot-check.h>
>> +#include <xen/init.h>
>> +
>> +static void __init test_ffs(void)
>> +{
>> + /* unsigned int ffs(unsigned int) */
>> + CHECK(ffs, 0, 0);
>> + CHECK(ffs, 1, 1);
>> + CHECK(ffs, 3, 1);
>> + CHECK(ffs, 7, 1);
>> + CHECK(ffs, 6, 2);
>> + CHECK(ffs, 0x80000000U, 32);
>> +}
>> +
>> +static void __init __constructor test_bitops(void)
>> +{
>> + test_ffs();
>> +}
>> diff --git a/xen/include/xen/bitops.h b/xen/include/xen/bitops.h
>> index cd405df96180..f7e90a2893a5 100644
>> --- a/xen/include/xen/bitops.h
>> +++ b/xen/include/xen/bitops.h
>> @@ -31,6 +31,23 @@ unsigned int __pure generic_flsl(unsigned long x);
>>
>> #include <asm/bitops.h>
>>
>> +/*
>> + * Find First/Last Set bit (all forms).
>> + *
>> + * Bits are labelled from 1. Returns 0 if given 0.
>> + */
>> +static always_inline __pure unsigned int ffs(unsigned int x)
>> +{
>> + if ( __builtin_constant_p(x) )
>> + return __builtin_ffs(x);
>> +
>> +#ifdef arch_ffs
>> + return arch_ffs(x);
>> +#else
>> + return generic_ffsl(x);
>> +#endif
>> +}
>> +
>> /* --------------------- Please tidy below here ---------------------
>> */
>>
>> #ifndef find_next_bit
>> --
>> 2.30.2
>>
--
Nicola Vetrini, BSc
Software Engineer, BUGSENG srl (https://bugseng.com)
next prev parent reply other threads:[~2024-05-31 6:56 UTC|newest]
Thread overview: 50+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-05-24 20:03 [PATCH v2 for-4.19 00/13] xen/bitops: Untangle ffs()/fls() infrastructure Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 01/13] ppc/boot: Run constructors on boot Andrew Cooper
2024-05-29 19:35 ` Shawn Anastasio
2024-05-24 20:03 ` [PATCH v2 02/13] xen/bitops: Cleanup ahead of rearrangements Andrew Cooper
2024-05-27 8:24 ` Jan Beulich
2024-05-31 22:41 ` Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 03/13] ARM/bitops: Change find_first_set_bit() to be a define Andrew Cooper
2024-05-31 0:57 ` Stefano Stabellini
2024-05-24 20:03 ` [PATCH v2 04/13] xen/page_alloc: Coerce min(flsl(), foo) expressions to being unsigned Andrew Cooper
2024-05-27 6:26 ` Jan Beulich
2024-05-29 19:07 ` Andrew Cooper
2024-05-29 19:19 ` Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 05/13] xen/bitops: Implement generic_f?sl() in lib/ Andrew Cooper
2024-05-27 8:44 ` Jan Beulich
2024-05-28 13:20 ` Andrew Cooper
2024-05-31 1:03 ` Stefano Stabellini
2024-05-24 20:03 ` [PATCH v2 06/13] xen/bitops: Implement ffs() in common logic Andrew Cooper
2024-05-27 12:33 ` Jan Beulich
2024-05-31 1:14 ` Stefano Stabellini
2024-05-31 6:56 ` Nicola Vetrini [this message]
2024-05-31 8:34 ` Andrew Cooper
2024-05-31 8:48 ` Andrew Cooper
2024-06-01 7:51 ` Nicola Vetrini
2024-05-24 20:03 ` [PATCH v2 07/13] x86/bitops: Improve arch_ffs() in the general case Andrew Cooper
2024-05-27 12:40 ` Jan Beulich
2024-05-27 13:27 ` Jan Beulich
2024-05-27 13:37 ` Jan Beulich
2024-05-28 12:30 ` Andrew Cooper
2024-05-28 13:12 ` Jan Beulich
2024-06-01 1:47 ` Andrew Cooper
2024-06-03 6:24 ` Jan Beulich
2024-05-24 20:03 ` [PATCH v2 08/13] xen/bitops: Implement ffsl() in common logic Andrew Cooper
2024-05-27 12:43 ` Jan Beulich
2024-05-31 1:15 ` Stefano Stabellini
2024-05-24 20:03 ` [PATCH v2 09/13] xen/bitops: Replace find_first_set_bit() with ffsl() - 1 Andrew Cooper
2024-05-27 12:57 ` Jan Beulich
2024-05-24 20:03 ` [PATCH v2 10/13] xen/bitops: Delete find_first_set_bit() Andrew Cooper
2024-05-27 12:58 ` Jan Beulich
2024-05-29 22:17 ` Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 11/13] xen/bitops: Implement fls()/flsl() in common logic Andrew Cooper
2024-05-27 13:38 ` Jan Beulich
2024-05-24 20:03 ` [PATCH v2 12/13] xen/bitops: Clean up ffs64()/fls64() definitions Andrew Cooper
2024-05-27 13:44 ` Jan Beulich
2024-06-01 12:57 ` Andrew Cooper
2024-05-24 20:03 ` [PATCH v2 13/13] xen/bitops: Rearrange the top of xen/bitops.h Andrew Cooper
2024-05-27 13:50 ` Jan Beulich
2024-05-27 13:51 ` [PATCH v2 for-4.19 00/13] xen/bitops: Untangle ffs()/fls() infrastructure Oleksii K.
2024-05-28 14:22 ` [PATCH v2 for-4.19 0.5/13] xen: Introduce CONFIG_SELF_TESTS Andrew Cooper
2024-05-29 7:13 ` Jan Beulich
2024-05-29 7:30 ` Oleksii K.
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7b974b36b89c216379b86170af9de451@bugseng.com \
--to=nicola.vetrini@bugseng.com \
--cc=JBeulich@suse.com \
--cc=Volodymyr_Babchuk@epam.com \
--cc=andrew.cooper3@citrix.com \
--cc=bertrand.marquis@arm.com \
--cc=consulting@bugseng.com \
--cc=federico.serafini@bugseng.com \
--cc=julien@xen.org \
--cc=michal.orzel@amd.com \
--cc=oleksii.kurochko@gmail.com \
--cc=roger.pau@citrix.com \
--cc=sanastasio@raptorengineering.com \
--cc=simone.ballarin@bugseng.com \
--cc=sstabellini@kernel.org \
--cc=wl@xen.org \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.