From: Sarika Sharma <quic_sarishar@quicinc.com>
To: Johannes Berg <johannes@sipsolutions.net>
Cc: <linux-wireless@vger.kernel.org>
Subject: Re: [PATCH RFC 2/7] wifi: cfg80211: reorg sinfo structure elements for MLO
Date: Wed, 15 Jan 2025 12:10:16 +0530 [thread overview]
Message-ID: <63dfda06-b83d-422a-af39-6af3c55dfbd9@quicinc.com> (raw)
In-Reply-To: <f8de2e7127b7a79e259bf14c62c4eb0ef25ddfb6.camel@sipsolutions.net>
On 1/14/2025 4:49 PM, Johannes Berg wrote:
> On Sun, 2025-01-12 at 13:40 +0530, Sarika Sharma wrote:
>> On 1/10/2025 2:49 PM, Johannes Berg wrote:
>>> On Fri, 2025-01-10 at 09:54 +0530, Sarika Sharma wrote:
>>>>
>>>> struct station_info {
>>>>
>>>> + struct link_station_info deflink;
>>>
>>> Having a deflink here seems kind of questionable?
>>
>> ohh! why so? In other structures like vif, sdata, sta, we did the same
>> way. So why can't we have the same way here as well?
>
> Well, (a) I tend to think in hindsight it was sort of a mistake, but (b)
> we couldn't really do it differently due to all drivers. But here you're
> already touching all the code anyway, and it's mostly cfg80211/mac80211,
> so why bother?
Sure, I will remove deflink and instead could use link pointer (link[0])
to fill statistics for non-ML stations.
>
>>> Why not pass multiple pointers?
>>
>> Sorry, I didn't get you.
>> Did you mean keep the sinfo structure and call this for filling all link
>> level, non-mL, ML information?
>
> I think I meant that we could have per link pointers passed to the
> method, but we might as well just have them in the sinfo struct as you
> introduce in later patches.
Sure, will introduce the link pointer here and use link[0] for non-ML
stations and corresponding link pointer for ML stations.
For drivers that offload link decisions and do not provide per-link
statistics, a flag could be used to indicate whether the per-link
statistics is filled from driver or not, if not can use link[0] to fill
the station information and if yes then can use the corresponding link
pointers to fill link level information.
>
>>>> - if (!(sinfo->filled & BIT_ULL(NL80211_STA_INFO_TX_BITRATE)) &&
>>>> + if (!(link_sinfo->filled & BIT_ULL(NL80211_STA_INFO_TX_BITRATE)) &&
>>>>
>>>
>>> A little less renaming would probably also make this easier to review.
>>
>> Sure, but this is corresponding to filling link level data, that's why
>> just renaming sinfo to link_sinfo.
>
> Yeah, but does it matter so much? :)
Not really, this is just done to differentiate the structures
used(station_info or link_station_info) and code readability purpose.
>
> I guess the flipside is that this way it's easier to review that all
> values fall into the right place, but I think the data structure
> organisation you did mostly ensures that anyway? Not sure though.
Yes from data structure organization it is taken care that it falls at
right place.
If it found to be difficult to review and required, I can rename to sinfo?
>
> johannes
next prev parent reply other threads:[~2025-01-15 6:40 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-10 4:24 [PATCH RFC 0/7] wifi: cfg80211/mac80211: add support to handle per link statistics of multi-link station Sarika Sharma
2025-01-10 4:24 ` [PATCH RFC 1/7] wifi: cfg80211: reorg sinfo structure elements for mesh Sarika Sharma
2025-01-10 9:15 ` Johannes Berg
2025-01-12 8:08 ` Sarika Sharma
2025-01-10 4:24 ` [PATCH RFC 2/7] wifi: cfg80211: reorg sinfo structure elements for MLO Sarika Sharma
2025-01-10 9:19 ` Johannes Berg
2025-01-12 8:10 ` Sarika Sharma
2025-01-14 11:19 ` Johannes Berg
2025-01-15 6:40 ` Sarika Sharma [this message]
2025-01-11 6:51 ` kernel test robot
2025-01-11 7:25 ` kernel test robot
2025-01-10 4:24 ` [PATCH RFC 3/7] wifi: cfg80211: extend statistics for link level in sinfo Sarika Sharma
2025-01-10 9:20 ` Johannes Berg
2025-01-12 8:10 ` Sarika Sharma
2025-01-10 9:21 ` Johannes Berg
2025-01-12 8:14 ` Sarika Sharma
2025-01-11 9:49 ` kernel test robot
2025-01-10 4:24 ` [PATCH RFC 4/7] wifi: cfg80211: add accumulated statistics for MLO links Sarika Sharma
2025-01-10 4:24 ` [PATCH RFC 5/7] wifi: mac80211: add support to accumulate removed link statistics Sarika Sharma
2025-01-10 9:22 ` Johannes Berg
2025-01-12 8:15 ` Sarika Sharma
2025-01-10 4:24 ` [PATCH RFC 6/7] wifi: cfg80211: add additional MLO statistics Sarika Sharma
2025-01-10 4:24 ` [PATCH RFC 7/7] wifi: ath12k: correctly fetch arsta for MLO Sarika Sharma
2025-01-10 9:45 ` [PATCH RFC 0/7] wifi: cfg80211/mac80211: add support to handle per link statistics of multi-link station Johannes Berg
2025-01-12 8:17 ` Sarika Sharma
2025-01-10 16:53 ` Ben Greear
2025-01-15 5:11 ` Sarika Sharma
2025-01-15 17:02 ` Ben Greear
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=63dfda06-b83d-422a-af39-6af3c55dfbd9@quicinc.com \
--to=quic_sarishar@quicinc.com \
--cc=johannes@sipsolutions.net \
--cc=linux-wireless@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.