From: Andrew Cooper <andrew.cooper3@citrix.com>
To: Jan Beulich <jbeulich@suse.com>
Cc: "Roger Pau Monné" <roger.pau@citrix.com>,
Xen-devel <xen-devel@lists.xenproject.org>
Subject: Re: [PATCH 2/7] x86/xstate: Cross-check dynamic XSTATE sizes at boot
Date: Fri, 14 Jun 2024 14:56:38 +0100 [thread overview]
Message-ID: <71cbc846-527d-45f0-bd0b-df3f0294e7cd@citrix.com> (raw)
In-Reply-To: <22e0473a-aca8-4645-a3f4-21a9d9e0ebd3@suse.com>
On 23/05/2024 4:34 pm, Jan Beulich wrote:
> On 23.05.2024 13:16, Andrew Cooper wrote:
>> Right now, xstate_ctxt_size() performs a cross-check of size with CPUID in for
>> every call. This is expensive, being used for domain create/migrate, as well
>> as to service certain guest CPUID instructions.
>>
>> Instead, arrange to check the sizes once at boot. See the code comments for
>> details. Right now, it just checks hardware against the algorithm
>> expectations. Later patches will add further cross-checking.
>>
>> Introduce the missing X86_XCR0_* and X86_XSS_* constants, and a couple of
>> missing CPUID bits. This is to maximise coverage in the sanity check, even if
>> we don't expect to use/virtualise some of these features any time soon. Leave
>> HDC and HWP alone for now. We don't have CPUID bits from them stored nicely.
> Since you say "the missing", ...
>
>> --- a/xen/arch/x86/include/asm/x86-defns.h
>> +++ b/xen/arch/x86/include/asm/x86-defns.h
>> @@ -77,7 +77,7 @@
>> #define X86_CR4_PKS 0x01000000 /* Protection Key Supervisor */
>>
>> /*
>> - * XSTATE component flags in XCR0
>> + * XSTATE component flags in XCR0 | MSR_XSS
>> */
>> #define X86_XCR0_FP_POS 0
>> #define X86_XCR0_FP (1ULL << X86_XCR0_FP_POS)
>> @@ -95,11 +95,34 @@
>> #define X86_XCR0_ZMM (1ULL << X86_XCR0_ZMM_POS)
>> #define X86_XCR0_HI_ZMM_POS 7
>> #define X86_XCR0_HI_ZMM (1ULL << X86_XCR0_HI_ZMM_POS)
>> +#define X86_XSS_PROC_TRACE (_AC(1, ULL) << 8)
>> #define X86_XCR0_PKRU_POS 9
>> #define X86_XCR0_PKRU (1ULL << X86_XCR0_PKRU_POS)
>> +#define X86_XSS_PASID (_AC(1, ULL) << 10)
>> +#define X86_XSS_CET_U (_AC(1, ULL) << 11)
>> +#define X86_XSS_CET_S (_AC(1, ULL) << 12)
>> +#define X86_XSS_HDC (_AC(1, ULL) << 13)
>> +#define X86_XSS_UINTR (_AC(1, ULL) << 14)
>> +#define X86_XSS_LBR (_AC(1, ULL) << 15)
>> +#define X86_XSS_HWP (_AC(1, ULL) << 16)
>> +#define X86_XCR0_TILE_CFG (_AC(1, ULL) << 17)
>> +#define X86_XCR0_TILE_DATA (_AC(1, ULL) << 18)
> ... I'm wondering if you deliberately left out APX (bit 19).
It was deliberate. APX isn't in the SDM yet, so in principle is still
subject to change.
I've tweaked the commit message to avoid using the word 'missing'.
> Since you're re-doing some of what I have long had in patches already,
> I'd also like to ask whether the last underscores each in the two AMX
> names really are useful in your opinion. While rebasing isn't going
> to be difficult either way, it would be yet simpler with
> X86_XCR0_TILECFG and X86_XCR0_TILEDATA, as I've had it in my patches
> for over 3 years.
I'm torn here. I don't want to deliberately make things harder for you,
but I would really prefer that we use the more legible form...
>> --- a/xen/arch/x86/xstate.c
>> +++ b/xen/arch/x86/xstate.c
>> @@ -604,9 +604,156 @@ static bool valid_xcr0(uint64_t xcr0)
>> if ( !(xcr0 & X86_XCR0_BNDREGS) != !(xcr0 & X86_XCR0_BNDCSR) )
>> return false;
>>
>> + /* TILE_CFG and TILE_DATA must be the same. */
>> + if ( !(xcr0 & X86_XCR0_TILE_CFG) != !(xcr0 & X86_XCR0_TILE_DATA) )
>> + return false;
>> +
>> return true;
>> }
>>
>> +struct xcheck_state {
>> + uint64_t states;
>> + uint32_t uncomp_size;
>> + uint32_t comp_size;
>> +};
>> +
>> +static void __init check_new_xstate(struct xcheck_state *s, uint64_t new)
>> +{
>> + uint32_t hw_size;
>> +
>> + BUILD_BUG_ON(X86_XCR0_STATES & X86_XSS_STATES);
>> +
>> + BUG_ON(s->states & new); /* States only increase. */
>> + BUG_ON(!valid_xcr0(s->states | new)); /* Xen thinks it's a good value. */
>> + BUG_ON(new & ~(X86_XCR0_STATES | X86_XSS_STATES)); /* Known state. */
>> + BUG_ON((new & X86_XCR0_STATES) &&
>> + (new & X86_XSS_STATES)); /* User or supervisor, not both. */
>> +
>> + s->states |= new;
>> + if ( new & X86_XCR0_STATES )
>> + {
>> + if ( !set_xcr0(s->states & X86_XCR0_STATES) )
>> + BUG();
>> + }
>> + else
>> + set_msr_xss(s->states & X86_XSS_STATES);
>> +
>> + /*
>> + * Check the uncompressed size. Some XSTATEs are out-of-order and fill in
>> + * prior holes in the state area, so we check that the size doesn't
>> + * decrease.
>> + */
>> + hw_size = cpuid_count_ebx(0xd, 0);
>> +
>> + if ( hw_size < s->uncomp_size )
>> + panic("XSTATE 0x%016"PRIx64", new bits {%63pbl}, uncompressed hw size %#x < prev size %#x\n",
>> + s->states, &new, hw_size, s->uncomp_size);
>> +
>> + s->uncomp_size = hw_size;
>> +
>> + /*
>> + * Check the compressed size, if available. All components strictly
>> + * appear in index order. In principle there are no holes, but some
>> + * components have their base address 64-byte aligned for efficiency
>> + * reasons (e.g. AMX-TILE) and there are other components small enough to
>> + * fit in the gap (e.g. PKRU) without increasing the overall length.
>> + */
>> + hw_size = cpuid_count_ebx(0xd, 1);
>> +
>> + if ( cpu_has_xsavec )
>> + {
>> + if ( hw_size < s->comp_size )
>> + panic("XSTATE 0x%016"PRIx64", new bits {%63pbl}, compressed hw size %#x < prev size %#x\n",
>> + s->states, &new, hw_size, s->comp_size);
>> +
>> + s->comp_size = hw_size;
>> + }
>> + else
>> + BUG_ON(hw_size); /* Compressed size reported, but no XSAVEC ? */
> I'm not quite happy with this being fatal to booting. Maybe just WARN_ON()?
It's going to trigger on every pass. I've reworked it to be an
opencoded WARN_ONCE() (as we don't have this construct yet), but it's
ended up as a plain WARN().
~Andrew
next prev parent reply other threads:[~2024-06-14 13:56 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-05-23 11:16 [PATCH for-4.19 v3 0/7] x86/xstate: Fixes to size calculations Andrew Cooper
2024-05-23 11:16 ` [PATCH 1/7] x86/xstate: Fix initialisation of XSS cache Andrew Cooper
2024-05-23 15:09 ` Jan Beulich
2024-05-23 11:16 ` [PATCH 2/7] x86/xstate: Cross-check dynamic XSTATE sizes at boot Andrew Cooper
2024-05-23 15:34 ` Jan Beulich
2024-06-14 13:56 ` Andrew Cooper [this message]
2024-06-17 10:08 ` Jan Beulich
2024-05-23 11:16 ` [PATCH 3/7] x86/boot: Collect the Raw CPU Policy earlier on boot Andrew Cooper
2024-05-23 15:44 ` Jan Beulich
2024-06-14 18:26 ` Andrew Cooper
2024-06-17 10:25 ` Jan Beulich
2024-06-17 17:30 ` Andrew Cooper
2024-06-18 7:04 ` Jan Beulich
2024-05-23 11:16 ` [PATCH 4/7] x86/xstate: Rework xstate_ctxt_size() as xstate_uncompressed_size() Andrew Cooper
2024-05-23 16:09 ` Jan Beulich
2024-06-14 13:56 ` Andrew Cooper
2024-05-23 11:16 ` [PATCH 5/7] x86/cpu-policy: Simplify recalculate_xstate() Andrew Cooper
2024-05-23 11:16 ` [PATCH 6/7] x86/cpuid: Fix handling of XSAVE dynamic leaves Andrew Cooper
2024-05-23 16:16 ` Jan Beulich
2024-06-14 14:06 ` Andrew Cooper
2024-05-23 11:16 ` [PATCH 7/7] x86/defns: Clean up X86_{XCR0,XSS}_* constants Andrew Cooper
2024-05-23 15:46 ` Jan Beulich
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=71cbc846-527d-45f0-bd0b-df3f0294e7cd@citrix.com \
--to=andrew.cooper3@citrix.com \
--cc=jbeulich@suse.com \
--cc=roger.pau@citrix.com \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.