All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kaartic Sivaraam <kaartic.sivaraam@gmail.com>
To: Patrick Steinhardt <ps@pks.im>, Junio C Hamano <gitster@pobox.com>
Cc: "Phillip Wood" <phillip.wood123@gmail.com>,
	"SZEDER Gábor" <szeder.dev@gmail.com>,
	git@vger.kernel.org,
	"brian m. carlson" <sandals@crustytoothpaste.net>,
	"Elijah Newren" <newren@gmail.com>,
	"Derrick Stolee" <stolee@gmail.com>,
	"Phillip Wood" <phillip.wood@dunelm.org.uk>
Subject: Re: [PATCH RFC v2 2/2] Move libgit.a sources into separate "lib/" directory
Date: Mon, 6 Jul 2026 09:59:18 +0530	[thread overview]
Message-ID: <7d00e3e0-27f7-4d54-8985-ba7b670efcfb@gmail.com> (raw)
In-Reply-To: <akX1TMoRr87Id8Ss@pks.im>

On 02/07/26 10:51, Patrick Steinhardt wrote:
> On Wed, Jul 01, 2026 at 07:45:09AM -0700, Junio C Hamano wrote:
>> Phillip Wood <phillip.wood123@gmail.com> writes:
>> 
>>> Another cost is remembering things have moved - the other day I spent
>>> too long wondering why "git show origin/seen:wt-status.c" wasn't working
>>> until I ran "git log origin/seen" and realized it had move to
>>> lib/wt-status.c.
>>
>> Yes, this has bit me multiple dozen times, as the tip of 'seen' is
>> contaminated with this rename, already.  It is a huge pain.
> 
> Yeah, this one I don't have any arguments against besides a very
> hand-wavy "it'll get better over time" :)
>

On a bit of a tangent, this made me wonder if it would be helpful to 
make a potential improvement to 'git show' UX that shows a hint that the 
file asked to be shown was moved as part of a recent rename.

Something like:

   $ git show origin/seen:wt-status.c
   fatal: path 'wt-status.c' does not exist in 'origin/seen'
   hint: 'wt-status.c' appears to have been renamed to 
'builtin/wt-status.c' in 'origin/seen'
   hint: Did you mean 'origin/seen:builtin/wt-status.c'?
   hint: Disable this message with "git config advice.objectNameWarning 
false"

Finding rename just to show a hint sounds a bit too much work for a 
hint. I wonder if it would worth given the better UX, though.

--
Sivaraam


  reply	other threads:[~2026-07-06  4:29 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-04-16 13:24 [PATCH RFC 0/2] Move libgit.a sources into separate "lib/" directory Patrick Steinhardt
2026-04-16 13:24 ` [PATCH RFC 1/2] t/helper: prepare "test-example-tap.c" for introduction of "lib/" Patrick Steinhardt
2026-04-16 13:24 ` [PATCH RFC 2/2] Move libgit.a sources into separate "lib/" directory Patrick Steinhardt
2026-04-17 17:08   ` Elijah Newren
2026-04-17 19:18   ` brian m. carlson
2026-04-17 21:18     ` Junio C Hamano
2026-04-17 21:51       ` brian m. carlson
2026-04-20  6:41         ` Patrick Steinhardt
2026-04-19 14:11 ` [PATCH RFC 0/2] " Phillip Wood
2026-04-20  6:41   ` Patrick Steinhardt
2026-04-20 12:03 ` Derrick Stolee
2026-04-21  5:55   ` Patrick Steinhardt
2026-04-21 14:13     ` Derrick Stolee
2026-04-22  6:39       ` Patrick Steinhardt
2026-06-22 10:38 ` [PATCH RFC v2 " Patrick Steinhardt
2026-06-22 10:38   ` [PATCH RFC v2 1/2] t/helper: prepare "test-example-tap.c" for introduction of "lib/" Patrick Steinhardt
2026-06-22 10:38   ` [PATCH RFC v2 2/2] Move libgit.a sources into separate "lib/" directory Patrick Steinhardt
2026-06-22 13:08     ` Junio C Hamano
2026-06-24 10:32       ` Patrick Steinhardt
2026-06-24 11:23       ` Oswald Buddenhagen
2026-06-26 16:01     ` Johannes Schindelin
2026-06-26 18:50       ` Junio C Hamano
2026-07-01  6:54       ` Patrick Steinhardt
2026-06-27  6:40     ` SZEDER Gábor
2026-07-01  6:55       ` Patrick Steinhardt
2026-07-01 13:26         ` Phillip Wood
2026-07-01 14:45           ` Junio C Hamano
2026-07-02  5:21             ` Patrick Steinhardt
2026-07-06  4:29               ` Kaartic Sivaraam [this message]
2026-07-01  6:59 ` [PATCH RFC v3 0/2] " Patrick Steinhardt
2026-07-01  6:59   ` [PATCH RFC v3 1/2] t/helper: prepare "test-example-tap.c" for introduction of "lib/" Patrick Steinhardt
2026-07-01  6:59   ` [PATCH RFC v3 2/2] Move libgit.a sources into separate "lib/" directory Patrick Steinhardt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7d00e3e0-27f7-4d54-8985-ba7b670efcfb@gmail.com \
    --to=kaartic.sivaraam@gmail.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=newren@gmail.com \
    --cc=phillip.wood123@gmail.com \
    --cc=phillip.wood@dunelm.org.uk \
    --cc=ps@pks.im \
    --cc=sandals@crustytoothpaste.net \
    --cc=stolee@gmail.com \
    --cc=szeder.dev@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.