From: Junio C Hamano <gitster@pobox.com>
To: Tay Ray Chuan <rctay89@gmail.com>
Cc: Git Mailing List <git@vger.kernel.org>,
Johannes Schindelin <Johannes.Schindelin@gmx.de>,
Mike Hommey <mh@glandium.org>
Subject: Re: [PATCH 00/23] http*: refactor (v6)
Date: Sat, 06 Jun 2009 11:04:35 -0700 [thread overview]
Message-ID: <7v8wk5dyrw.fsf@alter.siamese.dyndns.org> (raw)
In-Reply-To: <20090606164253.65a945ba.rctay89@gmail.com> (Tay Ray Chuan's message of "Sat\, 6 Jun 2009 16\:42\:53 +0800")
Tay Ray Chuan <rctay89@gmail.com> writes:
> Junio, this replaces the entire 'rc/http-push' topic.
>
> Changes from the previous patch series:
>
> - add a list of functions added (patch #15)
>
> - use back the die()'s like in the original (patch #16)
Thanks, will queue, but please double check the result after I push it
out, as I found some other changes not listed above, relative to what was
queued in 'pu' (I am not complaining; I am asking your extra set of
eyeballs in case I somehow screwed up applying your series to my tree).
- return value of fetch_indices() is 0 when http_get_info_packs() returns
HTTP_MISSING_TARGET (both in http-push.c and http-walker.c);
- break the function definition of run_request_queue() by removing "void"
from the parameter list ("send out fetch requests on queue" -- no need
to resend, I fixed it up again while applying);
- update the error checking in transport.c:get_refs_via_curl() to make it
look more similar to what are in fetch_indices() in both http-push.c and
http-walker.c.
- add unused "cleanup:" label to get_refs_via_curl() in transport.c
(again no need to resend, I fixed it up while applying);
- add back a few missing "->local = NULL" I screwed up while applying the
previous series.
By the way, this is not your fault at all, but for a patch series
description, "shortlog" is a sucky way, as we can see below. When you
talk about "patch #15", the reader cannot find which one you are talking
about but has to go back to the MUA, so the list is useless for that
purpose.
The output of "shortlog" in an e-mail message is wonderful when you are a
subsystem maintainer who bundles many people's work and are sending out a
pull request (i.e. you are transferring the whole graph in "take it or
reject all" fashion, and you can refer to an individual changeset with its
commit object name).
But I think a cover letter to a patch series should serve as an easy index
from patch number to the title in some way, and "shortlog" is not suitable
for that eapecially for a multi-author series.
> Christian Couder (1):
> http-push: fix missing "#ifdef USE_CURL_MULTI" around
> "is_running_queue"
>
> Mike Hommey (7):
> Don't expect verify_pack() callers to set pack_size
> transport.c::get_refs_via_curl(): do not leak refs_url
> http.c: new functions for the http API
> transport.c::get_refs_via_curl(): use the new http API
> http.c::http_fetch_ref(): use the new http API
> http-push.c::remote_exists(): use the new http API
> http-push.c::fetch_symref(): use the new http API
>
> Tay Ray Chuan (15):
> t5540-http-push: test fetching of loose objects
> t5540-http-push: test fetching of packed objects
> http*: cleanup slot->local after fclose
> http-push: send out fetch requests on queue
> t5550-http-fetch: test fetching of packed objects
> http-push, http-walker: style fixes
> http-walker: verify remote packs
> http*: copy string returned by sha1_to_hex
> http-push: do not SEGV after fetching a bad pack idx file
> http*: move common variables and macros to http.[ch]
> http: create function end_url_with_slash
> http*: add http_get_info_packs
> http: use new http API in fetch_index()
> http*: add helper methods for fetching packs
> http*: add helper methods for fetching objects (loose)
> http-push.c | 579 ++++++++---------------------------------------
> http-walker.c | 533 +++++++------------------------------------
> http.c | 601 +++++++++++++++++++++++++++++++++++++++++++++++--
> http.h | 85 +++++++
> pack-check.c | 8 +-
> t/t5540-http-push.sh | 36 +++
> t/t5550-http-fetch.sh | 8 +
> transport.c | 36 ++--
> 8 files changed, 905 insertions(+), 981 deletions(-)
next prev parent reply other threads:[~2009-06-06 18:05 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-06-06 8:42 [PATCH 00/23] http*: refactor (v6) Tay Ray Chuan
2009-06-06 18:04 ` Junio C Hamano [this message]
2009-06-06 18:23 ` Jakub Narebski
2009-06-07 0:45 ` Tay Ray Chuan
2009-06-07 0:41 ` Tay Ray Chuan
2009-06-10 10:36 ` Tay Ray Chuan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7v8wk5dyrw.fsf@alter.siamese.dyndns.org \
--to=gitster@pobox.com \
--cc=Johannes.Schindelin@gmx.de \
--cc=git@vger.kernel.org \
--cc=mh@glandium.org \
--cc=rctay89@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.