From: Tay Ray Chuan <rctay89@gmail.com>
To: Junio C Hamano <gitster@pobox.com>
Cc: Git Mailing List <git@vger.kernel.org>,
Johannes Schindelin <Johannes.Schindelin@gmx.de>,
Mike Hommey <mh@glandium.org>
Subject: Re: [PATCH 00/23] http*: refactor (v6)
Date: Sun, 7 Jun 2009 08:41:59 +0800 [thread overview]
Message-ID: <be6fef0d0906061741p6f3864a9m25d25e23ef0db760@mail.gmail.com> (raw)
In-Reply-To: <7v8wk5dyrw.fsf@alter.siamese.dyndns.org>
Hi,
On Sun, Jun 7, 2009 at 2:04 AM, Junio C Hamano<gitster@pobox.com> wrote:
> Thanks, will queue, but please double check the result after I push it
> out, as I found some other changes not listed above, relative to what was
> queued in 'pu' (I am not complaining; I am asking your extra set of
> eyeballs in case I somehow screwed up applying your series to my tree).
>
> - return value of fetch_indices() is 0 when http_get_info_packs() returns
> HTTP_MISSING_TARGET (both in http-push.c and http-walker.c);
This is correct. I had noted this in the patch; perhaps I should have
included it in the cover letter.
> - break the function definition of run_request_queue() by removing "void"
> from the parameter list ("send out fetch requests on queue" -- no need
> to resend, I fixed it up again while applying);
My bad. I hadn't noticed that you've already been doing this.
> - update the error checking in transport.c:get_refs_via_curl() to make it
> look more similar to what are in fetch_indices() in both http-push.c and
> http-walker.c.
Yes. I noted this in the patch text.
> - add unused "cleanup:" label to get_refs_via_curl() in transport.c
> (again no need to resend, I fixed it up while applying);
Indeed. It was an uncaught consequence of the previous change.
> - add back a few missing "->local = NULL" I screwed up while applying the
> previous series.
I'll have to take a look at those.
> By the way, this is not your fault at all, but for a patch series
> description, "shortlog" is a sucky way, as we can see below. When you
> talk about "patch #15", the reader cannot find which one you are talking
> about but has to go back to the MUA, so the list is useless for that
> purpose.
Is there a way to do this with git-format-patch? ("this" being a list
of numbered patches, instead of them being grouped by author)
--
Cheers,
Ray Chuan
next prev parent reply other threads:[~2009-06-07 0:46 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-06-06 8:42 [PATCH 00/23] http*: refactor (v6) Tay Ray Chuan
2009-06-06 18:04 ` Junio C Hamano
2009-06-06 18:23 ` Jakub Narebski
2009-06-07 0:45 ` Tay Ray Chuan
2009-06-07 0:41 ` Tay Ray Chuan [this message]
2009-06-10 10:36 ` Tay Ray Chuan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=be6fef0d0906061741p6f3864a9m25d25e23ef0db760@mail.gmail.com \
--to=rctay89@gmail.com \
--cc=Johannes.Schindelin@gmx.de \
--cc=git@vger.kernel.org \
--cc=gitster@pobox.com \
--cc=mh@glandium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.