All of lore.kernel.org
 help / color / mirror / Atom feed
From: Junio C Hamano <gitster@pobox.com>
To: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Johannes Schindelin <Johannes.Schindelin@gmx.de>,
	Johannes Sixt <j6t@kdbg.org>,
	git@vger.kernel.org
Subject: Re: [PATCH v3] Add an option not to use link(src, dest) && unlink(src) when that is unreliable
Date: Mon, 27 Apr 2009 15:10:09 -0700	[thread overview]
Message-ID: <7vvdopwxxa.fsf@gitster.siamese.dyndns.org> (raw)
In-Reply-To: <alpine.LFD.2.00.0904271314130.22156@localhost.localdomain> (Linus Torvalds's message of "Mon, 27 Apr 2009 13:18:19 -0700 (PDT)")

Linus Torvalds <torvalds@linux-foundation.org> writes:

> Maybe the config option shouldn't be a boolean, but a "how to instantiate 
> objects". IOW, we could do
>
> 	[core]
> 		createobject = {link|rename}
>
> instead. Maybe we some day could allow "inplace", for some totally broken 
> system that supports neither renames nor links, and just wants the object 
> to be created with the final name to start with.
>
> (Ok, that sounds unlikely, but I mention it because it's an example of the 
> concept. Maybe somebody likes crazy databases, and would like to have a 
> "createobject = mysql" for some DB-backed loose object crap).
>
> 		Linus

More likely is "bigtable", I guess ;-)

  reply	other threads:[~2009-04-27 22:10 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-04-23 10:53 [PATCH] Add an option not to use link(src, dest) && unlink(src) when that is unreliable Johannes Schindelin
2009-04-23 19:16 ` Johannes Sixt
2009-04-23 19:33   ` Johannes Schindelin
2009-04-25  9:57   ` [PATCH v2] " Johannes Schindelin
2009-04-25 16:49     ` Junio C Hamano
2009-04-25 17:40       ` Linus Torvalds
2009-04-25 18:38         ` Michael Gaber
2009-04-25 18:43           ` Linus Torvalds
2009-04-27  3:37           ` Jay Soffian
2009-04-25 18:50       ` Johannes Sixt
2009-04-25 17:05     ` Junio C Hamano
2009-04-26 17:39       ` Johannes Schindelin
2009-04-25 17:39     ` Linus Torvalds
2009-04-23 19:39 ` [PATCH] " Alex Riesen
2009-04-23 21:59   ` Johannes Schindelin
2009-04-24  5:44     ` Alex Riesen
2009-04-25 17:56 ` Linus Torvalds
2009-04-25 18:52   ` Johannes Sixt
2009-04-26  1:17     ` Junio C Hamano
2009-04-26 17:40       ` Johannes Schindelin
2009-04-27 12:00         ` [PATCH v3] " Johannes Schindelin
2009-04-27 15:15           ` Linus Torvalds
2009-04-27 16:11             ` Johannes Schindelin
2009-04-27 16:53               ` Linus Torvalds
2009-04-27 19:55             ` Junio C Hamano
2009-04-27 20:13               ` Linus Torvalds
2009-04-27 20:18               ` Linus Torvalds
2009-04-27 22:10                 ` Junio C Hamano [this message]
2009-04-27 22:28                   ` Johannes Schindelin
2009-04-27 23:06                     ` Linus Torvalds
2009-04-27 22:32                 ` [PATCH] Rename core.unreliableHardlinks to core.createObject Johannes Schindelin
2009-04-27 23:48                   ` Junio C Hamano
2009-04-28  8:23                     ` Johannes Schindelin
2009-04-28  8:44                       ` Junio C Hamano
2009-04-28 14:50                         ` Johannes Schindelin
2009-04-28 20:59                           ` Junio C Hamano
2009-04-28 22:07                             ` Johannes Schindelin
2009-04-26 17:38   ` [PATCH] Add an option not to use link(src, dest) && unlink(src) when that is unreliable Johannes Schindelin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7vvdopwxxa.fsf@gitster.siamese.dyndns.org \
    --to=gitster@pobox.com \
    --cc=Johannes.Schindelin@gmx.de \
    --cc=git@vger.kernel.org \
    --cc=j6t@kdbg.org \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.