From: Junio C Hamano <gitster@pobox.com>
To: Johannes Schindelin <Johannes.Schindelin@gmx.de>
Cc: Linus Torvalds <torvalds@linux-foundation.org>,
Johannes Sixt <j6t@kdbg.org>,
git@vger.kernel.org
Subject: Re: [PATCH] Rename core.unreliableHardlinks to core.createObject
Date: Mon, 27 Apr 2009 16:48:13 -0700 [thread overview]
Message-ID: <7vws95vete.fsf@gitster.siamese.dyndns.org> (raw)
In-Reply-To: <alpine.DEB.1.00.0904280031100.10279@pacific.mpi-cbg.de> (Johannes Schindelin's message of "Tue, 28 Apr 2009 00:32:25 +0200 (CEST)")
Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
> diff --git a/Makefile b/Makefile
> index 5c8e83a..9ca1826 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -172,8 +172,8 @@ all::
> # information on a not yet closed file that lstat would return for the same
> # file after it was closed.
> #
> -# Define UNRELIABLE_HARDLINKS if your operating systems has problems when
> -# hardlinking a file to another name and unlinking the original file right
> +# Define OBJECT_CREATION_USES_RENAMES if your operating systems has problems
> +# when hardlinking a file to another name and unlinking the original file right
With the configuration variable for this relatively obscure feature in
place, I wonder if we can simply get rid of the hardcoded compilation
preference. After all, even on your eeepc, I presume that you have some
filesystems in native format where you do not have the breakages, and some
others mounted with unfsd breakage. When diagnosing a possible issue on
somebody else's box, having to look into .git/config to see which codepath
is used is bad enough, but it is even worse to have a default that can be
different with compilation switch.
It would essentially boil down to this hunk; instead of introducing
OBJECT_CREATION_MODE, we default to hardlinks, and let the configuration
override it (and do nothing else).
> diff --git a/environment.c b/environment.c
> index 10578d2..801a005 100644
> --- a/environment.c
> +++ b/environment.c
> @@ -43,10 +43,10 @@ unsigned whitespace_rule_cfg = WS_DEFAULT_RULE;
> enum branch_track git_branch_track = BRANCH_TRACK_REMOTE;
> enum rebase_setup_type autorebase = AUTOREBASE_NEVER;
> enum push_default_type push_default = PUSH_DEFAULT_UNSPECIFIED;
> -#ifndef UNRELIABLE_HARDLINKS
> -#define UNRELIABLE_HARDLINKS 0
> +#ifndef OBJECT_CREATION_MODE
> +#define OBJECT_CREATION_MODE OBJECT_CREATION_USES_HARDLINKS
> #endif
> -int unreliable_hardlinks = UNRELIABLE_HARDLINKS;
> +enum object_creation_mode object_creation_mode = OBJECT_CREATION_MODE;
next prev parent reply other threads:[~2009-04-27 23:48 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-04-23 10:53 [PATCH] Add an option not to use link(src, dest) && unlink(src) when that is unreliable Johannes Schindelin
2009-04-23 19:16 ` Johannes Sixt
2009-04-23 19:33 ` Johannes Schindelin
2009-04-25 9:57 ` [PATCH v2] " Johannes Schindelin
2009-04-25 16:49 ` Junio C Hamano
2009-04-25 17:40 ` Linus Torvalds
2009-04-25 18:38 ` Michael Gaber
2009-04-25 18:43 ` Linus Torvalds
2009-04-27 3:37 ` Jay Soffian
2009-04-25 18:50 ` Johannes Sixt
2009-04-25 17:05 ` Junio C Hamano
2009-04-26 17:39 ` Johannes Schindelin
2009-04-25 17:39 ` Linus Torvalds
2009-04-23 19:39 ` [PATCH] " Alex Riesen
2009-04-23 21:59 ` Johannes Schindelin
2009-04-24 5:44 ` Alex Riesen
2009-04-25 17:56 ` Linus Torvalds
2009-04-25 18:52 ` Johannes Sixt
2009-04-26 1:17 ` Junio C Hamano
2009-04-26 17:40 ` Johannes Schindelin
2009-04-27 12:00 ` [PATCH v3] " Johannes Schindelin
2009-04-27 15:15 ` Linus Torvalds
2009-04-27 16:11 ` Johannes Schindelin
2009-04-27 16:53 ` Linus Torvalds
2009-04-27 19:55 ` Junio C Hamano
2009-04-27 20:13 ` Linus Torvalds
2009-04-27 20:18 ` Linus Torvalds
2009-04-27 22:10 ` Junio C Hamano
2009-04-27 22:28 ` Johannes Schindelin
2009-04-27 23:06 ` Linus Torvalds
2009-04-27 22:32 ` [PATCH] Rename core.unreliableHardlinks to core.createObject Johannes Schindelin
2009-04-27 23:48 ` Junio C Hamano [this message]
2009-04-28 8:23 ` Johannes Schindelin
2009-04-28 8:44 ` Junio C Hamano
2009-04-28 14:50 ` Johannes Schindelin
2009-04-28 20:59 ` Junio C Hamano
2009-04-28 22:07 ` Johannes Schindelin
2009-04-26 17:38 ` [PATCH] Add an option not to use link(src, dest) && unlink(src) when that is unreliable Johannes Schindelin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7vws95vete.fsf@gitster.siamese.dyndns.org \
--to=gitster@pobox.com \
--cc=Johannes.Schindelin@gmx.de \
--cc=git@vger.kernel.org \
--cc=j6t@kdbg.org \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.