All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sarthak Sharma <sarthak.sharma@arm.com>
To: SeongJae Park <sj@kernel.org>, pratmal@google.com
Cc: akpm@linux-foundation.org, shuah@kernel.org, yosry@kernel.org,
	david@kernel.org, ljs@kernel.org, Liam.Howlett@oracle.com,
	vbabka@kernel.org, rppt@kernel.org, surenb@google.com,
	mhocko@suse.com, linux-mm@kvack.org,
	linux-kselftest@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 0/2] selftests/mm: use pattern matching in .gitignore
Date: Fri, 31 Jul 2026 14:44:46 +0530	[thread overview]
Message-ID: <8356ad87-9c1e-4068-b5ee-86e8bb669c3b@arm.com> (raw)
In-Reply-To: <20260512010148.1175-1-sj@kernel.org>

Hi Pratyush and SeongJae!

On 5/12/26 6:31 AM, SeongJae Park wrote:
> On Mon, 11 May 2026 17:34:09 +0000 pratmal@google.com wrote:
> 
>> From: Pratyush Mallick <pratmal@google.com>
>>
>> The current selftests/mm/.gitignore hardcodes each generated test binary
>> by name, which requires manual updates every time a new test is added.
>>
>> This series switches to a pattern-matching approach (similar to KVM
>> selftests), ignoring everything by default and allowing specific source
>> extensions. To accommodate this without tracking generated headers,
>> local_config.h is renamed to local_config.h_gen.
>>
>> Changelog since v2:
>> - Split the changes into two separate patches (header rename and
>>   .gitignore update)
>> - Added Suggested-by for David Hildenbrand for the header rename approach.
>> - Dropped David's and Yosry's Reviewed-by tags.
>> - Kept Lorenzo Stoakes's Reviewed-by and added Mike Rapoport's Acked-by.
>>
>> Changelog since v1 (RFC):
>> - Renamed local_config.h to local_config.h_gen to avoid conflict with !*.h.
>> - Updated Makefile, check_config.sh, and affected .c files for the rename.
>> - Removed *.mod.c as it was unnecessary.
> 
> Adding previous revision links together [1] would be helpful for people who
> willing to see details of previous discussions.
> 
>>
>> Pratyush Mallick (2):
>>   selftests/mm: use pattern matching in .gitignore
>>   selftests/mm: rename local_config.h to local_config.h_gen
> 
> So, after applying the first patch, we may show local_config.h unexpectedly
> shown on 'git status' output?  Maybe too trivial thing, but I'm wondering if we
> already considered doing the renaming first.

Just a gentle ping on this patchset, since it has been some time since
the last discussion :).

Would it make sense to reorder the patches as SeongJae suggested and
respin? Pratyush, if you don't have time to send a v4, I would be happy
to prepare and send it. Please let me know if you'd like me to.

> 
> [1] https://docs.kernel.org/process/submitting-patches.html#commentary
> 
> 
> Thanks,
> SJ
> 
> [...]
> 

Thanks,
Sarthak


  reply	other threads:[~2026-07-31  9:16 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-11 17:34 [PATCH v3 0/2] selftests/mm: use pattern matching in .gitignore pratmal
2026-05-11 17:34 ` [PATCH v3 1/2] " pratmal
2026-05-11 17:34 ` [PATCH v3 2/2] selftests/mm: rename local_config.h to local_config.h_gen pratmal
2026-05-12  1:01 ` [PATCH v3 0/2] selftests/mm: use pattern matching in .gitignore SeongJae Park
2026-07-31  9:14   ` Sarthak Sharma [this message]
2026-08-01 22:34     ` Pratyush Mallick

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8356ad87-9c1e-4068-b5ee-86e8bb669c3b@arm.com \
    --to=sarthak.sharma@arm.com \
    --cc=Liam.Howlett@oracle.com \
    --cc=akpm@linux-foundation.org \
    --cc=david@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=pratmal@google.com \
    --cc=rppt@kernel.org \
    --cc=shuah@kernel.org \
    --cc=sj@kernel.org \
    --cc=surenb@google.com \
    --cc=vbabka@kernel.org \
    --cc=yosry@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.