All of lore.kernel.org
 help / color / mirror / Atom feed
From: Chuan Liu <chuan.liu@amlogic.com>
To: sashiko-reviews@lists.linux.dev
Cc: devicetree@vger.kernel.org, neil.armstrong@linaro.org,
	conor+dt@kernel.org, robh@kernel.org,
	linux-amlogic@lists.infradead.org
Subject: Re: [PATCH 03/10] soc: amlogic: clk-measure: Add support for more SoCs
Date: Mon, 14 Sep 2026 11:00:13 +0800	[thread overview]
Message-ID: <86ae1163-1507-4b4f-8d21-87fd2492a833@amlogic.com> (raw)
In-Reply-To: <20260911083742.9C6621F000FF@smtp.kernel.org>



On 9/11/2026 4:37 PM, sashiko-bot@kernel.org wrote:
> [你通常不会收到来自 sashiko-bot@kernel.org 的电子邮件。请访问 https://aka.ms/LearnAboutSenderIdentification,以了解这一点为什么很重要]
> 
> [ EXTERNAL EMAIL ]
> 
> Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
> - [Low] The `clk_msr_a9` array is missing the `const` qualifier, causing it to be placed in the modifiable `.data` section instead of the read-only `.rodata` section.
> - [Low] Possible typo in the clock name "exit_Tsin_B_CLK_IN" for ID 26 in the `clk_msr_a9` array.
> --
> 
> commit f03ec42ca0d7092f88d23ba06d4bfb38fc33ede1
> Author: Chuan Liu <chuan.liu@amlogic.com>
> 
> soc: amlogic: clk-measure: Add support for more SoCs
> 
> This commit adds clk-measure driver support for several Amlogic SoCs
> including A5, A4, S7, S7D, S6, and A9.
> 
>> diff --git a/drivers/soc/amlogic/meson-clk-measure.c b/drivers/soc/amlogic/meson-clk-measure.c
>> index 0d4ba2555d175..671e0c3753dec 100644
>> --- a/drivers/soc/amlogic/meson-clk-measure.c
>> +++ b/drivers/soc/amlogic/meson-clk-measure.c
> [ ... ]
>> @@ -1041,6 +1041,843 @@ static const struct meson_msr_id clk_msr_t7[] = {
> [ ... ]
>> +static struct meson_msr_id clk_msr_a9[] = {
> 
> [Severity: Low]
> Is the missing const qualifier here intentional? Without const, this array is
> placed in the modifiable data section instead of the read-only rodata section,
> increasing the mutable memory footprint.
> 
> Other clock ID tables introduced in this patch, such as clk_msr_a5 and
> clk_msr_s7, are properly defined as static const struct meson_msr_id. Because
> the driver only copies the elements from these arrays during device probe,
> the original template array does not need to be mutable.
> 

I'll add "const" in V2.

>> +     CLK_MSR_ID(0,  "sys_clk"),
>> +     CLK_MSR_ID(1,  "axi_clk"),
> [ ... ]
>> +     CLK_MSR_ID(24, "ddr_dpll_pt_clk"),
>> +     CLK_MSR_ID(25, "mod_Tsin_A_CLK_IN"),
>> +     CLK_MSR_ID(26, "exit_Tsin_B_CLK_IN"),
> 
> [Severity: Low]
> Does this string contain a typo? The name "exit_Tsin_B_CLK_IN" is exported to
> userspace via debugfs.
> 
> In similar SoC definitions like clk_msr_s6, the corresponding ID 26 is named
> "ext_Tsin_B_CLK_IN", likely standing for external. Using "exit" here instead
> of "ext" could confuse users or break userspace scripts expecting consistent
> naming across SoCs.
> 

and rename "exit_Tsin_B_CLK_IN" to "ext_Tsin_B_CLK_IN".

>> +     CLK_MSR_ID(27, "u3p2pll1_0_clk_div16"),
> [ ... ]
> 
> --
> Sashiko AI review · https://sashiko.dev/#/patchset/20260911-more-socs-to-support-clk_measure-v1-0-940e269aa52f@amlogic.com?part=3

-- 
Best regards,
Chuan


WARNING: multiple messages have this Message-ID (diff)
From: Chuan Liu <chuan.liu@amlogic.com>
To: sashiko-reviews@lists.linux.dev
Cc: devicetree@vger.kernel.org, neil.armstrong@linaro.org,
	conor+dt@kernel.org, robh@kernel.org,
	linux-amlogic@lists.infradead.org
Subject: Re: [PATCH 03/10] soc: amlogic: clk-measure: Add support for more SoCs
Date: Mon, 14 Sep 2026 11:00:13 +0800	[thread overview]
Message-ID: <86ae1163-1507-4b4f-8d21-87fd2492a833@amlogic.com> (raw)
In-Reply-To: <20260911083742.9C6621F000FF@smtp.kernel.org>



On 9/11/2026 4:37 PM, sashiko-bot@kernel.org wrote:
> [你通常不会收到来自 sashiko-bot@kernel.org 的电子邮件。请访问 https://aka.ms/LearnAboutSenderIdentification,以了解这一点为什么很重要]
> 
> [ EXTERNAL EMAIL ]
> 
> Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
> - [Low] The `clk_msr_a9` array is missing the `const` qualifier, causing it to be placed in the modifiable `.data` section instead of the read-only `.rodata` section.
> - [Low] Possible typo in the clock name "exit_Tsin_B_CLK_IN" for ID 26 in the `clk_msr_a9` array.
> --
> 
> commit f03ec42ca0d7092f88d23ba06d4bfb38fc33ede1
> Author: Chuan Liu <chuan.liu@amlogic.com>
> 
> soc: amlogic: clk-measure: Add support for more SoCs
> 
> This commit adds clk-measure driver support for several Amlogic SoCs
> including A5, A4, S7, S7D, S6, and A9.
> 
>> diff --git a/drivers/soc/amlogic/meson-clk-measure.c b/drivers/soc/amlogic/meson-clk-measure.c
>> index 0d4ba2555d175..671e0c3753dec 100644
>> --- a/drivers/soc/amlogic/meson-clk-measure.c
>> +++ b/drivers/soc/amlogic/meson-clk-measure.c
> [ ... ]
>> @@ -1041,6 +1041,843 @@ static const struct meson_msr_id clk_msr_t7[] = {
> [ ... ]
>> +static struct meson_msr_id clk_msr_a9[] = {
> 
> [Severity: Low]
> Is the missing const qualifier here intentional? Without const, this array is
> placed in the modifiable data section instead of the read-only rodata section,
> increasing the mutable memory footprint.
> 
> Other clock ID tables introduced in this patch, such as clk_msr_a5 and
> clk_msr_s7, are properly defined as static const struct meson_msr_id. Because
> the driver only copies the elements from these arrays during device probe,
> the original template array does not need to be mutable.
> 

I'll add "const" in V2.

>> +     CLK_MSR_ID(0,  "sys_clk"),
>> +     CLK_MSR_ID(1,  "axi_clk"),
> [ ... ]
>> +     CLK_MSR_ID(24, "ddr_dpll_pt_clk"),
>> +     CLK_MSR_ID(25, "mod_Tsin_A_CLK_IN"),
>> +     CLK_MSR_ID(26, "exit_Tsin_B_CLK_IN"),
> 
> [Severity: Low]
> Does this string contain a typo? The name "exit_Tsin_B_CLK_IN" is exported to
> userspace via debugfs.
> 
> In similar SoC definitions like clk_msr_s6, the corresponding ID 26 is named
> "ext_Tsin_B_CLK_IN", likely standing for external. Using "exit" here instead
> of "ext" could confuse users or break userspace scripts expecting consistent
> naming across SoCs.
> 

and rename "exit_Tsin_B_CLK_IN" to "ext_Tsin_B_CLK_IN".

>> +     CLK_MSR_ID(27, "u3p2pll1_0_clk_div16"),
> [ ... ]
> 
> --
> Sashiko AI review · https://sashiko.dev/#/patchset/20260911-more-socs-to-support-clk_measure-v1-0-940e269aa52f@amlogic.com?part=3

-- 
Best regards,
Chuan


_______________________________________________
linux-amlogic mailing list
linux-amlogic@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-amlogic

  reply	other threads:[~2026-09-14  3:00 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-11  8:28 [PATCH 00/10] soc: amlogic: clk-measure: Add support for more SoCs Chuan Liu via B4 Relay
2026-09-11  8:28 ` Chuan Liu
2026-09-11  8:28 ` Chuan Liu via B4 Relay
2026-09-11  8:28 ` [PATCH 01/10] dt-bindings: soc: amlogic: Add compatible to support " Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay
2026-09-13  9:03   ` Krzysztof Kozlowski
2026-09-13  9:03     ` Krzysztof Kozlowski
2026-09-14  2:50     ` Chuan Liu
2026-09-14  2:50       ` Chuan Liu
2026-09-11  8:28 ` [PATCH 02/10] soc: amlogic: clk-measure: Support more measurement channels Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay
2026-09-11  8:28 ` [PATCH 03/10] soc: amlogic: clk-measure: Add support for more SoCs Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay
2026-09-11  8:37   ` sashiko-bot
2026-09-11  8:37     ` sashiko-bot
2026-09-14  3:00     ` Chuan Liu [this message]
2026-09-14  3:00       ` Chuan Liu
2026-09-11  8:28 ` [PATCH 04/10] soc: amlogic: clk-measure: Optimize CLK_MSR_ID to reduce memory usage Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay
2026-09-11  8:28 ` [PATCH 05/10] arm64: dts: amlogic: a5: Add clk-measure controller node Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay
2026-09-11  8:28 ` [PATCH 06/10] arm64: dts: amlogic: a4: " Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay
2026-09-11  8:28 ` [PATCH 07/10] arm64: dts: amlogic: s7: " Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay
2026-09-11  8:28 ` [PATCH 08/10] arm64: dts: amlogic: s7d: " Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay
2026-09-11  8:28 ` [PATCH 09/10] arm64: dts: amlogic: s6: " Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay
2026-09-11  8:28 ` [PATCH 10/10] arm64: dts: amlogic: a9: " Chuan Liu via B4 Relay
2026-09-11  8:28   ` Chuan Liu
2026-09-11  8:28   ` Chuan Liu via B4 Relay

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=86ae1163-1507-4b4f-8d21-87fd2492a833@amlogic.com \
    --to=chuan.liu@amlogic.com \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-amlogic@lists.infradead.org \
    --cc=neil.armstrong@linaro.org \
    --cc=robh@kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.